Jump to content

EET 1.0 Release Candidate 12 up on GitHub


Recommended Posts

can't be if you can run the game after installing clean EET. For situations like this I've posted this bat that may be able to find (or not) the issue with game crashing on start-up: http://gibberlings3.net/forums/index.php?showtopic=28822&page=4&do=findComment&comment=254333

All I know is that:

- any mod installed with ANSI encoded strings = crash

- messed up GUI code = crash

Edited by K4thos
Link to post

Noticed on the Github that Almateria's Restoration is now under expert, what happen with that mod?

that's a question to BWS guys (if by 'under expert' you mean BWS mods recommendations). I have no idea what is the reasoning behind this change.

Edited by K4thos
Link to post

 

Noticed on the Github that Almateria's Restoration is now under expert, what happen with that mod?

that's a question to BWS guys (if by 'under expert' you mean BWS mods recommendations). I have no idea what is the reasoning behind this change.

 

If you look at this and the author's answer/refusal to fix it, you know http://www.shsforums.net/topic/56026-almaterias-restoration-project/page-22?do=findComment&comment=594937.

Link to post

New version up on Github:

Version 1.0 Release Candidate 9.1

  • fixed regression with Imoen not spawning at the end of SoD if she hasn't been in party during BG1 transition (hotfix for previous versions: http://gibberlings3.net/forums/index.php?showtopic=28580&page=2&do=findComment&comment=254649)
  • fixed CLASTEXT.2DA content importation (missing kit description in mod added kits installed on BG:EE)
  • fixed typo in TRA files: Sacred Groove -> Sacred Grove
  • improved automatic code for cloning/deleting opcode 267 spell effect
  • title, campain icon, logo BAM files expanded with IWD-in-EET images
  • cosmetic change to make comparing code between EET family mods easier (%MOD_FOLDER% usage)
Edited by K4thos
Link to post

I know I'm a bit late to the party but ...

Welcome back K4thos!!!!

We missed ya, bud :)

 

From what I've been seeing from Beamdog, they're planning to patch BG2:EE and IWD:EE with the next set of patches from PST:EE this fall. Looking forward to shaking out IWD in EET after that. Now I need to get with the program and finish up my full EET playthrough from many months ago. Darn those "other" games that occasionally grab my interest...

Link to post

Sort of ...

.. I think ..

 

From what I've seen from Beamdog, they made more improvements to the EE engine for PSTEE that they will be bringing to the rest of the EE games -- first BG1&2EE, and then IWD:EE.

 

Assuming I interpreted this blog post correctly.

Link to post

Apologies if I'm posting in the wrong place, but I'm getting an error trying to install the Core portion of the mod on my Mac:

 

 

205 PETRIFIED appended to SPECIFIC.IDS

Appending to files ...

251 SPECTACLES_QUEST appended to SPECIFIC.IDS

Patching BG2:EE TLK files

SET_STRING 211898 out of range 0 -- 103214

Stopping installation because of error.

Stopping installation because of error.

Stopping installation because of error.

ERROR Installing [Core EET (game importation)], rolling back to previous state

Will uninstall 2404 files for [EET_CORE.TP2] component 0.

Uninstalled 2404 files for [EET_CORE.TP2] component 0.

ERROR: Failure("SET_STRING out of range")

PLEASE email the file SETUP-EET_CORE.DEBUG to K4thos (swit)

Using Language [English]

Install Component [Core EET (game importation)]?

nstall, or [N]ot Install or [Q]uit? Q

[./lang/en_us/dialog.tlk] created, 103214 string entries

NOT INSTALLED DUE TO ERRORS Core EET (game importation)

Press ENTER to exit.

 

I'd really appreciate a response, or - if I'm posting in the wrong portion of the forum - being redirected to where I should be posting this. I found a similar error earlier in this thread, but following the suggestion there - deleting dialog.tlk, and renaming dialog.bak to .tlk didn't help, exact same error.

Link to post

Dziugas, must be OS related. It failed to merge TLK files. The good news is that I've managed to successfully use STRING_SET_RANGE to append BG:EE strings on top of BG2:EE tlk with the newest weidu, so outside merging using terminal/command line is no longer needed. I need to test if uninstallation etc. works, and if there won't be problems new version will be up on Github in about an hour. There is huge chance that it will solve your problems since the new implementation is no longer dependent on OS specific stuff for TLK merging.

Link to post

Version 1.0 Release Candidate 9.2

  • less confusing installation - setup-EET_core.exe no longer used thanks to working STRING_SET_RANGE and NEXT_STRREF functionality in latest WeiDU (this means that from now on SETUP-EET.DEBUG is the file that should be used for reporting issues)
  • uninstallation and re-installation should be more reliable now (tested several times on the same game without any problems)
  • fixed AttackedThieves BG1 variable not being remapped in previous versions
  • fixed strref references to BG1 movie files (movies menu)
  • starting game in ToB will show Sacred Grove icon on map right away
  • improvements in column appending code

-------------

 

Thanks in advance for updating BWS. Dziugas, let us know if this update fixes your problem.

 

The new implementation needs to COPY BG:EE TLK file in order to read 0xa offset (total amount of strings). It's possible that weidu won't be able to do it if BG:EE TLK is very large (there is COPY size limit, although there's still about 8 MB left when it comes to vanilla file). If someone will report that in heavily modded BG:EE the size is reached we will switch to Lua code in order to read this value.

Edited by K4thos
Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...