Jump to content

EET v13.4 released


Recommended Posts

Bug report by @Graion Dilach here but as it's a bug in the default EE UI it can be interesting to fix it in EET.

The 2.6 patch adds new voices (AoN) and Beamdog uses a custom sorting function (compareCustomSound) in the UI.menu file to put these voices at the end of the list. But this function is buggy (invalid order function for sorting). They didn't notice this as the bug only happens with EET.

I reimplement the function in LeUI like this (you can use this in EET if you want):

function compareCustomSound(s1, s2)
	-- DEFAULT, then normal alphabetically, then AoN alphabetically (result must be strictly less than)
	if (s1.sound == "DEFAULT" and s2.sound ~= "DEFAULT") then
		return true
	elseif (s2.sound == "DEFAULT" and s1.sound ~= "DEFAULT") then
		return false
	elseif (string.sub(s1.sound, 1, 4) == "BDTP" and string.sub(s2.sound, 1, 4) ~= "BDTP") then
		return false;
	elseif (string.sub(s2.sound, 1, 4) == "BDTP" and string.sub(s1.sound, 1, 4) ~= "BDTP") then
		return true;
	end
	return s1.sound < s2.sound
end

 

Link to comment

Installation Bug:  (edit: well, my fault obviously...)

Including SOA compatibility patches
Appending to files ...
[EET/tbl/map_eet_areas.tbl] loaded, 10942 bytes
EET/tbl/map_eet_areas.tbl copied to EET/backup/0/map_eet_areas.tbl, 10942 bytes
Appended text to [EET/tbl/map_eet_areas.tbl]
[EET/temp/WeiDU.log] loaded, 1502 bytes
ERROR: cannot convert %col2% or %%col2%% to an integer
ERROR: [EET/tbl/compatibility.tbl] -> [EET/tbl/compatibility.tbl] Patching Failed (COPY) (Failure("Int32.of_string"))
Stopping installation because of error.
Stopping installation because of error.

Debug can't be attached due to size limit. 

Another interessting thing after the installation stopped:

ERROR Installing [EET core (resource importation)], rolling back to previous state
Unable to Unlink [EET/backup/0/OTHER.0]: Unix.Unix_error(1, "unlink", "EET/backup/0/OTHER.0")
WARNING: Cannot uninstall STRING_SET #270672, out of range 0 -- 103584
WARNING: Cannot uninstall STRING_SET #270671, out of range 0 -- 103584

(and many more warnings of the same type)

I used 13.4 on 2.6.6. But I used WeiDU 2.47 and not the one provided with the EET. Maybe that is the reason for the problem. I'll check for that. But anyhow I guess the error is interessting by itself as it happened for the SoA compatibility part... 

edit: used the provided setup-EET.exe which says it is a 2.47 too but has a smaller size. same problem, no changes.

next edit: was my fault: I modified the compatibility.tbl but in a wrong way (missed a "0"):

WALAHNAN 0           //Walahnan NPC
BRISTLELICK            //Bristlelick NPC

Edited by maus
update
Link to comment

Error message when using EET_end (2.6.6 and 13.4)

ERROR: [PDIALOG.2da] -> [override/PDIALOG.2da] Patching Failed (COPY) (Failure("ERROR: READ_2DA_ENTRY_FORMER failed on variable %pdialog_45_5%"))
Stopping installation because of error.
ERROR: [CAMPAIGN.2DA] -> [.../CAMPAIGN.2DA] Patching Failed (COPY) (Failure("ERROR: READ_2DA_ENTRY_FORMER failed on variable %pdialog_45_5%"))
Stopping installation because of error.

ERROR Installing [EET end (last mod in install order) -> Standard installation], rolling back to previous state
Will uninstall   1 files for [EET_END/EET_END.TP2] component 0.
Uninstalled      1 files for [EET_END/EET_END.TP2] component 0.
ERROR: Failure("ERROR: READ_2DA_ENTRY_FORMER failed on variable %pdialog_45_5%")
PLEASE email the file SETUP-EET_END.DEBUG to K4thos (swit)
Using Language [English]

 

For a second try the error messages are:

Preparing ALORAJ.dlg source file (38 states starting from 0)
Copying and patching 1 file ...
ERROR: cannot convert num_states_MINSCJ or %num_states_MINSCJ% to an integer
ERROR: [MINSCJ_.dlg] -> [EET/temp/append/dlg/MINSCJ_.d] Patching Failed (COPY) (Not_found)
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [EET end (last mod in install order) -> Standard installation], rolling back to previous state
Will uninstall   9 files for [EET_END/EET_END.TP2] component 0.
Uninstalled      9 files for [EET_END/EET_END.TP2] component 0.
ERROR: Not_found
PLEASE email the file SETUP-EET_END.DEBUG to K4thos (swit)
Using Language [English]

This is strange. Third run without changing anything passed with SUCCESSFUL, no Warnings.

 

Link to comment

For the installation mentioned above: that was crap, Kits totally destroyed and very strange. 

For the next try I got the same first error message about the pdialog.2DA (attached). I eliminated all entries from BG1 Mods which are only providing a DV but no dialog-files (glam and thalan). That helped to avoid this first error message which was reproducable in the second installation. 

PDIALOG.2DA

Link to comment

Could you share a mod list and installation order instead of randomly throwing errors on obviously custom-edited files? Why do you need to edit the compatibility list? What are you actually trying to do?

Edited by Graion Dilach
Link to comment

Well, the idea is to make an EET installation. In detail: I have been doing several of EET installations (more than 20, about 10 successful). This time I'm trying to make 2.6.x version for the first time (and with WeiDU 2.47). In the end it is trying to check what works and whar does not. For example: with former installations sometimes I had problems when I was using GlamPack (which has not been updated since), sometimes not. A full stop like this time was somehow new. So in the end the mod is not really compatible with EET while adding DVs without dialogfile in the pdialog.2DA 

To edit the compatibility list is necessary if you install Mods in BG1 not listed yet, otherwise EET won't start... 

WeiDU logs for the first attempt are attached below. 

The second installation crashed during a reinstall of EET_End. But that was due to hardware issues. The mods have been more or less the same (HTaM 3.4 instead of 3.3 and small changes in the order of installation). 

WeiDU.txt WeiDU-BGEE.txt

Link to comment

Oh, I completely overlooked Lava's new NPCs lacking EET compatibility (and yet I looked at them when I started campaigning for mod NPCs having correct voicesets in BGEE). I'm not sure what his plans are regarding that - this wasn't brought up in Walahnan's topic s atleast. I'd skip those myself for now. I've never played with Glam's NPCs myself.

Edited by Graion Dilach
Link to comment
10 minutes ago, jastey said:

As far as I know, @Lava will make his mods EET compatible when they are done and tested, just not while they are still in development.

Yeah, and this does also include traification. I can imagine, with all the mods he created during these years, reaching to each of the translators to update translation every time he adds/changes something would be a pain. Besides, some translators can be already unavailable by now.

Link to comment

I will be looking for someone to help with making some of my mods available for EET, but Walahnan is not on that list just yet. I'm not even sure if more than 3-4 people played the mod from OC to the end of SoD.

I think it would be ok to have Verr BG1, White and Bristle to get newest EET compatibility, but as I do not use EET myself, that would need to be handled by someone familiar with such matters, but as always - always send me PM first: I can tell you which are in my opinion ready and are not getting any major content-oriented updates. I know it requires delicate work and people that help always get included in the readme.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...