Jump to content
Demivrgvs

Revised SCS

Recommended Posts

I've completely missed this revised mod. Gonna have to re install everything coz it seems essential to me. I'll wait for SRv4b14 then.

 

BTW Kreso you've specified that it should work fine with BWP. I don't use it, just the Big World Fixpack, so that should I launch this one without your mod and then unzip it after ?

 

Besides is it compatible with atweaks as it modifies a lot ennemies AI.

Share this post


Link to post

I don't know about BWfixpack. I've included it's fixes already, so just extract revised SCS after BWFixpack. aTweaks should be compatible, more or less. You won't get revised targeting from aTweaks demons and there are some minor inconsistencies, but it shouldn't matter much.

Share this post


Link to post

Kreso, did you code this in a way that the behavioural changes are only active if SR is installed? Does this version of the mod behave any differently from v30 on non-SR installs?

No on both accounts... I didn't have the time to do it in such a manner, altough it could be possible I reckon. My main gripe against it is that I couldn't get the v30 option of using a custom library file to work, it should be very easy (a matter of adding one line) but it doesn't work. And I need that file. The code governing those is beyond my comprehension, and I don't even know where to start looking for the bug preventing this to work.

This version installs and works the same as SCS. You can tweak it (i.e. dragon's HP, slowcast etc.) via ini file just like the original.

 

I've just noticed this and that's a bummer. I think it's worth implementing it the way to work on both vanilla games and SR installations. What is the library file you've mentioned? More details where the problem lays and how you tried to implement it would be useful too. Maybe I will be able to help with fixing/changing it.

Edited by K4thos

Share this post


Link to post

I also think I should do this. Gimme a week or two. It's fairly straightforward to do (I've forgotten that SCS actually has seperate libs for non-revision and revison installs, and few years ago DavidW explained how this works), it's just time-consuming. I'll need to:

- go through all scripts once again

- add seperate check for each casting block (IsDemivrgs), !(IsDemivrgvs)

- add all I've changed to not_SR libraray code

 

Two weeks tops.

 

As for the problem (with these seperate libs it's not a problem anymore) : SCS as of v30 added an option to write your own library file, where triggers are stored. It's in .INI file.

library_override none

 

Now, instead of "none" you could write whatever you want and SCS should take data from that file. However, last I tried it, it did nothing. It still used it's own library.

With SR/IR there are seperate libs I'll use.

Share this post


Link to post

I just wanted to pop in to say that I am excited with this modification and the possibilities it represents. Thanks for your work on tweaking the AI in this manner. It would be a large undertaking, but I share kreso's enthusiasm for the possibility of having an AI that utilizes the KR abilities as well.

Share this post


Link to post

Hey guys

New here.

tried a BGT install years ago on an old setup, it proved too much of an effort.

 

This time im tryin'it anew with EET.

 

However:

 

ERROR: cannot convert macro_spell or %macro_spell% to an integer
ERROR: [stratagems_external/workspace/scroll_map.txt] -> [stratagems_external/workspace] Patching Failed (COPY) (Not_found)
Stopping installation because of error.
ERROR Installing [initialise mod (all other components require this)], rolling back to previous state
This is with the revised version

Share this post


Link to post

I'm sorry, but I can't reproduce this error. I've installed this on EET and works fine. I'll upload a new version (it will work fine for both SR and non-SR installs) in a week or so; maybe that will help (no guarantees).

Share this post


Link to post

Hi,

 

I got a parse error when trying to install this revised Sword Coast Stratagems on EET. Details (and debug files) here. Is this a bug, or did I do something wrong?

 

Thanks,

Willard

Share this post


Link to post

Hi,

 

I got a parse error when trying to install this revised Sword Coast Stratagems on EET. Details (and debug files) here. Is this a bug, or did I do something wrong?

 

I've had same problem (using regular Stratagems). Seems to have fixed itself however, I just re-tried to install and it worked. Up until "Smarter General AI", then it botches up with "not found" line I have no idea why.

Is it possible that someone (who knows github usage and similar stuff better than me) uploads a fully fixed SCSv30 somewhere that doesn't require two sets of different fixes from both Alienquake & EET compat. by K4thos and installs on EET w/o issues? I'm not talking about SR-revised version, just the regular SCS.

Share this post


Link to post

I've had same problem (using regular Stratagems). Seems to have fixed itself however, I just re-tried to install and it worked. Up until "Smarter General AI", then it botches up with "not found" line I have no idea why.

Is it possible that someone (who knows github usage and similar stuff better than me) uploads a fully fixed SCSv30 somewhere that doesn't require two sets of different fixes from both Alienquake & EET compat. by K4thos and installs on EET w/o issues? I'm not talking about SR-revised version, just the regular SCS.

Kreso: I've updated the BiG World Fixpack patches for SCS v30 to include K4thos' EET changes. Therefore, for non-Spell-Revisions installations (whether EET or not), the BiG World Fixpack is all you need.
I've further added to the Big World Fixpack an additional set of patches that will only be applied if the mod folder "spell_rev" is seen; these patches merge all of your "Revised SCS" changes with K4thos' and the Fixpack's.
Therefore, for Spell Revisions installations (whether EET or not), the BiG World Fixpack is also all you need.
(N.B. I also looked at subtledoctor's SCS hotfixes on the Beamdog forum and there is nothing there that wasn't covered between yours and K4thos' changes. The BiG World Fixpack now includes all patches for SCS to date.)
I've reviewed all of the areas of overlap between your changes, K4thos' changes, and the original Fixpack changes, and I think everything's OK, except...
... It seems you deleted two lines (comparing to original v30) from the bottom of stratagems\tactical_bg1\c2end.tpa (Mulahey). Was this intentional? I didn't see anything mentioned about it in this thread.
    LAF ssl_to_bcs STR_VAR script=helpmul location=~tactical_bg1/ssl~ rename_to= ~%tutu_var%helpmul~ END
    LAF extend_area_script STR_VAR area= ~%NashkelMines_MulaheysCave%~ bottom=mularea location=ssl ssl=yes END
FYI, for your project to make a single version of SCS that works with-or-without Spell Revisions, you might find it helpful to look at the new patches here: these reflect all of the changes you made.
Edited by agb1

Share this post


Link to post

 

I've reviewed all of the areas of overlap between your changes, K4thos' changes, and the original Fixpack changes, and I think everything's OK, except...
... It seems you deleted two lines (comparing to original v30) from the bottom of stratagems\tactical_bg1\c2end.tpa (Mulahey). Was this intentional? I didn't see anything mentioned about it in this thread.
    LAF ssl_to_bcs STR_VAR script=helpmul location=~tactical_bg1/ssl~ rename_to= ~%tutu_var%helpmul~ END
    LAF extend_area_script STR_VAR area= ~%NashkelMines_MulaheysCave%~ bottom=mularea location=ssl ssl=yes END

 

And that's why Mulahey battle doesn't work properly on my install :spanking: . No, it wasn't intentional.

 

I'll check out the link later, I've got a horrible hangover.

Share this post


Link to post

SCS for SR (or viceversa)

What might one expect from this dowload?

Few years ago when I noticed that on SR+SCS installs some spells were misused by AI. Since SCS's main concept is "don't do anything stupid" this bugged me a lot. So I decided to change it. This mod is a compilation of my own tweaks I used in numerous No-Reload games.

Most of the changes are found in Demi's first post. I'll go into how this affects gameplay, since with newest SR it will differ from ur usual SCS experience. BG1 part may not be so affected, but BG2 is a much different experience than before.

 

The biggest two changes are

 

1) Dispelling Screen. This tweak probably changes gamplay the most. It's a substitute for the uber-cheese SI:Abj (fwiw, Spell Immunity in PnP worked by absorbing a single spell, and then dissapearing). The difference between Dispel Screen and SI:Abj is that SR makes Dispel Screen work much more like it's PnP counterpart. It will now absorb a dispel attempt (by "dispel attempt" I mean anything that dispels - Carsomyr, Dispel Arrow, Anti-magic ray and similar) or Breach, then dissapear. As a balancing factor, the spell now has AoE similar to Protection from Evil, so even your fighters can enjoy beeing buffed bit longer.

AI will use Dispel Magic and Breach against it to bring it down. As in-game effect, this will make early BG2 a bit easier, it will make late BG2 a bit harder, and it will make ToB a living hell for your mages. :D

If you're enjoying vanilla mage omnipotence, this change you will not enjoy. With ToB Demons using Dispel at will you'll see that mages are no longer as overpowering as they used to be. Dispelling Screen *always* gets removed, regardless of dispel level check.

You'll want a balanced party to play SR/SCS game now. Fwiw, my longest no-reload run using this ended in ToB, Sendai enclave Lich Odamaron.

Anybody finishing this battle on this install w/o cheese deserves a medal. :rolleyes:

 

Hey kreso -

 

I was thinking about installing Sword Coast Strategems with your SR fixes, however the bolded part worries me a bit. I am exclusively a solo player and if your modifications force people to play in a party, I must say I am afraid to install it!

 

By the way, good job on working on this and providing us with these modifications, and the same extend to those who worked on SCS and SR.

 

Since I have SR installed but I play solo, should I install this version or the default SCS? I want to play solo though, and I just hope I can actually complete the game with a solo mage! Is it still possible?

 

Thanks for your time!

 

Dax

Share this post


Link to post

If you are using SR, you definitely want Kreso's version. Without it, the SCS mages are clueless about SR's changes and the reduced difficulty reflects the AI's attempts to cast spells that don't work as expected. You can always use the in-game difficulty setting to make it a bit easier for a certain encounter if you get stuck, but having mages actually use SR's spells intelligently is much better in my opinion!

 

Whichever version of SCS you want to use, I recommend applying the Big World Fixpack before running the installer. There are a handful of community patches that aren't in Kreso's version, and the Fixpack will add them for you.

 

Also, I've updated the Fixpack to restore the two lines of code accidentally removed from the Mulahey encounter, so here's hoping that will work correctly too!

Share this post


Link to post

Since I have SR installed but I play solo, should I install this version or the default SCS? I want to play solo though, and I just hope I can actually complete the game with a solo mage! Is it still possible?

Frankly, it doesn't really matter much if you use this SCS or the original version. With latest SR you won't solo a mage through ToB, sorry.

My guess is you'd have a better chance with a barbarian/some paladin, but it will be suffering experience throughout the game. :undecided:

 

P.S.

Here are some more toughts about it.

Edited by kreso

Share this post


Link to post
Guest
This topic is now closed to further replies.

×