Jump to content

GOG BG1 & BG2 install on fresh or upgraded RetroPie 4.1


Recommended Posts

Here is my situation. I have looked at the few results online, but have hit a wall at getting a GOG Baldur’s Gate (BG1) and BG2 installed on a RPi 3 Model B on an upgraded and clean build of RetroPie v4.1. I have tried default and modified BG config files, but the error still occurs at the exact same spot, regardless of GOG source OS (Mac and Win) and version of RetroPie. To me, it implies that the GOG versions of BG1 and BG2 are not compatible with GemRB since both versions hiccup at the exact same spot. I have the GemRB.logs and screenshots of the RPi file directories for BG1 and BG2 from Win and Mac sources (if necessary). Looks like it hangs on the same nonexistent ’fonts.2da’ file in their respective directory.

BG1 & BG2 v. (GOG-7) Windows
BG1 (GOG-15) & BG2 (GOG-12) v. Mac
For BG1, Win and Mac GOG versions:
(ResourceManager/WARNING): Couldn't find 'INITIALS'... Tried INITIALS.ttf INITIALS.bam
(Core/FATAL): Unable to load font resource: INITIALS for ResRef INITIALS (check fonts.2da)
For BG2 Win and Mac GOG versions:
(ResourceManager/WARNING): Couldn't find 'NUMBER2'... Tried NUMBER2.ttf NUMBER2.bam
(Core/FATAL): Unable to load font resource: NUMBER2 for ResRef NUMBER2 (check fonts.2da)
Any thoughts would be appreciated.
Link to comment

First, GOG versions are fine. The font files are stored in DATA/GUIFONT.BIF (lowercase) in bg2. BUT, you are trying with the enhanced editions, which we do not support yet (no real incentive). They use normal fonts directly, ditching the old bitmap ones — hence the errors. The mention of fonts.2da is where our version is configurable.


I think you got the classic versions for free a while ago — just check your account.

Link to comment

Thanks lynx. I thought I was installing it wrong. I looked around GOG's support site for the classic version, but could not find it. It's all good since I can run that on my laptop. I just bought some disks off of eBay for my RetroPie build. I'll know in a few days if that solves the problem.


Thanks again!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...