Jump to content

Bug Thread


Scourge

Recommended Posts

I don't know if this has been reported or no, but in Minsc.bsc and Valygar.bsc the cre file name is used where the dv (rspirit01) should be used, like in See("RSPIRIT1") in Minsc, so he won't start his dialogue and in Valygar Dead("RSPIRIT1") et al.

Link to comment

I don’t know if this problem is related to the NPC Strongholds mod or not, but I had a problem in the Umar Hills while managing a ranger's stronghold. Forest spirit Mairyn gave the task to solve the problem with Lord Igen, but after that refuses to speak with me. She replies that she will speak only with the ranger. My protagonist is a ranger, but she does not want to talk to him. And to complete this quest becomes impossible. If Valigar owns the stronghold - the result is the same, Mairyn refuses to speak with him and answers that she will only speak with the ranger.

Link to comment
Guest Rinpoo

Mairya the forest spirit, after finishing the necklace fetch quest.  Refuses to acknowledge my Ranger/Cleric as the ranger despite me being accepted for the role.  Aerie was accepted as the Cleric, so that worked fine.  She keeps saying she will "only talk to the ranger," and she says that to everyone but Minsc, who gets no dialog at all.

The Mayer also refuses to open dialog with me at all just as Minsc with the spirit, so there is nothing I can do to continue the ranger quest.  I really do not know what to do.  This bug has me stuck and I have no idea how to fix it.

Running on 8.1

Link to comment

Not sure if posted before:

I rescued Haer'Dalis and he was made the owner of the theatre. Then I removed him from the party for a while, to make place for Valygar for the Planar Sphere quest. After finishing it and re-replacing him with Haer'Dalis, I talked with the playmaker. He mentioned the play being a flop and the stronghold quest ended, even though it hardly ever started. I suppose it's due to kicking HD out of the party, but I can't be sure (no saves before it).

Link to comment
Guest Connelly

I had a problem in an ETT installation. For reference, any other mods that I got installed and I could think can be causing conflicts are Expanded Thief Stronghold, Alternatives and AllThingsMazzy.

After giving the thief guild to Imoen, the lieutenants didn't react to her, only recognizing Charname as guildmaster. I had the idea of checking their dialogue files in Near Infinity, and found out all of them retained their vanilla dlg files. I had to go one by one changing their related files to the new ones introduced by the mod. Now they react to Imoen, although I also had to recreate Brannel (the door guard) with a Ctrl+Y and a CreateCreature command for his changes to stick. Ama seems to have her correct dialogue, but the global values that advance her lines do not seem to trigger correctly. Later, I couldn't advance with the pickpockets issue until I CreateCreature each of them and started the KishSpawnedPickpockets variable.

Once the thief war starts, Renal didn't speak to me when I got to his room, and I had to CreateCreature him outside in the streets so he could talk with Imoen; this might have been a conflict with the AllThingsMazzy mod, as it has its own quest to eliminate the Shadow Thieves where Amnian soldiers support you. And after killing Aran, I had to reduce the KishThiefWar variable from 3 to 2, as Imoen was stuttering trying to speak her line after killing Aran; that line had a very particular trigger range of higher than 0 and lesser than 3, and I'm not completely sure but I think there was a prior moment where KishThiefWar is supposed to be at 3.

My main suspect for a possible conflict is Expanded Thief Stronghold. It was installed before NPC Strongholds, but it's possible that it changed the creature files to different ones than what this mod looks for. Although I searched for any mention of it in this forum, in case someone else already noticed anything, and I found nothing.

I also had problems with the de'Arnise keep and the ranger cabin. As others said, Mairyn just plain ignores Minsc, although I can't see what's wrong there. Nalia gets a "no valid reply or link" in her dialogue just before proposing you or a party member the idea of taking the keep. I had to do a dirty edit on her dialogue triggers that would force her to directly offer the keep to Mazzy. The Prelate also didn't react to Keldorn after rescuing Garren's son; far as I could tell, the variables needed to trigger his talk about starting the paladin quests didn't get initialized.

The theater with Haer'Dalis, the druid groove with Jaheira, and the Lathander temple with Aerie worked fine, although I might have gotten the impression of the timers for new tasks being off; not important though. Haven't tried the rest.

Link to comment
Guest energisedcamel

Hello! There seems to be a few bugs with Minsc and the ranger stronghold, the biggest of which is a looping dialogue. Minsc keeps noticing Delon, but no one appears, so the dialogue ends. Any idea how I can fix this?

Link to comment
Guest energisedcamel

Just to clarify, it is the line @1060 = ~Delon! What do you need from Minsc and Boo?~

I had a few issues before (Mairya not appearing, Madulf not appearing during the orog attack, Tombelthen appearing again in the Umar Hills, not at the ruined temple, etc.) but none of these were gamebreaking. I'm really hoping I don't have to uninstall the mod to continue, because it's one of my all-time favourite!

Link to comment
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...