Jump to content

Banters showing as invalid


Recommended Posts

Running a clean install of bg1 EE (save for a portrait pack but that is beside the point) ,I have mod merge(since I also have SOD), the bg1 npc project installs without issue, but when I go ingame and either get a banter or try to initiate one the text window only shows "invalid 94301" or some other string of numbers that I believe refers to the entry on the Dialogue.tlk file. I've tried it with both new games and existing saves. I'm not sure where I went wrong, I've tried reinstalling the Npcpack but can't seem to get the banters to show an actual text string instead of just invalid number strings.


Any help is appreciated,

Edited by Viraku
Link to post

Which game language did you install the mod to? I assume it's a different one than the language you are playing the game in. Have a look into the weidu.conf. If the language directly listed there is a different one than you want to play the game in, delete the weidu.conf in your BG:EE game folder and reinstall the BG1NPC Project mod. The installer should ask for the game language then.

Edited by jastey
Link to post

Playing the game in english and the language listed in the weidu.conf is en_us.

and for clarification an example of specefically what happens is letsay at the beginning of the game, right after Imoen joins, I have the PC manually start dialogue with her, the textbox just says "INvalid:94293" and then gives me 7 responses "1:INvalid 94294", "2:Invalid 94296", "3:Invalid: 94297" and so on. If I walk over to where Gorion encountered the armored figure, Imoen starts a dialogue that just shows "INvalid: 82840" and my responses are also just invalid+number.

Vanilla dialogue works fine, such as conversations with IMoen or Khalid and Jahiera about joining, et cetera.

Edited by Viraku
Link to post

I was pretty sure I had uninstalled the npc pack before I did modmerge(as the game wouldn't run with npcpack installed otherwise) I didn't get any errors when it installed ( or I failed to notice them). But upon checking the dlc folder I see Sod-dlc.zip has not been renamed. should I manually rename it then?

Link to post

But upon checking the dlc folder I see Sod-dlc.zip has not been renamed. should I manually rename it then?

That would explain the issue, since the dialog.tlk file in the DLC .zip file will override the regular dialog.tlk file.


You could try renaming sod-dlc.zip to sod-dlc.disabled manually. If you continue to encounter problems, I'd suggest starting from a fresh install.

Link to post

Renamed the SOd-dlc manually to no effect, did a clean install of bg, and moved it out of the steamapps folder, modmerge was able to change the name of sod-dlc this time, installed the npc pack, booted it up from the new location and now it works. looks like the culprit was windows dislike of letting things in the programfiles folder where steam was defaulting to.

Thank you again for all the help!

Link to post
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...