Jump to content

EETLauncher


Recommended Posts

Hi, I created launcher for EET:

image.png.9c269a3d5f1f5440ee4ae21147ee76c9.png

Usage:

  • put it into game folder with EET installation

Features:

  • execute baldur.exe from BG2EE directory if EET installation is detected
  • open EET readme file
  • open EET forum
  • open EET webpage
  • open correct EET baldur.lua
  • change EET GUI
     
It needs new logo and application icon with "Enhanced Edition Trilogy" text. Any other feedback is welcome.

Download ( only for Windows 7, 8.1, 10 , NET Framework 4 or higher required )

Changelog:

1.6.0 - added "Mods" link

1.5.0 - rewrite using WPF

1.4.0 - rewrite using Windows Forms

1.3.0 - responsive "Change GUI to ..." operation

1.2.0 - added ability to change EET GUI

1.1.0 - added background, custom font, mouse hover reaction, "SETTINGS" button

1.0.0 - first version

Edited by AL|EN
Link to comment

Any details available what it is good for or how to use it?

 

When I try to run it, my Avira blocks it and deletes it.

When I try to run it without Avira, it tells me I need net framework 3.0 or better. Since I have windows 10, this makes no sense, since it is included already?

Link to comment

Thanks for feedback, It is really helpful. Virus detection is false positive. It's the same stupid thing as with many others AV's. Application is nothing more than 50 lines of Powershell Windows Forms code. I think that the problem leads in the way how the code is packed into .exe. I see what I can do about it but not now.

 

NET 3.0 requirements, I hopefully fixed it. Please redownload whole repository using new download link: https://github.com/ALIENQuake/EETLauncher/archive/master.zip

 

Usage: It's very simple application which execute baldur.exe from BG2EE directory if EET installation is detected, opens EET readme file, opens webpage with a link to this forum.

 

( Windows 10 has only 4.0+ enabled by default, when you run application which require NET <4.0, it offers you a option to enable build-in legacy version )

Edited by ALIENQuake
Link to comment

Thanks for feedback, It is really helpful. Virus detection is false positive. It's the same stupid thing as with many others AV's. Application is nothing more than 50 lines of Powershell Windows Forms code. I think that the problem leads in the way how the code is packed into .exe. I see what I can do about it but not now.

 

NET 3.0 requirements, I hopefully fixed it. Please redownload whole repository using new download link: https://github.com/ALIENQuake/EETLauncher/archive/master.zip

 

Usage: It's very simple application which execute baldur.exe from BG2EE directory if EET installation is detected, opens EET readme file, opens webpage with a link to this forum.

 

( Windows 10 has only 4.0+ enabled by default, when you run application which require NET <4.0, it offers you a option to enable build-in legacy version )

It works, I put the exe and the config file into BG2EE and it launches the game or opens the webpages.

Link to comment

1.2.0 - added ability to change EET GUI :happy:

I have the following issue

- EET_gui mod is installed and in use.

- I start your tool and go to Setting

- it shows SoD GUI in use and I select change to BG2

- The tool freezes. When I kill it in Taskmanager I can start the game from Baldur.exe and the GUI has been changed to BG2 indeed.

- when I try your tool again, it still shows me SoD GUI in use and offers me BG2 for change

 

I re-installed EET_Gui mod to repair.

Link to comment

Launcher is freezing because it execute EET_Gui mod with appropriate commandline switches for installing and uninstalling. If the installation/GUI change was sucesful, the "Current GUI" text will become green. If not, then red. I see what I can do about avoiding application freezing.

Edited by ALIENQuake
Link to comment

Launcher is freezing because it execute EET_Gui mod with appropriate commandline switches for installing and uninstalling. If the installation/GUI change was sucesful, the "Current GUI" text will become green. If not, then red. I see what I can do about avoiding application freezing.

I just dd another round of tests with your tool. It works now as described. I have no idea what failed on my earlier attempt. Maybe too many other things were running.

Anyway, sorry for the false alert.

Link to comment

1.3.0 - responsive "Change GUI to ..." operation

 

Application is no longer frozen/suspended during "Change GUI to ..." operation and the user will receive feedback of the operation status during execution

Edited by ALIENQuake
Link to comment

The new logo can be identical of the current one with "Enhanced Edition Trilogy" text. Or you own invention with BG1, SoD, BG2, ToB and IWD icons/logos combined. :beer:

Edited by ALIENQuake
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...