Jump to content

Ajantis BGII: Problems and Bug Reports


Recommended Posts

2 hours ago, Lauriel said:

And before @Jarno Mikkolajumps on this one about the debug file-none was produced because installation was aborted when these errors popped up.  He does keep one on one's toes. :)

So you are sure that no "setup-ajantisbg2.debug" file exists in the game directory you installed it into ? That you can open with Notepad...

Link to comment
Just now, Jarno Mikkola said:

So you are sure that no "setup-ajantisbg2.debug" file exists in the game directory you installed it into ? That you can open with Notepad...

I'm sure.  I patched it with the files it was looking for long ago and reinstalled.  I should have been more methodical, but I wasn't.

Link to comment

@Lauriel how exactly did you install the mod? Did you do it in several steps? Did you rearrange the components afterwards?

The tp2 contains the following with regard to Wilson:

////Give WILSON banter file as used in the Wilson chronicles ///

 PRINT ~Wilson detected - Wilson interdia.2da append - set Wilsons's banter file (BWILSON & BWILSO25)~
    APPEND ~interdia.2da~ ~WILSON BWILSON BWILSO25~
      <<<<<<<< ...inlined/BWILSON.d
      COMPILE ~...inlined/BWILSON.d~
      <<<<<<<< ...inlined/BWILSO25.d
      COMPILE ~...inlined/BWILSO25.d~

This should be fail-safe - but it is only done once, no matter how many times the optional mod components are re- or deinstalled afterwards. It seems that after installing the main component those Wilson dlg files somehow got lost on your BGII game, which is weird. Also, if you installed the mod there should be a DEBUG. If you have the mod installed and no DEBUG then something went very wrong I would say.

Link to comment

Hmm, so the inlined didn't work.  Very strange.  This isn't the only weirdness that's happened on my machine.  I'm wondering now if my anti-virus software is being intrusive.

8 minutes ago, jastey said:

If you have the mod installed and no DEBUG then something went very wrong I would say.

I have the debug now, but only after providing those files and moving on.  I don't have the debug files from when the error occurred. Like I said, I should have been more methodical, but wasn't.

Link to comment

OK. I do start to think there is something fishy with your install tbh. I managed to destroy several installs even without obvious things like aborted mod installations or starting several install windows at once etc. (which usually lead to a borked install right away). Still, at some point I noticed the game is done for with ressources in it that shouldn't be there or mixed up strings in the dialog.tlk etc. although no mod was installed. I usually start with a fresh game in those cases.

Link to comment

I started over with virus protection off and it went normally - though my dream sequences still aren't showing their respective BMPs.  They exist in the game, just not showing up.  Not pertinent to Ajantis, though.

8 minutes ago, jastey said:

I do start to think there is something fishy with your install tbh

I've started from scratch three times today.  This final time no issues with Ajantis.

Link to comment
Guest Krhoma

Thank you for creating this mod, I have enjoyed the writing! I am playing BGT, windows version v20 of the mod. I ran into a problem with the cyclic talks on the engaged path. The talks trigger normally until number 9, and then stop before Douglas can deliver the message about parents. I tried waiting in both city and outdoor areas to test whether 10a or 10 will trigger but nothing happens. Is there another condition except time between talks and location? If not, is there a way to force this part of the script via console?

I have also tried spawning Douglas with console, he successfully gives the message but no meeting triggers at the inn. I am not sure what other variable to try setting.

Link to comment

It might happen that the messenger spawns outside the visual rage but then doesn't manage to get to the group in time (or is stuck behind a door ect.) The EEs are worse than the clasic games in this regard, I should change the messenger's arrival to something near the group to prevent this. The messenger should spawn for Global("C#AjantisLoveTalk","GLOBAL",19) after the timer run if the group is in an accessible outdoor area (no mod areas considered).

If Global("C#AjantisLTWarten","GLOBAL",2) is at "2" and Global("C#AjantisLoveTalk","GLOBAL",19) at "19", spawning him via cheats and talking to him should make the romance proceed, though. Cheats would be C:CreateCreature("C#AJDOUG")

After talking to the messenger, the variable Global("C#AjantisLoveTalk","GLOBAL",20) should be at "20" and the variable Global("C#AjantisIlvastarrMeeting","GLOBAL",1) should be at "1". This will lead to Ajantis' parents being in the Mithrest Inn - if Keldorn's quest to confront Sir William is not active.

Link to comment
Guest Krhoma

Thank you for a quick response! I have set the LTWarten variable to 2, lovetalk was already at 19, and spawned Douglas. He delivered the message. I visited the inn but no parents were present. I then exited the inn, set the LoveTalk to 20 and IlvastarrMeeting to 1 via console and entered the inn again (both of these were already with correct values if I check the save game with Keeper, but I tried via console anyway). No parents appeared. Keldorn quest has already been completed. My BGT is using the classic version of BG, not EE, but not sure if that matters. Anything else I can try?


Link to comment

After talking ot Douglas, Global("C#AjantisLoveTalk","GLOBAL",20) and Global("C#AjantisIlvastarrMeeting","GLOBAL",1) should already be set.

27 minutes ago, Guest Krhoma said:

I visited the inn but no parents were present.

With the variables above, visiting Mithrest Inn ("AR0704") with Ajantis in group should lead to Ajantis starting a dialogue that his parents are there. This calls a cutscene where they are spawned and the dialogue with them will be triggered.

The consitions are the following ("Myself" being Ajantis):


/* Meet Lord and Lady Ilvastarr at Mithrest Inn AR0704: dialogue activation */
        !Exists("willia") //do not disturb Keldorn's Quest
    RESPONSE #100

You could check for the variables and make sure Player1 is detectable (no cloak of hiding etc.), that no mod changed the area code of the Mithrest Inn (you never know...), that Sir William isn't present as a left-over (or his corpse...). Checking the conditions is useful to identify a general problem with the romance now before it comes back to bite you later.

If all fails, you could just visit Mithrest Inn with Ajantis in group for the variables I listed at the beginning of this post and set C:SetGlobal("C#AjantisIlvastarrMeeting","GLOBAL",2) (for Ajantis and the PC both being able to talk and seeing each other) and it should start the meeting.

Link to comment
Guest Krhoma

I checked the variables and the only one that didn't match my status was "C#AjantisRomanceActive" which was set at 1 rather than 2. After changing it to 2, the cutscene happened as intended, thank you for the detailed guide! Now I can experience the in-laws rejection.....

Would the change to this variable mean that I missed on content while it was set at 1? I am curious if I should load to an earlier save, although so far nothing seemed unusual or missing.


Link to comment


I don't know how I'm supposed to use this table in library. I have blue powder and invisible rune and I'm stuck 2 hours now with this stupid table. Every time I'm trying to use it I've got message  "You browse the document for information about the items in your pack. The blue powder seems to be an adhesive that, if laid upon a surface, will form a durable coating. You see figures that show how to dredge a rough surface to obtain an even result. However, you have nothing that you want to use it on. This could make the invisible rune visible, but why would you do that? "

Am I missing something? I have those items in my backpack, I read note, speak with trapped paladin....

Link to comment

Yes, that should have happened. Bodhi should start talking about the PC's love like for the original romances.


Global("C#AjantisBodhiAbduction","GLOBAL",0) -> check variable for this situation
!Global("C#AjantisRomanceActive","GLOBAL",3) -> NOT 3, i.e. active romance

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...