Jump to content
Bartimaeus

SR Revised V1.1.0 (2019 February 5th)

Recommended Posts

Inquisitor Dispel Magic doesn't penetrate Minor Globe of Invulnerability.

Power is set to 3 instead of 0 like the mage and priest version.

 

Share this post


Link to post

@Kilgor

With the ini switch for making Dispel Magic penetrate Globes? Thanks for the spot, will fix.

@NdranC If it is incompatible, I do not know how - it is a very simple component that adds a few graphical files with unique filenames without too much avenue to go wrong.

I discovered the source of the problem for Ray Enfeeblement - it turns out, this particular spell actually has two different spells that both BG1 and BG2 use: SCRL6F and SCRLAI. Nothing to do with EET. I'll guess I'll just make a redundant copy over it.

Finally, I also discovered the issue with Zargal and his Whistling Swords. Well, sort of - I fixed it, but I'm not sure why it was necessary, since it hasn't been a problem before. Basically, I had been using "REMOVE_CRE_ITEM sw1h09_", when it needed to be "REMOVE_CRE_ITEM ~sw1h09_~". Normally, the tildes are optional, but I guess if your item has an underscore in it, it's mandatory.

Share this post


Link to post
9 hours ago, Bartimaeus said:

@Kilgor

With the ini switch for making Dispel Magic penetrate Globes? Thanks for the spot, will fix.

@NdranC If it is incompatible, I do not know how - it is a very simple component that adds a few graphical files with unique filenames without too much avenue to go wrong.

I discovered the source of the problem for Ray Enfeeblement - it turns out, this particular spell actually has two different spells that both BG1 and BG2 use: SCRL6F and SCRLAI. Nothing to do with EET. I'll guess I'll just make a redundant copy over it.

Finally, I also discovered the issue with Zargal and his Whistling Swords. Well, sort of - I fixed it, but I'm not sure why it was necessary, since it hasn't been a problem before. Basically, I had been using "REMOVE_CRE_ITEM sw1h09_", when it needed to be "REMOVE_CRE_ITEM ~sw1h09_~". Normally, the tildes are optional, but I guess if your item has an underscore in it, it's mandatory.

Awesome. I'll be busy with heavy work stuff this week but maybe next weekend I'll be able to test out some of this stuff assuming you already have a new version out. Thanks!

Share this post


Link to post

Ok I got bored and decided to start a new test playthrough with the latest commits from your github repo. Everything really good so far (Whistling Sword was fixed btw) but I just encountered an issue that I'm not sure is caused by SR but I don't know where else to ask tbh and it's close enough.

I was doing the basilisk area and I think my main character got hit and very slowly started to "petrify". Instead of looking all gray like the other statues (honestly I have never been petrified before so I don't even know what it looks like) my character turned brown and had the "held" debuff. I was expecting the game to be over but it never happened. I remained "held" but I couldn't leave the map with my other companions and I had no more stone to flesh scrolls left on me, so effectively I soft locked the game... I think.

It's possible this is caused by some weird interaction between other mods but I though I would check over here anyway.

Share this post


Link to post
Posted (edited)

That's been SR behavior for years now, actually. I think the reasoning behind it (since I'm not the one that implemented it, I can only guess here) being that it doesn't break character relationships (since the original style of petrifying booted your characters out of your party, which at least non-EE games used to think of as a relation-ending), doesn't lead to permadeath if their statue gets destroyed (since they remain in the party), and doesn't destroy items like petrification did. I actually am still considering whether to restore classic petrification behavior for non-party members - see here in the "Imprisonment" block.

Edited by Bartimaeus

Share this post


Link to post
Posted (edited)
3 hours ago, Kilgor said:

Blade of Roses doesn't seem to apply any of the Singing Sword bonuses.

Should go in the IRR thread, :). Anyways, it does, but it works oddly. The character with the Blade of Roses must actually be attacking for it to sing. So simply standing around with it out will not be enough. I'm trying to recall why it's like this instead of the always on passive, but I'm struggling to remember...

Edited by Bartimaeus

Share this post


Link to post

Ah okay :)

 

Btw i want to thank you for keeping the mod updated, so i can continue playing this great game :)

Share this post


Link to post

I just realized after casting Creeping Doom, that Insect Plague isn't working according to the spell description.

With Creeping Doom you'll have to target someone, but Insect Plague can target any point.

Share this post


Link to post
6 hours ago, Kilgor said:

Ah okay :)

 

Btw i want to thank you for keeping the mod updated, so i can continue playing this great game :)

No problem.

As for Insect Plague, Insect Plague should also have to target someone the same as Creeping Doom, so I'll fix that. Thanks!

 

Share this post


Link to post
Posted (edited)

Mage version of Chaos has -6 save on every effect, instead of -4 save like the cleric version.

Also mage Chaos hold effect can't be saved against and have only 9 effects, while the cleric Chaos has 16 effects.

Edited by Kilgor

Share this post


Link to post
Posted (edited)

@Kilgor

Thanks, confirmed. Inherited from base SR, will get a fix on the master git sometime soon.

Edited by Bartimaeus

Share this post


Link to post
Posted (edited)

Hello Bart,

 

Found a minor bug  in spell_rev/languages/english/setup.tra that affects the name of the components.

 

Lines:

@10002=~Cure Sleep Fix~
@10003=~Mirror Image Fix~
@10004=~Dispel Magic Fix~

Should be:

@10002=~Mirror Image Fix~
@10003=~Dispel Magic Fix~
@10004=~Cure Sleep Fix~

 

Thank you for taking the time to fix and enhance this great mod!

Best regards.

Edited by Antipatiko

Share this post


Link to post
4 hours ago, Antipatiko said:

Hello Bart,

 

Found a minor bug  in spell_rev/languages/english/setup.tra that affects the name of the components.

 

Lines:


@10002=~Cure Sleep Fix~
@10003=~Mirror Image Fix~
@10004=~Dispel Magic Fix~

Should be:


@10002=~Mirror Image Fix~
@10003=~Dispel Magic Fix~
@10004=~Cure Sleep Fix~

 

Thank you for taking the time to fix and enhance this great mod!

Best regards.

Nice spot and it has been fixed, thank you! Also have fixed what @DavidW described here, so a thanks to him as well.

Edited by Bartimaeus

Share this post


Link to post
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×