Jump to content

SCS v32 Release Candidate (now Version 10) Available for Testing

Recommended Posts

18 hours ago, Guest Erik said:

This is not really a bug report on the current version (I have no PC to test on at the moment), but I was wondering if the bug with the Fission Slime in Durlag's Tower (with the game not correctly teleporting you to the Chess Board) has been fixed. My last play through was in BG:EE, and this was the only time that I had to use the console.

I think so, don’t recall for sure.

2 hours ago, Guest Galwail said:

Hi, I was installing SCS and run into following error:

SCS install error: the SSL file dvefreetr.ssl cannot be found at stratagems/genie/genie/ssl
Stopping installation because of error.

To resolve this I had to change following lines in genie.tpa

         LAF ssl_to_bcs STR_VAR script=~dvefreetr~ location=~genie/ssl~ END
         LAF edit_creature STR_VAR creature=~dvefreet=>dw#dvefr~ editstring=~strip_script=>dvmelee~ END


         LAF ssl_to_bcs STR_VAR script=~dvefreet~ location=~ssl~ END
         LAF edit_creature STR_VAR creature=dvefreet editstring=~strip_script=>dvmelee~ END

Did I break my game more, or will this change work? I know next to nothing about weidu and ssl, so this is pure guessing on my part 😆


It probably won’t break anything, certainly won’t break much.

2 hours ago, Blind_Visionary said:

If this has been reported and/or fixed already, my apologies.

In SCS32v8, on BG1EE, MGOI fails to block damage from Snilloc's Snowball Storm. Screenshot attached.

Thanks for your continued work on this amazing mod, David!


Noted, thanks.

Link to comment

Regarding sniloc's snowball storm, it seems to be bugged in general. Ihtafeer & co. use it quite often and they get hurt by it, even though they should be immune. It also bypasses magic resistance of the mustard jelly form (though cold resistance works).

There is also something weird going on with Cernd. When met at the druid grove (didn't let him join the party), he continues to cast charm person or mammal on my mage's skeletons. 😆 But once he challenges Faldorn to a fight, it's like he's not a druid at all: doesn't cast any spells, doesn't shapeshift, just attacks her with the quarterstaff.

Edited by chimaera
Link to comment

I will check on the beamdog redmine site if these 2 are intended: -Melf's meteors thrown reduce spell traps/minor spells deflections (etc) spell counts by 3. Eg. Throw 2 meteors dispel minor s. deflection.

-Limited wish counts as a summon eg. when you have 5 already you cannot summon limited with.

-Globe of Invulnerability with stop a spell thrust from dispelling a minor spell deflection (or similar spell) but with not stop offensives spells from reducing their count.

Thank you

Edited by david76321
Link to comment

Hi, I've been running RC9 in BG1 via an SOD install. I've been finding random drop scrolls for spells called 'Dancing Lights' and 'Darkness.' I don't have IWD spells installed, and I've never seen these spells in Baldur's Gate before, so I thought I would mention it.

Edited by OrlonKronsteen
Didn't mean to quote original topic post.
Link to comment
8 minutes ago, OrlonKronsteen said:

Hi, I've been running RC9 in BG1 via an SOD install. I've been finding random drop scrolls for spells called 'Dancing Lights' and 'Darkness.' I don't have IWD spells installed, and I've never seen these spells in Baldur's Gate before, so I thought I would mention it.

I've had a similar bug with spell revisions. From what I recall, darkness is a drow innate added by SoD. For some readon with SR it became available for sorcerers, though I never found a scroll.

Link to comment

SCS does a trawl through all game files to find spell scrolls, and then randomizes those of the appropriate level.

In this case, SoD introduces entirely legal, functional scrolls of both those spells, so SCS is detecting them and adding them to loot drops. However, on a quick trawl through SoD (which I do with extreme caution as I haven't actually had a chance to play it yet) it looks as if they only occur as a trick to give innates to certain creatures - they're marked as undroppable in those creatures' inventories and don't show up elsewhere. So my scroll-randomizer should probably ignore them.

If anyone familiar with SoD wants to tell me otherwise, I'll take their word for it - but I'll repeat my reminder that anyone who spoils its content will be cast into the outer darkness wherein there is a wailing and a gnashing of teeth.

Link to comment
2 hours ago, subtledoctor said:

Off topic, we seem to be in a reverse-race to be the last person to play SoD... 😆

Haven't played it too 😂 even if I own all ee games I'm still using good old classics (waiting a french translation for bg2ee, english don't bother me but I'm so disappointed it's still not translated and anyway I'm a bit of a old-school guy...)

Sorry for the off-topic 😉

Link to comment

Edit: Turns out I remember things wrong, getting old... 😢

A minor bug in the Planar Sphere, kind of funny. 😉 This happens as soon my character enters the basement, so before she even engages the enemies. (Same thing happens with some liches, only the cast suffocate, which is less of a problem, because they're immune to it)


Edited by chimaera
Link to comment

When I cast the cleric spell "Far Sight," nothing happens aside from a graphic of an eye briefly appearing over Viconia. Again, I'm in BG1 via SOD, and the only mod installed other than SCS is Tweaks Anthology v8.

Edit: after testing the spell in an non-SOD, BG1 install (with an identical Tweaks and RC9 install) it works fine, so the problem seems to be within SOD, and may not be related to SCS at all. I will try to test the games without SCS when I get the time to see if I can reproduce the bug.

It looks like this is a SOD-specific bug. Sorry for the false alarm.

Edited by OrlonKronsteen
Further testing
Link to comment

BG 1:EE with only UI (lefreut) mods installed besides SCS. Installation worked fine, tested several of the IWD spells. So far so good, except that Expeditious Retreat displays a red poison icon on the portrait, with the effect being shown in character sheet as "Marek's Poison". The spell itself works fine and wears off normally.

Link to comment
This topic is now closed to further replies.
  • Create New...