Jump to content

SCS v32 Release Candidate (now Version 10) Available for Testing


Recommended Posts

I thought that maybe Cure/Cause Wounds would work in RC10 because I saw a fix related to it.
There might be an improvement since now Smarter
Priests is installed with warnings and could not be installed before, if I remeber correctly
However, I still get lots of errors across multiple files. Without Cure/Cause Wounds there are none.
I uploaded 
SETUP-STRATAGEMS.DEBUG with errors to DropBox https://www.dropbox.com/s/ujjhtz7r9l2vgth/SETUP-STRATAGEMS.DEBUG?dl=0 in case you'd like to do some more fixes around it. Thanks for the continuous development.

SCS
v32 RC10
BG2 EE v2.5.16.6
Windows
Stratagems Installer lang - ENG
Game lang. - PL
installed via Beamdog client
no other mods,

The first error is related to BERKREF.CRE (in RC9 the first error was related to AR18PRIE.CRE)

Copied [weidu_external/workspace\ssl_out\dw#priest.baf] to [weidu_external/workspace\ssl_out\dw#pr11.baf] (NO BACKUP MADE!)
Compiling 1 script ...
[weidu_external/workspace\ssl_out\dw#pr11.baf] loaded, 219412 bytes

[tb#_compile_eval_buffer/weidu_external/workspace\ssl_out\dw#pr11.baf] PARSE ERROR at line 494 column 1-27
Near Text: )
	syntax error
ERROR: parsing [tb#_compile_eval_buffer/weidu_external/workspace\ssl_out\dw#pr11.baf]: Parsing.Parse_error
ERROR: error compiling [tb#_compile_eval_buffer/weidu_external/workspace\ssl_out\dw#pr11.baf]: Parsing.Parse_error
ERROR: compiling [weidu_external/workspace\ssl_out\dw#pr11.baf]!
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
ERROR: [BERKREF.CRE] -> [override/BERKREF.CRE] Patching Failed (COPY) (Parsing.Parse_error)
Stopping installation because of error.

Failed to patch BERKREF.CRE; error message was Parsing.Parse_error

Failed to patch BERKREF.CRE; error message was Parsing.Parse_error
[weidu_external/data/stratagems/sfo_warnings.txt] loaded, 1512 bytes
Appending to files ...
[weidu_external/data/stratagems/sfo_warnings.txt] loaded, 1512 bytes
weidu_external/data/stratagems/sfo_warnings.txt copied to weidu_external/backup/stratagems/6040/sfo_warnings.txt, 1512 bytes
Appended text to [weidu_external/data/stratagems/sfo_warnings.txt]
Copying and patching 1 file ...

 

Edited by xorton
Link to post

I tried to take a quick look at the Mordekainen Force Missile description issue. While I can't pinpoint the exact cause as of yet, what seems clear is that the symbol that is causing trouble for me is the em dash (i.e. the long dash), which is used in a small set of spell descriptions. I will try to check if I have working examples of em dashes in the vanilla BG spells, or if the symbol is generally not working.

Any way some extra information: I am using Win 10, my windows language setting is German but my BG installation and language setting is in English. Also, as mentioned I am using Lefreut UI, if that replaces any fonts it might be another possible cause. Will see if I can pin it down further.

Link to post
12 minutes ago, Guest Erik said:

I tried to take a quick look at the Mordekainen Force Missile description issue. While I can't pinpoint the exact cause as of yet, what seems clear is that the symbol that is causing trouble for me is the em dash (i.e. the long dash), which is used in a small set of spell descriptions. I will try to check if I have working examples of em dashes in the vanilla BG spells, or if the symbol is generally not working.

Any way some extra information: I am using Win 10, my windows language setting is German but my BG installation and language setting is in English. Also, as mentioned I am using Lefreut UI, if that replaces any fonts it might be another possible cause. Will see if I can pin it down further.

OK, I checked with Infinity Explorer and the em-dashes do not show up correctly there as well. So my guess is that install time, the em dashes get corrupted. I don't really mind, though, it is a very minor issue.

Link to post

Just wanted to briefly mentioned that I reached Durlag's Tower and was testing the Basilisks at the top. I cast Prot from Petrification on Kivan and moved him right next to one of the Greater Basilisk. The Basilisk never used his melee attack and continued trying to petrify me. This is all still on Tactical Difficulty. NearInfinity shows the basilisk having the correct SCS script.

Link to post

In my current game with SRR, Breach bypass minor/normal/greater spelldeflections and spell trap.  Do you think it can comes from SCS David ?  I have made the following test with SPWI338 :

[weidu] WeiDU version 24600

Mods affecting SPWI318.SPL:
00000: /* created or unbiffed */ ~ASCENSION/ASCENSION.TP2~ 2 0 // Ascension1.7.2
00001:  ~SPELL_REV/SETUP-SPELL_REV.TP2~ 0 0 // Spell Revisionsv4 Beta 16 (Revised V1.1.0)
00002:  ~STRATAGEMS/SETUP-STRATAGEMS.TP2~ 0 5900 // Initialise AI components (required for all tactical and AI components)v32 RC9

 

Note that breach do not bypass  shield  of the archons (level7 priest) in my game. (witch is the normal behaviour)

Edited by DrAzTiK
Link to post
On 3/11/2019 at 4:17 PM, DrAzTiK said:

In my current game with SRR, Breach bypass minor/normal/greater spelldeflections and spell trap.  Do you think it can comes from SCS David ?  I have made the following test with SPWI338 :

[weidu] WeiDU version 24600

Mods affecting SPWI318.SPL:
00000: /* created or unbiffed */ ~ASCENSION/ASCENSION.TP2~ 2 0 // Ascension1.7.2
00001:  ~SPELL_REV/SETUP-SPELL_REV.TP2~ 0 0 // Spell Revisionsv4 Beta 16 (Revised V1.1.0)
00002:  ~STRATAGEMS/SETUP-STRATAGEMS.TP2~ 0 5900 // Initialise AI components (required for all tactical and AI components)v32 RC9

 

Note that breach do not bypass  shield  of the archons (level7 priest) in my game. (witch is the normal behaviour)

Note that in SR (either with or without Revised), SPWI318 wouldn't protect against Breach anyways, since it only protects up to level 4 spells (in contrast, I think it's level 7 in vanilla). Nevertheless, I did specifically test Spell Deflection against Breach in a clean install of SRR, and it worked just fine. Is SCS now automatically making Breach always effective against liches? (Does this involve setting the power level of its effects to 0? If so, that would do it.)

Link to post

bunch of errors while installing this cannot upload file here says max size is 0.98 mb so i put it on tinyupload instead http://s000.tinyupload.com/?file_id=09457530062807983661

======================================================================

smaller_bam is bg2_button_resized
Copying 1 file ...
ERROR: error loading [stratagems/caster_shared/resource/bg2_button_resized.bam]
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Initialise AI components (required for all tactical and AI components)], rolling back to previous state
Will uninstall 3323 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
Uninstalled    3323 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
ERROR: Unix.Unix_error(20, "stat", "stratagems/caster_shared/resource/bg2_button_resized.bam")
Please make a backup of the file: SETUP-STRATAGEMS.DEBUG and look for support at: For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.
Using Language [English]

 

======================================================================

 

 

Edited by Fraglord85
Link to post

Scs 32RC10 installs well with Alien's 'Project Infinity' tool to install mods (this is with windows 7 64 bit edition operating system and installing ascension first) BG2ee Latest  patch. 

On a side note if there are bugs with ascension's creatures/scripts with scs is it right to post them here? I just love the mods together for the final battle.

(Below is all on insane, all fine tune difficulties to insane or if available throne of bhaal, and with no difficulty damage increase)

It looks like sendai in the final confrontation doesn't have mage HLA's. Expected: mage HLA's.

It looks like abazigal doesnt get anything more than spell shield, stone skins and improved haste, checking after a couple of rounds. Expected: Pre-buffing with spell tuning, or others.

(This second sentence could be intended behaviour.)

 

Thank you for the superb mod SCS 32RC10. Its just awesome ill continue having fun and trying out more of the above. 

Edit (Finally just beat the final confrontation with Ascension. Such an epic battle really fun with SCS32rc10 - thank you)

Edited by david76321
Link to post

- With SRR and RC9 : I just wanted to confirm that spirit armor (leve4) and mestil acid sheath (level5) do not appear in the text box when they are supposed to be cast as prebuff. Also these 2 spells are not active on the creature when they are part of the prebuff routine.

- Sometimes, enemies mage use improved haste in the prebuff routine. The problem is that haste effect only affect the creature casting it and not allies around but maybe it is intented.

- Also it looks like Irenicus in hell do not have chain contingency

- No message in the text box when Tolgerias use mislead spell.

 

 

 

Edited by DrAzTiK
Link to post
48 minutes ago, Kangkunis said:

Could I just upgrade rc9 to rc10 by reinstalling ? Scs was installed last on my mod order Or should I just do a clean install

If it's the last, then you can run the setup-scs.exe and uninstall the components, yes all of them. My advice is that you at least try to clean the current area before this ..as the creatures in there have already been effectively saved as is. And you might need to restart the game ..as you might not be able to use your saves ... if you do this. So THINK, before you advance. 

After the uninstall, go to the game directory, remove the SCS folder and then extract the rc10 to it's place, and install it. And it doesn't need to be the last mod either, as with any other weidu mod. Well, except the ones that are installed before mods that make .bif -files, as those can't be uninstalled correctly. And in this case, the likelihood of not usable saves increase.

Yes, in those cases, the install time gets also longer ... as you are truthfully uninstalling and reinstalling a lot of stuff.

Edited by Jarno Mikkola
Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...