Jump to content
Sign in to follow this  
Rhaella

Bug and Typo Reports

Recommended Posts

Correction - I did not use ChangeStat in the earliest versions of Sirene-BG2. I used another action that was available in non-EE, which is probably why it didn't cause issues.

Updating is free and is easily doable using whatever client you bought the game on - GoG, Steam or Beamdog.

Share this post


Link to post

Great, I will update. The VCV10 was a series of mods by the guy (Vlad) who put together Tortured Souls, and some other improved encounter mods. What is the issue with DERATS mod? It added kits.

Share this post


Link to post
4 minutes ago, rossbach451 said:

Great, I will update. The VCV10 was a series of mods by the guy (Vlad) who put together Tortured Souls, and some other improved encounter mods. What is the issue with DERATS mod? It added kits.

DERATS (Deratiseur's kitpack) is probably fine and shouldn't have been the cause. Vlad's Compilation... it's likely not the issue but since the modder is a raving EE-hater and also admits to not using other people's mods I wouldn't put it past him to happily override the ACTION.IDS file (which would be an incredibly stupid thing to do) and not care in the slightest about compatibility with other mods. I wouldn't install it on EE. It's not made for it.

EDIT: Btw, you should revisit the download sites of your mod selection after you've updated. A lot of the mods listed will have been updated since years ago when v1.3 of EE was the latest thing.

Edited by Artemius I

Share this post


Link to post
1 minute ago, Artemius I said:

DERATS (Deratiseur's kitpack) is probably fine and shouldn't have been the cause. Vlad's Encounter... it's likely not the issue but since the modder is a raving EE-hater and also admits to not using other people's mods I wouldn't put it past him to happily override the ACTION.IDS file (which would be an incredibly stupid thing to do) and not care in the slightest about compatibility with other mods. I wouldn't install it on EE. It's not made for it.

Ugh, never understood such parochialism. I have never had an issue with him, but I will avoid his mods. Too bad, I did love Sime, had no real use for the rest of the TS mod.

Share this post


Link to post
22 hours ago, Artemius I said:

Looks like you're missing the ChangeStat action in the action.ids file. I've seen this issue a lot with pre-v2.0 versions of EE.

Thanks for handling this, Artemius. (There are a couple minor issues I need to fix, but I saw 20 responses here and was momentarily very worried, hahaha.)

Do you know if there's any way to check for pre- vs. post-v2 versions of EE? Though maybe forcing people to update is the better option...

Edited by Rhaella

Share this post


Link to post
3 hours ago, Rhaella said:

Thanks for handling this, Artemius. (There are a couple minor issues I need to fix, but I saw 20 responses here and was momentarily very worried, hahaha.)

Do you know if there's any way to check for pre- vs. post-v2 versions of EE? Though maybe forcing people to update is the better option...

If you're really worried about it, you could instead apply spells to alter stats as needed. Honestly, though, I would not worry about in the same way mods don't worry about unpatched ToB--2.0 came out years ago; it's not unreasonable to expect folks to update.

Share this post


Link to post

The mod only uses ChangeStat to set experience values so you could use AddXPObject instead. It just adds experience to the NPC rather than setting it and shows a 'X has gained Y quest experience points' in the message box.

Share this post


Link to post
On 1/14/2019 at 9:08 PM, Artemius I said:

DERATS (Deratiseur's kitpack) is probably fine and shouldn't have been the cause. Vlad's Compilation... it's likely not the issue but since the modder is a raving EE-hater and also admits to not using other people's mods I wouldn't put it past him to happily override the ACTION.IDS file (which would be an incredibly stupid thing to do) and not care in the slightest about compatibility with other mods. I wouldn't install it on EE. It's not made for it.

EDIT: Btw, you should revisit the download sites of your mod selection after you've updated. A lot of the mods listed will have been updated since years ago when v1.3 of EE was the latest thing.

DAMMIT! I have updated my BG2 EE today, and still cannot use this mod. Attached is the debug. I am frustrated with myself for not figuring this out, I am not mad at anyone here. I really appreciate any time you can spare me on this issue.

SETUP-EVANDRA.zip

Share this post


Link to post
[evandra/scripts/bgee.baf] PARSE ERROR at line 46 column 1-37
Near Text: )
	[ChangeStat] not found in ACTION.IDS

[evandra/scripts/bgee.baf]  ERROR at line 46 column 1-37
Near Text: )
	Parsing.Parse_error
ERROR: parsing [evandra/scripts/bgee.baf]: Parsing.Parse_error
Stopping installation because of error.
Stopping installation because of error.

You're still getting the same error? Are you sure you're playing on v2.5?

Share this post


Link to post
19 minutes ago, rossbach451 said:

DAMMIT! I have updated my BG2 EE today, and still cannot use this mod. Attached is the debug. I am frustrated with myself for not figuring this out, I am not mad at anyone here. I really appreciate any time you can spare me on this issue.

SETUP-EVANDRA.zip

Well, we can always get around the problem manually. If you open up the mod folder, you'll find a subfolder called "scripts" instead. You can drop the file I've attached inside there and it will overwrite the file that's causing you trouble. 

bgee.baf

Share this post


Link to post
16 minutes ago, Artemius I said:

[evandra/scripts/bgee.baf] PARSE ERROR at line 46 column 1-37
Near Text: )
	[ChangeStat] not found in ACTION.IDS

[evandra/scripts/bgee.baf]  ERROR at line 46 column 1-37
Near Text: )
	Parsing.Parse_error
ERROR: parsing [evandra/scripts/bgee.baf]: Parsing.Parse_error
Stopping installation because of error.
Stopping installation because of error.

You're still getting the same error? Are you sure you're playing on v2.5?

Yup. 2.5.16.6

Share this post


Link to post
On 1/17/2019 at 7:58 PM, Artemius I said:

Post your weidu.log?

So, any ideas? I will just continue to try, and add other mods to go on with the game. Thanks for your help thus far!

Share this post


Link to post
Guest thanks!
On 1/17/2019 at 7:47 PM, Rhaella said:

Well, we can always get around the problem manually. If you open up the mod folder, you'll find a subfolder called "scripts" instead. You can drop the file I've attached inside there and it will overwrite the file that's causing you trouble. 

bgee.baf

You are the best!!! I just noticed your post, and tried it out. Thank you!

Share this post


Link to post
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×