Jump to content

Sword Coast Stratagems v32 now available


Recommended Posts

First of all, @DavidW congrats on the release and thanks for this amazing mod!

I'm not sure if bug or intended, but I just tried to use a Protection from Magic scroll on Daveorn and he was still able to cast spells, etc. What gives? Does SCS v32 neuter the scroll somehow? (I just Ctrl+F'ed the readme, but there doesn't seem to be any mention of this.)

Link to post
8 hours ago, AnonymousHero said:

First of all, @DavidW congrats on the release and thanks for this amazing mod!

I'm not sure if bug or intended, but I just tried to use a Protection from Magic scroll on Daveorn and he was still able to cast spells, etc. What gives? Does SCS v32 neuter the scroll somehow? (I just Ctrl+F'ed the readme, but there doesn't seem to be any mention of this.)

Not intentional; will check out.

He's definitely casting spells, not just using his sequencer?

Link to post

Well it's definitely scs considering it's the only mod I have installed. Using nahal's reckless dweomer with chaos shield up gives the message "wild surge averted with chaos shield" while with improved chaos shield the surge happens. Here are the components I used.

WeiDU.log

Link to post

Getting a whole bunch of these while installing Improved Mindflayers on BG2EE:
 

[tb#_compile_eval_buffer/weidu_external/workspace/ssl_out/flayer01.baf] PARSE ERROR at line 1654 column 1-59
Near Text: )
        [CheckSpellState] argument [ITEM_PSIBLAST] not found in [splstate.IDS]

[tb#_compile_eval_buffer/weidu_external/workspace/ssl_out/flayer01.baf] PARSE ERROR at line 1667 column 1-99
Near Text: )
        [CheckSpellState] argument [ITEM_PSIBLAST] not found in [splstate.IDS]

[tb#_compile_eval_buffer/weidu_external/workspace/ssl_out/flayer01.baf] PARSE ERROR at line 1668 column 1-105
Near Text: )

 

Link to post

SCS doesn't modify the file beyond adding detectable-spells detection to it, and that string is one of the game engine's core strings.

8 minutes ago, Angel said:

Getting a whole bunch of these while installing Improved Mindflayers on BG2EE:
 


[tb#_compile_eval_buffer/weidu_external/workspace/ssl_out/flayer01.baf] PARSE ERROR at line 1654 column 1-59
Near Text: )
        [CheckSpellState] argument [ITEM_PSIBLAST] not found in [splstate.IDS]

[tb#_compile_eval_buffer/weidu_external/workspace/ssl_out/flayer01.baf] PARSE ERROR at line 1667 column 1-99
Near Text: )
        [CheckSpellState] argument [ITEM_PSIBLAST] not found in [splstate.IDS]

[tb#_compile_eval_buffer/weidu_external/workspace/ssl_out/flayer01.baf] PARSE ERROR at line 1668 column 1-105
Near Text: )

 

I'll need a WEIDU.log, since I don't get those on a clean full install.

Link to post
42 minutes ago, Carso said:

Well it's definitely scs considering it's the only mod I have installed. Using nahal's reckless dweomer with chaos shield up gives the message "wild surge averted with chaos shield" while with improved chaos shield the surge happens. Here are the components I used.

WeiDU.log

On the one hand, I can't see how this could possibly be anything to do with SCS.

On the other hand, I can reproduce it on a clean install, so it clearly *is* SCS.

How interesting. Will investigate...

Link to post

Hey all! I'm having a little trouble updating to the most version. I previously worked with the RC10, or whatever it was called, and I've downloaded the current version since then. Everything reinstalls fine except for a few components related to Ascension, starting with the Smarter Melissan component and a problem with the gate5.spl file. My debug file is attached. Any idea what I can do?

EDIT: Also, is it possible I can change my username to semiticgod? (it's me from the Beamdog forums)

 

SETUP-STRATAGEMS.DEBUG

Edited by USA
Link to post

You're using the old version of Ascension - which, y'know, is fair enough, since new versions of things often having teething problems, but I didn't really test with the old version.

In this case, it's a bug in the code that tries to allow for the old version. Will fix; in the meantime, if you want to hotfix, open stratagems/ascension/ascension_shared.tpa in a text editor, and replace ~COPY "gate5.spl"~ with ~COPY_EXISTING "gate5.spl"~.

EDIT: as for username, try asking @Mike1072or @CamDawg, since it's above my pay grade.

Link to post
9 hours ago, DavidW said:

On the one hand, I can't see how this could possibly be anything to do with SCS.

On the other hand, I can reproduce it on a clean install, so it clearly *is* SCS.

How interesting. Will investigate...

… and got it. Bug in the new version of Detectable Spells. Fixed locally; will distribute in (fairly-imminent) next version.

Link to post

I have found a problem with Tweaks v32 - the last version - : when I entered my team in the sewers - in the Temples District of Athkatla - I have had a crash on my last BG2/ToB install and I return on Windows. I  haven’t encountered this problem before with the RC versions of Tweaks 32. So I have made many attempts, on SoA and ToB and it seems that the problem is Gaius, the member mage of the evil adventurers team in the sewers, who have been modified moreover by Revised Battles; I had a look at his CRE file and I haven’t found anomalies at first sight. I put here my ToBEx log here, and I hope this problem will be resolved soon.

TobEx.log

GAIUS.cre

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...