Jump to content
Luke

Lizard men are equipped with "invisible" weapons

Recommended Posts

All Lizard men (i.e., "CDIS2LZ7", "CDIS2LZ6", "CDIS2LZ5", "CDIS1LZ4" and "CDIS1LZ3") lack their weapon (I'm talking about the in-game sprites. According to their CRE files, the weapon itself is in the appropriate quick slot and selected, so there's probably a problem with their BAM files).

Edited by Luke

Share this post


Link to post
25 minutes ago, CamDawg said:

Alright, something to fix for 2.6 then.

I had a look at IWDEE and it seems to be a link between creature animation, item category (offset 0x1c), equipped appearance (offset 0x22) and weapon proficiency (offset 0x31).

Let's consider NALIZMAN.itm as an example => If you set item category to 20 (Large swords), equipped appearance to "HB" and weapon proficiency to 99 (Halberd), then the weapon is visible (even though for some frames appears to be misaligned with respect to the hands....)

Edited by Luke

Share this post


Link to post

It's a problem with IWD-EE in the first instance: lizardman summons have standard items like S1-12 and B1-12, which don't have anything set in 0x22. (The same is true in vanilla IWD - either the bug was present there too, or there's some engine difference.)

Share this post


Link to post

Right. Fixing the weapons is still in my ToDO list, but if the next patch will fix this issue, I would be happy to remove it and spend my time fixing other points. ;)

Share this post


Link to post
On 6/4/2019 at 9:18 PM, Gwendolyne said:

will be fixed with IA.

Just to be sure everything is really fixed.... Even after setting 'equipped appearance' to, say, "HB" (Halberd), I keep getting this.....

Do you know what's wrong?

Share this post


Link to post

There are two parts for the fix; the first is that the lizardmen need a weapon with an animation that the animation uses--which you've done--and the second part is that the actual halberd animation is missing from the animation itself. You could try grabbing the mliz* BAM files from Fixpack and dropping them in to your override folder.

Share this post


Link to post
On 6/6/2019 at 11:52 PM, CamDawg said:

...and the second part is that the actual halberd animation is missing from the animation itself. You could try grabbing the mliz* BAM files from Fixpack and dropping them in to your override folder.

@Gwendolyne

Well, this issue is not present in IWDEE and my BGEE override folder contains the same 85 MLIZ*bam files that are in IWDEE (unless I'm missing something....)

So, what are exactly the files that are missing?

Edited by Luke

Share this post


Link to post
23 minutes ago, Gwendolyne said:

the mliz[x]... bam files, with x being c[lub], h[alberd] and q[uaterstaf].

 

I told you, everything seems to be there => from MLIZCA.bam to MLIZCWKE.bam; from MLIZHA1.bam to MLIZHWKE.bam; from MLIZQA1.bam to MLIZQWKE.bam.

It's very weird.... Could you try it yourself and then let me know what's wrong? Thanks!

Edited by Luke

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...