Jump to content

SCS Rules invalid text SCS Difficulty Button

Recommended Posts

Hello everyone,

I did a quick search on the forum but I coud not find anything about this specific problem and none of the solutions worked for me so far.

When I try to select the SCS_Difficulty_Button, a text box with Invalid entries pops up.

In other words, I can't set up the difficulty settings for SCS. This is too bad as I'd really like to experience this awesome and ingenious mod from DavidW.


Windows 10, Display 1366 X 768

BGEE 2.5 + SoD

- SCS v32

- Steam Version

- modmerger installed (to work with SoD)

- Installation folder is not in Program Files

- Edit 1: The game ran at least once prior to installation

- Edit 2: Game was installed in rewrite permissible folder.

Installed features:

Replace +1 arrows and other projectiles with nonmagical "fine" ones
Replace many +1 magic weapons with nonmagical "fine" ones
- Weapons are imune to IRON CRISIS
Faster Bears
More realistic wolves and wild dogs
Improved shapeshifting

Initialise AI components (required for all tactical and AI components)
Smarter general AI
Smarter mages
Smarter Priests
Improved Spiders
Smarter sirines and dryads
Slightly smarter carrion crawlers
Smarter basilisks

Improved doppelgangers
Tougher Black Talons and Iron Throne guards
Improved kobolds
Improved Cloakwood druids

I also tried installing with SoD deactivated but achieved the same result.  I'm sure I must have missed out on something since others have been running this mod without any issues.



FIXED: Make sure you select the correct default game language


Edited by Aubergine
Link to comment

Thanks for the reply.

I just tried a fresh install with the same settings and the game running in the main BGEE menu in windowed mode. Saldy, the result was the same.

I don't suppose I could edit the dialog file manually or maybe download the file from someone?

Another workaround would be to have access to the actual text branches and just select the options based on the dialog numbers showing up on my screen (e.g. 5 + 1 +1 for Insane or whatever)

Edited by Aubergine
Link to comment
2 hours ago, Aubergine said:


He asked if you game was running... and then you make a test that has the game running while you install.

You need to have ran the game, for it to know which dialog file to edit yes, but you need to quit the game for: the mod install to have access to the files, while it's not in read_only -state. A weidu mod is defined by the Weimers Infinity Engine Dialog Utility editingtool, aka by installing a weidu mod, you get exatly what you ask.

Another reason why you might not be able to have correct dialog is, that you don't have re-write permission to your install folder, meaning that your game folder is in the C drive, but not in your C:\Users\<windows username>\ -folder. As that's the only folders you have a rewrite permission, by default. This is a Windows 10 feature.

Edited by Jarno Mikkola
Link to comment

Yeah...I guess I completely misunderstood what DavidW suggested by installing " with the game open".

Thanks for the suggestion. I did a fresh install on C:\Users\<windows username>\, ran the game once, ran the modmerger then the SCS installer. Alas, the result was the same.

Link to comment

Well, the mod makes setup-*modname*.debug -file during install, so go to the game folder, package the file into a .zip archive and attach it to a post. This will let us see if there's things going wrong by a good degree.

The archiving reduces the text files size by a factor anywhere from 10 to near 1000, so that's why... I suggest this.

Edited by Jarno Mikkola
Link to comment
26 minutes ago, Jarno Mikkola said:

Do you have the "DLC" called "Siege of the Dragonspear", for you to install any mods on top of a game with that, you need to use the modmerger tool first.

I do have SoD installed and I did use the modmerger tool. I suppose the modmerger installation was successful since the sod-dlc.zip file was effectively unzipped and renamed to sod-dlc.disabled.

In any case, I did try to install the SCS mod without Sod but the result was the same.

Edited by Aubergine
Link to comment

It's possible that somehow you've configured WEIDU so it's editing the wrong (i.e., wrong-language) dialog file. Try this:

- uninstall SCS (and any other mods you're using).

- Delete the file 'weidu.conf' from your game directory.

- reinstall SCS. At the beginning it will give you two language choices. The first is up to you; the second (with a prompt like 'please choose the language in which you want to play the game' *must* be set to the language you are playing in. (If that's English, the choice is probably number 1).

EDIT: Jarno got there first.

Link to comment

Running the installer once more, I noticed I did not select the correct default game language. Rather, I kept pressing 0 + 0  instead of the proper number for English, which 0 + (9, I believe?)

Welp. Now I feel like a total boob for wasting everyone's time. I hope this serves as a cautionary tale for others who experience the same inadvertence.

Thanks to both of you.

FIXED: Make sure you select the correct default game language

Edited by Aubergine
Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...