Jump to content

SCS updated to 32.6 (now 32.8)


Recommended Posts

Guest The_sextein

It may not be perfect but what I was talking about can be found here.

https://forums.beamdog.com/discussion/72639/comments-on-new-v2-5-pathfinding-it-is-bad-news/p2

Link to post
On 4/9/2020 at 3:12 PM, Guest The_sextein said:

The EE Versions of the game don't have a path finding node adjustment because it is maxed out by default so they removed the option to lower it.  The problem is that characters spawn on top of each other and get stuck on each other.  So if you are playing on a really high difficulty level like LOB mode you lose the battle if everyone doesn't do exactly what you tell them to because a couple seconds delay can ruin a fight.  I fixed the Flail of Ages and Foebane and I have a great GUI that I downloaded that replaces the EE abomination.  There is a fix that will roll back the pathfinding to version 2.3 but that still leaves LOB mode that is bugged out.  I was lucky enough to download the older version from the steam console before that got screwed up so I would rather just stick to 2.3.  If that means using SCS 31 instead of 32 then that is fine with me but I figured I would ask to be sure that SCS 32 won't work with EE 2.3.

I just use CTRL+J to break them apart.

Link to post

Made an account to report a couple bugs I ran across.

One is that "Improved npc customization" doesn't work at all with Wilson. Can't put more than two pips into two weapon fighting and he is stuck at lvl 0.

The second one I think is also related to "Improved NPC customization". Basically recruitable NPC's can't die if you fight them before recruiting them and I assume leveling them past 0. Happened 3 times to me. First was with Dorn after provoking him, then with Valygar (makes it pretty difficult to take his body to enter the planar sphere), and Cernd who attacked me after poisoning the grove. You can still kill them by stat draining them though.

This one might not be related to SCS but according to the wiki tenser's transformation should now be usable with abilities in the latest EE patch but I couldn't get them to work together.

Some weirdness with contingency being called "quick weapon" in the abilities bar but it works fine so not that big of a deal.

Also SCS is the best and so is this website :) 

Link to post
Guest BettaGeorge

I can confirm that the "infinite leveling" bug persists in version 32.8, and only happens if party AI is off at the time the NPC joins the party. Workaround for those (like me) who like micromanaging their party: keep party AI on at all times, but set everyone's script to "None" in the customization screen.

Link to post
1 hour ago, Guest BettaGeorge said:

I can confirm that the "infinite leveling" bug persists in version 32.8, and only happens if party AI is off at the time the NPC joins the party. Workaround for those (like me) who like micromanaging their party: keep party AI on at all times, but set everyone's script to "None" in the customization screen.

I was able to reproduce this bug, indeed party AI needs to be turned off for this to happen. 

Link to post
Guest Guest Fatso

For those wondering about the infinite levelling of NPCs when they join the party when using the component "improved NPC customisation and management", I found a solution, well at least for now until the mod is updated by the author.

The trick is to leave on "Party AI" at all times. 

If you don't want to use Party AI (which is also my case), after installing SCS, install the Tweaks Anthology mod. In the "Joinable NPC Tweaks" section, install the component "Don't Auto-Assign Advanced AI Scripting to Party". The description cites that "Party members automatically get assigned the 'Advanced AI' script in BGEE/BG2EE. This component alters the NPCs to instead come with the "DEFAULT" AI script assigned, which does nothing, as they do in vanilla BG/BG2 games."

Ta daa. Lemme know if it helped a couple of you people.

Great mod by the way. Lots of fun and it allows me to rediscover the BG games that I know so well.

Link to post

Ok, finally managed to install SCS v32.8 on EET install using Project Infinity tool. I have put it after EET_end in install order. The main component installed with errors, though (the others installed without any errors). Not sure if those errors are harmless or can result with some unexpected events during game.

I'm attaching Debug file and WeiDU logs.

I know @DavidW is currently in hiatus, but maybe someone could let me know if those warnings could get me in the trouble during game.

ProjectInfinity-Weidu-Debug-stratagems-5900-Error.log WeiDU.log WeiDU-BGEE.log

Link to post

I have very similar warnings to Cahir, also EET via PI.

No effects altered on:

  • scrl07.itm (protection from magic)
  • spwi418d.spl
  • halb11.itm

These are probably fine, I assume something else (SR/IR?) is modifying them first and SCS does not need to. What is the best way for me to check what they are? Search engines are not helping much!

The Warning: you've called an include with no argument is a new one to me.

Logs attached, thanks.

ProjectInfinity-Weidu-Debug-stratagems-5900-Error.log WeiDU.log

Link to post

I've got this while I was  trying to install this version on easyTutu:

Quote

ERROR locating resource for 'COPY'
Resource [ELAIRSU4.cre] not found in KEY file:
    [./chitin.key]
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Initialise AI components (required for all tactical and AI components)], rolling back to previous state
Unable to Unlink [weidu_external/backup/stratagems/5900/OTHER.5900]: Unix.Unix_error(1, "unlink", "weidu_external/backup/stratagems/5900/OTHER.5900")
Will uninstall 5776 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.

 

Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...