Jump to content

Near Infinity & Infinity Explorer Questions


Recommended Posts

I'm definitely not working on anything.

That being said, Near Infinity has some very terrible window tearing when opening files from the folder tree. Any way to prevent that? The version is Version 2.1-20180615 or here.

Additionally, I'm attempting to use the version of Infinity Explorer from the 2016 version here and it doesn't want to recognize my BG install (I'm using the Beamdog client, installed directly on my main hard drive (no program files)). Any particular folder I need to point it to or does it just not like EE?

If both of these questions are irrelevant because there is a snazzier and easier tool out there that we're using, I'd love the link but these were just my goto tools back in the bronze age.

Thanks in advance. :) 

Link to comment

Licks his bronze knife, "Yeah, still tastes the same. Blood." The tools have not changed... except the ShadowKeeper got to become EEKeeper, but haven't tried it after the first iteration.

You might want to update your Java Runtime for NI, but that's about it. I have 20180205 version and it has no tearing... so if I got your description right, it might be something with your screen size. Or the fact that you are looking at the BG1EE+SoD, which you should install the DLCMerger before you install/modify/look at it's files, as the DLC's dialog etc things are locked into the .zip archive, which the merger opens and expands to be as they are intended. But that's only for the GoG/Steam game, as the SoD is a separate install on the Beamdog's side, so... I have no experience on this.

Link to comment

That sure shouldn't happen. So expect it to be a video driver/Java/other such issue, not a Near Infinity only.

And if you use Windows 10 as your OS, and C drive, you need to install the game into your user profile files, aka here:

C:\Users\<username>\Games\Game folder\ ... well the two first folders are must, as you are restricted to access the other folders as a non owner of them. Or just use another drive. The other OS'es have similar lesser restrictive access features you might be able to turn off... but, really the whole thing is a -curse words restricted from this forum site by the rule of the overseer-

Edited by Jarno Mikkola
Link to comment

It could be a video driver compatibility issue with the GUI framework used by NI. I found a similar issue that was solved by setting a global environment variable by this console command:

setx J2D_D3D false

Maybe it helps in your case as well.

Alternatively, start Near Infinity directly with 3D acceleration turned off (or create a shortcut out of it):

javaw -Dsun.java2d.d3d=false -jar NearInfinity.jar


Link to comment
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...