Jump to content

Compatibility issue with the NPC Project: weidu tries to copy nonexistent object

Guest BettaGeorge

Recommended Posts

Guest BettaGeorge

Hi there!

I have posted this issue over on the NPC Project forum and was directed here.

Trying to install the NPC Project (which used to be compatible with SCS) and then the General smarter AI component of SCS crashes the weidu installer.

I have included as much debugging information as I knew how to produce in my original post on the Beamdog forums. If you do not want to follow that link, I can also paste that information here.

Jastey has made me aware that I was using version 32.7 of SCS, while the newest version is 32.8. I have since downloaded 32.8 from github and reproduced the exact same error. If needed, I can reproduce all the debug files with this version, but I don't think anything has changed.

Should this somehow not be a bug, but rather my own screwup, then I would still appreciate any help 馃檪

Link to post

Oh wow, I actually figured out what is giving this "Tried to identify nonexistent weapon" message: it's because the x#keth.cre has items assigned to item slots - but there are no items on the cre.

Still: on Windows10 and BG:EE from BeamDog i can install the Smarter Ai component fine, despite also getting the "Tried to identify nonexistent weapon 每每每每每每每每.itm" message.

I posted into the BG1NPC bug thread what I hope is a solution.

Link to post
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...