Jump to content

Problem with instalation


Recommended Posts

Hi! and greetings young ones.

I'm having some issues when installing mods in my BG2EE v1.3.2064. 

Two mods I want to run together: SCS v30 and Tweaks anthology 9. I've tried the following: 

Clean instalation BG2EE v1.3.2064 with SCS v30: works fine. 

Clean instalation BG2EE v1.3.2064 with Tweaks anthology 9: works fine. 

Clean instalation BG2EE v1.3.2064 with Tweaks anthology 9 and then SCS v30: error. 

The file setup-stratagems_autoinstall say: 

CDTWEAKS/SETUP-CDTWEAKS.TP2  8 130 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 140 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 1010 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 1020 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 1040 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 1080 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 1160 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 1180 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 2210 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 2999 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 3000 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 3010 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 3060 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 3080 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 3121 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 4020 Installed
CDTWEAKS/SETUP-CDTWEAKS.TP2  8 4050 Installed

[CDTWEAKS/SETUP-CDTWEAKS.TP2] PARSE ERROR at line 2 column 1-7
Near Text: SUPPORT
    GLR parse error

Any idea what might be the problem? 

Thanks in advance guys. 

Stay safe and respect social distance. 

 

 

 

Link to post
11 hours ago, nicomg said:

BG2EE v1.3.2064. 

That's an outdated version of the game. Mods are usually updated to work with the newest game patch.

EDIT: yes, I probably should have read the whole post.

Link to post

Based on the portion of the setup-cdtweaks.debug, there's no way to tell if either of those resoponses is actually valid, so take them with as much salt as you like, and you should this time copy paste the entire debug file either as a text print ot an offsite repository, or a .zip file and give us the link to download it, as I am afraid your post count needs to be 5 to attach a file to the forum.

Link to post

As it has been already mentioned, the SCS package is outdated. More specifically it contains an ancient setup executable which doesn't support features that are used by the other mods you have already installed.

If you decide against using a more recent SCS version then I'd suggest to create a copy of your Tweaks Anthology installer (setup-cdtweaks.exe) and rename it to weidu.exe. It should overwrite the original (and outdated) SCS setup binary. Afterwards try installing SCS again.

Link to post

Well first things first: thanks you all for your answers.

I forgot to mention that in my BG1EE v1.3.2053 the same .exe files (SCS v30 and Tweaks anthology 9) works fine. 

Here it is the complete version of the setup-cdtweaks.debug file: https://mega.nz/file/J0A2BIDY#p5b305ojilYQ-wy64fgAa47jziKzXU2wnZ5thMyZuEg

Here it is the complete version of the SETUP-STRATAGEMS.debug file: https://mega.nz/file/F8gDSaLZ#cOlaD3F2sD_oxRTbYKONasBoHMJINscQ6yKcZpSy8jk

Order instalation: 

1) BG2EE 1.3.2064

2) Tweaks anthology v9

3) SCS v30

Other relevant information: I'm using Windows 7 Professional 32 bits. 

Thanks!

 

 

 

 

Link to post

Your debug file indicates you used weidu v 23700 to attempt to install SCS. Tweaks Anthology v9 comes with weidu v 24600. I'm not certain if it'll make any difference, but as per argent's advice, it may be wise to attempt to use that as your setup-stratagems.exe instead.

Edited by Bartimaeus
Link to post
40 minutes ago, Bartimaeus said:

Your debug file indicates you used weidu v 23700 to attempt to install SCS. Tweaks Anthology v9 comes with weidu v 24600. I'm not certain if it'll make any difference, but as per argent's advice, it may be wise to attempt to use that as your setup-stratagems.exe instead.

Good point, in my BG1EE i see only weidu 23700 in the WSETUP.DEBUG. 

The thing about more recent SCS versions is that they need BGEE + 2.0 versions, right? 

Otherwise, i've tried running SCS v30 with Tweaks Anthology v3 and same mistake. 

So.. i'm a little bit lost here. SOS please haha. 

Link to post
20 minutes ago, nicomg said:

So.. i'm a little bit lost here. SOS please haha. 

After you have downloaded the SCS v30, you can extract the archive it is, yes, it's a self extracting archive with a .exe as it's command extraction extension, meaning you can open it with WinRAR for example and view and extract it's content without triggering the auto -part of the extractor. You just need to right click it to open, if you have WinRAR, which gives options to run it with WinRAR... the 7zip program should have the same function. That will then open up the normal archive extration tool rather than the automatic one that, would give you not other options that one following a stupid command line that's premade into as a .exe. Giving you this command line, that it will follow to the letter:

setup-stratagems --uninstall --language 0 --force-install-list 1000 1000 1910 2000 2010 2030 2070 2080 2090 2100 2110 2120 2140 2150 2160 2170 3100 4010 4030 4180 5010 5900 6000 6010 6021 6030 6040 6100 6200 6500 6510 6520 6530 6540 6551 6563 6570 6580 6590 8000 8010 8020 8030 8043 8050 8061 8070 8081 8100 8110 8120 8140 8150 8160 8170 8180 8190

So instead of that, you then extract the files normally into the game folder, and then delete the setup-stratagems.exe file, and copy the already existing setup-cdtweaks.exe into the same folder and rename that as the just before deleted setup-stratagems.exe file, this will allow it to run updated weidu.exe file when you manually start the just created/copied/renamed setup-stratagems.exe file with a double click. And now you are presented with a MS-dos like interface with all the options the mod has to offer.

 

Link to post

Hmm, why is that a Professional, and not a Home edition of Windows 7 ? Just asking. Cause you shouldn't be using a work computer at home to play games. Because it jeopardises any info on the computer to a lot of backdoors etc to "allow gaming", which is a really messed up thing. 

@scs update:  Nope. See this: "Problem Unix.Unix_error(1, "mkdir" .... is not a weidu error so much as a probably an updated Windows 7 error involving you not having the permission to write into the folder. The solution, from here, quoting myself:

On 12/10/2014 at 12:54 PM, Jarno Mikkola said:

Install the game to the user accout folder in: C:\Users\<username>\ ... it's the only directory you have a full access/rights on Windows 8&8.1 even if you use admins account.

Erhm should have said sub-folder...

Edited by Jarno Mikkola
Link to post
2 hours ago, Jarno Mikkola said:

Hmm, why is that a Professional, and not a Home edition of Windows 7 ? Just asking. Cause you shouldn't be using a work computer at home to play games. Because it jeopardises any info on the computer to a lot of backdoors etc to "allow gaming", which is a really messed up thing. 

@scs update:  Nope. See this: "Problem Unix.Unix_error(1, "mkdir" .... is not a weidu error so much as a probably an updated Windows 7 error involving you not having the permission to write into the folder. The solution, from here, quoting myself:

Erhm should have said sub-folder...

Well i think i'm a good student cos' i got it right this time. 

First i run a clean install on my C:\Users\<username>\

Then i had to replace the .exe file from tweaks to stratagems to update wiedu.

And after all that trouble, BINGO!

Thanks mates! I couldn't work this out without you

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...