Jump to content

Can't install almost any SCS component due to errors


Recommended Posts

I get error messages for almost every SCS component I'm trying to install. I moved from 32.8 back to 32.7 but that didn't change a thing.

My very uneducated guess is that there is something wrong with SCS's not so standard installation/scripting process. It almost looks as if it didn't recognize it's own variables?

ERROR: illegal 1-byte read from offset 1 of 1-byte file INNER_PATCH_SAVE "%spellcode_base%"
ERROR: [spell.ids] -> [override] Patching Failed (COPY) (Failure("INNER_PATCH_SAVE \"%spellcode_base%\": read out of bounds"))

(see debug file for more detailed error messages..)

I've got a new machine with Windows10 so I'm not quite sure if it's related to that. Maybe stupid windows is preventing some part of SCS's installation process to run/access files properly?

 

SETUP-STRATAGEMS.7z

Edited by Ulb
Link to comment
10 minutes ago, Jarno Mikkola said:

One of the mods before made cheese from your spell.ids file. Open it with Near Infinity and have a look.

I will, but I've gotten a lot of different error messages that seem unrelated to spell.ids. Like, at one point it said it was missing a translation for a file and at another it said it couldn't make changes to %candlekeep%.are because the file didn't exist and so forth.. (should all be in the debug file)

Link to comment
1 hour ago, Ulb said:

..at another it said it couldn't make changes to %candlekeep%.are because the file didn't exist and so forth..

The reason is easy to determine, why it happens is that the candlekeep variable is not determined in the specific variable table that is loaded. Likely due to the fact that you have a wrong install order.

The debug file is nearly empty because you quit the install before it could start and finnish the other components debugs which would have shown them. Yes, the debug file is cleared each time you run the setup-modname.exe... so it won't show any of the other debugs, which is why BWS had the debug pass to it's own file after each install process.

Missing translations are likely if you first install a component from a mod, then overwrite the install files with others. This is why the BG community has a clearly determined procedure for installing mods. Called "How to build and maintain a clean install." it's offline now as the PPG is offline. But it was there in 2010 or so if I am not completely off my rocket.

Link to comment
Quote

Yes, the debug file is cleared each time you run the setup-modname.exe

I was not aware, I assumed it would just append to the file. In that case the file is probably not very helpful, yes.

I also admit the current installation was more of the 'quick and dirty' kind but it was close enough to what I usually run that I didn't expect to run into any major compatibility issues.

I guess I was wrong about that.

 

Link to comment

Erhm, don't take the above post wrong, my intention was to show that these are the procedures... and 'guick and dirty' is fine as long as you notice the difference. I also, have played and quit the Mega-weidu install game several times and have only completed it ones. -and quited that after BGT-s BG1 cause there was more mods to build.

Link to comment
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...