Jump to content
Sign in to follow this  
Nathan82

Problems with BGT megamod install

Recommended Posts

@subtledoctor i tried editing the description with this

Spoiler

 

Breach
Level: 5
School: Abjuration
Range: Long
Duration: Instant
Casting Time: 5
Area of Effect: 1 creature
Saving Throw: None

When this spell is cast at a creature, it breaches and dispels all of the specific and combat protections on the target creature. The target's magic resistance, if any, does not affect this spell.

The specific protection spells dispelled by Breach are: Resist Fear, Resist Elements, Death Ward, Free Action, Protection from Acid, Protection from Cold, Protection from Electricity, Protection from Fire, Chaotic Commands, Protection from Magic Energy, Protection from the Elements, and Protection from Energy.

The combat protection spells dispelled by Breach are: Mage Armor, Shield, Armor of Faith, Barkskin, Protection from Missiles, Spirit Armor, Stoneskin, Protection from Normal Weapons, Protection from Magical Weapons, Physical Mirror, Prismatic Mantle, and Absolute Immunity.

 

But it just seems to cause Near Infinity to crash.

I then used the Find References button and have attached the results (find references results.txt). No idea if thats of any help.

I also had a look in the PI logs and have attached the error logs for the SCS components that had errors.

@DavidW i've attached the stats.ids

I'll start uninstalling stuff and and let you know what i find

Thanks for all the help

 

find references result.txt ProjectInfinity-Weidu-Debug-stratagems-5900-Error.log ProjectInfinity-Weidu-Debug-stratagems-6100-Error.log ProjectInfinity-Weidu-Debug-stratagems-6510-Error.log STATS.IDS

Share this post


Link to post

@DavidW

Just to check, im probably being dumb, can i just uninstall scs and it will uninstall everything that was installed after it first or do i have to manually uninstall each mod that was in stalled after scs before uninstalling scs?

Sorry if stupid question.

Thanks

Share this post


Link to post

If you uninstall SCS, WEIDU will uninstall all the mods you installed after it - but then it will reinstall them after SCS is uninstalled. So it's better to uninstall all the ones after it first.

Share this post


Link to post
Posted (edited)
1 hour ago, DavidW said:

If you uninstall SCS, WEIDU will uninstall all the mods you installed after it - but then it will reinstall them after SCS is uninstalled. So it's better to uninstall all the ones after it first.

@Nathan82 If you want to expedite this process, what you can do is insert a fake component that does nothing into your weidu.log at the point that you want everything after to be uninstalled, then uninstall the fake component (which would uninstall everything after it as well), then terminate weidu and prevent it from reinstalling everything. Would just have to clear the uninstalled components from your weidu.log.

~STRATAGEMS/SETUP-STRATAGEMS.TP2~ #0 #8190 // Improved Minor Encounters: v33.1 <<< The final component you want to still be installed
~FAKEMOD/SETUP-FAKEMOD.TP2~ #0 #1 // Fake Component 1 <<< Uninstall this fake component
~FAKEMOD/SETUP-FAKEMOD.TP2~ #0 #2 // Fake Component 2 <<< Kill the weidu window (exit out, do not type "q" or "n") while it's sitting here asking if you want to install component 2
~FAKEMOD/SETUP-FAKEMOD.TP2~ #0 #3 // Fake Component 3 <<<
~SETUP-TURAMBAR_FIXES_TWEAKS.TP2~ #0 #12 // Inactive creatures fix: v1.8.1 BWP Fix <<< Erase everything in the weidu.log after the final component before the fake mod, starting here

...But that might be a little complicated/crazy for some people.

Edited by Bartimaeus

Share this post


Link to post

@DavidW I've uninstalled SCS and checked the spell description in NearInfinity and its still messed up and trying to read the descripion is still causing issues. I'll start a fresh install and do it in chunks and regularly check to see if i can narrow down whats causing the problem. I have a few other things to check for too.

Thanks for all the help from everybody so far.

Share this post


Link to post

I am reasonably sure that the mangled text in the spell description has been touched by SCS. So if it's still there when SCS is uninstalled, something went wrong in your install process and WEIDU didn't exit cleanly.

When that happens, you need to reinstall the game (or wipe it clean by replacing clean copies of chitin.key, dialog.tlk, and override, if you've got them). Just uninstalling the WEIDU mods won't do it

Share this post


Link to post

@davidw Im starting a completely fresh install. I've renamed the faulty install folder and i'll hang onto it for a bit to check couple of things but i always start from scratch.

I'll check the breach spell description in near infinity as i install mods to see if/when it gets corrupted.

Its just going to take ages.

3 SCS components installed with warnings last time so i'll probably install it one component at a time and ask if i get any warning this time apart from the Breach issue. Should i ask in this thread or start a new one in the SCS forum?

Thanks

Share this post


Link to post
1 hour ago, Nathan82 said:

3 SCS components installed with warnings last time so i'll probably install it one component at a time and ask if i get any warning this time apart from the Breach issue. Should i ask in this thread or start a new one in the SCS forum?

 

I don't mind.

Share this post


Link to post

I've found out which mod was causing the problem preventing spell selection at start of a new BG2 game.

It's the Improved Difficulty System from The Bigg Tweak Pack.

It's difficulty selection is the first thing that appears when starting a new game. I was selecting option 3 = Normal

Then after leveling up I was being prompted to change the difficulty to Novice or Normal and thats where the problem came in. Changing the difficulty via the slider in game options wasnt making a difference.

Once i'd found the mod that added the new difficulty system i had another look at the readme and tried changing that difficulty - press 'k' with AI on and it worked.

So i started a new game and selected option 2 = easy and i had no problems at all, spell selection dialogue appeared without me being prompted to adjust the difficulty.

The difficulty can then be set to after the game actually starts.

Thats one less problemto worry about now.

 

I've nearly got to the point of installing SCS, no issues with the Breach spell found yet. I've just seen version 33.2 released, i'll use that on this install.

Share this post


Link to post
Guest Guest

Nathan, thanks a lot for adding solutions to the problems you're meeting.

Share this post


Link to post

Guest, no worries. Hopefully it'll be useful to someone else too. I'll try and summarize everything once its working.

@DavidW I've found which component is screwing up the Breach spell and causing the crash.

stratagems:5900:Initialise AI components (required for all tactical and AI components)

It installs with errors too.

I've attached the spwi files and the error log. I'll put copies of the spwi files from before installing any SCS components in next post.

I'll try running change log again and see if it shows anything this time as well.

BTW, this is with version 33.2

Same problem happening with 33.1

Is it worth trying with some older versions?

Thanks

spwi513b.spl spwi513c.spl WAND18.ITM SPWI513.SPL ProjectInfinity-Weidu-Debug-stratagems-5900-Error.log

Share this post


Link to post

I got the chane-log to work. Its case sensitive, which i hadnt realised the first time.

I used this, this time and it actually worked.

WeiDU.exe --log nul --change-log SPWI513.SPL >change-log/change-log.txt --out change-log
WeiDU.exe --log nul --change-log spwi513b.spl >change-log/change-log1.txt --out change-log
WeiDU.exe --log nul --change-log spwi513c.spl >change-log/change-log2.txt --out change-log


(No one else noticed i done it wrong the first time either, before anyone calls me a donut 😀)

change-log1.txt change-log2.txt change-log.txt

Share this post


Link to post

OK, several observations:

1) Don't use the Improved Difficulty System component of BiggTweak with SCS v32 - it's obsolete. Its only function is to work around the hardcoded effects of the difficulty slider, but it's now possible to turn those off directly, and SCS already does that.

2) Why are you using Spell Revisions and SpellPack? They basically do the same thing - rearrange the spell system - and I'd have thought they're incompatible, conceptually and probably technically. (You can't really edit the spell system piecemeal - spells react to one another.) I strongly recommend using one or the other - and that being the case, I strongly recommend that the one you use is Spell Revisions, because it is currently maintained and SCS actively allows for it.

3) In any case, the change-log tells us that there is an incompatibility between the changes that SCS makes to Breach and the changes from Spell Pack and/or Spell Revisions. (It is not a bug with the SCS component itself, since I do an install test with BGT and Breach is working fine on an SCS-only install.) It's 99% likely that the incompatibility is with Spell Pack, since (a) it was installed later than Spell Revisions, and probably overwrites rather than patches spells; (b) SCS is explicitly aware of SR and allows for it, and I do SCS+SR install tests that seem ok. (Not on BGT, to be sure.) To test this, uninstall Spell Pack, reinstall SCS component 5900, and see if the problem recurs.

4) Assuming the issue is an incompatibility with Spell Pack, I'm not really interested in trying to fix it. Life is too short. It's not currently maintained; its latest version is many years old and only installs because of various third-party patches. (And compatibility with spell-system patches requires active design work mod-by-mod, it can't just be done by intelligent code.) My advice is to uninstall it. If you really want it for some reason, deactivate SCS's modifications to breach (via stratagems.ini; see the readme for details).

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...