Jump to content

Problems with BGT megamod install


Recommended Posts

31 minutes ago, DavidW said:

DSotSC introduces a new protective spell, Selune's Blessing, that is taken down by Breach. BUT it doesn't give that spell a name: instead it hardcodes the 'name' field of the spell to '34735'. I don't know why, as that string isn't 'Selune's Blessing', or anything similar, on any of the IE games. (The string 'Selune's Blessing' appears only in IWD2, and in a different slot). So this is a bug in DSotSC: the spell is misnamed.

Added this to the DSotSC bugthread, thanks!

Link to post
15 hours ago, Bartimaeus said:

one of them is being problematic in some extremely random and unexpected way

I think "mod didn't bother to set name field at all" pretty well qualifies for "problematic in some extremely random and unexpected way", :p.

Link to post

@Bartimaeus and @DavidW thank you very much for figuring this out, its much appreciated. I'll wait for new version of SCS before attempting another full install.

I think I just need to look at the stuttering a bit more and play around with stuff affected by aTweaks and see if any weirdness happens. If there are any specific requests relating to that let me know.

@jastey i was going to ask if this should be mentioned over on spellhold but you beat me too it.

Thanks again everyone

Link to post

@subtledoctor I think Guest means the issue with the new version of refinements causing a crash to desktop with mage character, either creating them or npcs joining, and the fact its not happening with the older 3.1 version. Working out which of the individual HLA components is causing the crash.

Link to post

@Jarno Mikkola and @jastey I've tried several times to install the stutter debug tool i downloaded using the link Jasyey provided above. The first time it failed due to lack of memory so i rebooted and tried again and got the following error;

Copied [YXYV25.BCS] to [override/YXYV25.BCS]
Copied [YXYVE.BCS] to [override/YXYVE.BCS]

[Z#1507.BCS.BAF] PARSE ERROR at line 20 column 1-25
Near Text: ActionOverride
    syntax error

[Z#1507.BCS.BAF]  ERROR at line 20 column 1-25
Near Text: ActionOverride
    Parsing.Parse_error
ERROR: parsing [Z#1507.BCS.BAF]: Parsing.Parse_error
ERROR: [Z#1507.BCS] -> [override/Z#1507.BCS] Patching Failed (COPY) (Parsing.Parse_error)
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Stutter Debug Tool -> Patching all scripts except NoAction() blocks - chose this when installing the first time (Installation could take a while!)], rolling back to previous state
Unable to Unlink [stutterdebug/backup/1/OTHER.1]: Unix.Unix_error(1, "unlink", "stutterdebug/backup/1/OTHER.1")
[stutterdebug/backup/1/UNSETSTR.1] SET_STRING uninstall info not found
Will uninstall 8252 files for [STUTTERDEBUG/STUTTERDEBUG.TP2] component 1.
  Restoring backed-up [stutterdebug/backup/1/II_MISC4R.BCS]
stutterdebug/backup/1/II_MISC4R.BCS copied to override/II_MISC4R.BCS, 886 bytes
Uninstalled    8252 files for [STUTTERDEBUG/STUTTERDEBUG.TP2] component 1.
Unable to Unlink [stutterdebug/backup/1/READLN.1]: Unix.Unix_error(20, "unlink", "stutterdebug/backup/1/READLN.1")
Unable to Unlink [stutterdebug/backup/1/READLN.1.TEXT]: Unix.Unix_error(20, "unlink", "stutterdebug/backup/1/READLN.1.TEXT")

Any idea whats gone wrong?

Should i try installing  LStest aswell and see if that gives a similar error?

Im trying to work out whats causing the stutter/lag when having certain bags of holding in a character's inventory.

The issue is affecting all party members. They temporarily pause for a fraction of  a second every 2 steps. Movement isnt cancelled, just slowed down a bit. Its also affecting animations. For example in High Hedge there is an animation of some sort of big bird flying overhead. When the stutter/lag causing bag of holding is in a chars inventory the animation stutters in time with party movement. As soon as the bag is dropped it goes back to normal. And its not all bags of holding that are doing it. The one addded to Thalantyr's store isnt causing a problem, the same as i have described previously.

 

Other odd things that are happening in current install;

Silke, in Beregost, cast cause moderate wounds on herself and no longer casts lightning bolt like she does in unmodded game. I had a look in near infinity and it doesnt look like she knows either spell so thats a bit weird. According to her .cre file (SILKE.CRE) i looked at in near infinity she has the following spells

Memorized spell: Spell: SPWI112.SPL (Magic Missile),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h
Memorized spell: Spell: SPWI111.SPL (True Strike),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h
Memorized spell: Spell: SPWI114.SPL (Shield),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h

Memorized spell: Spell: SPWI205.SPL (Horror),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h
Memorized spell: Spell: SPWI212.SPL (Mirror Image),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h
Memorized spell: Spell: SPWI212.SPL (Mirror Image),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h

Memorized spell: Spell: SPWI306.SPL (Hold Person),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h
Memorized spell: Spell: SPWI305.SPL (Haste),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h

Memorized spell: Spell: SPWI408.SPL (Stoneskin),Memorization: ( Spell memorized(0) ),Unknown: 00 00 h

Im going to guess ands say the lightning removal thing might be scs related but the casting cause wounds is a (hopefully) minor 'something went wrong somewhere' thing. Its only a small issue and isnt causing a problem, the cause moderate wounds thing just seemed weird. I guess im just expecting a lightning bolt and instead she buffs herrself then starts bashing people with a magic stick.

Level1npcs is doing something slightly strange in regard to druid spells. I have component 'level1npcs:1207:Jaheira' installed, mostly because i wanted to swap her staff proficiency points for something actually useful. Anyway, when she joins in the Friendly Arm Inn, she has the spells from unmodded game, such as cure minor wounds, then after levelling up for first time she gains the druid specific spells from the changes made by divine remix. Same thing when starting a bg2 game, when you first let her out of the cage she has generic spells then after levelling she has the druid specific ones as well. So i tested by creating a new fighter/druid PC and starting BG1 and that char has the druid specific spell selection only (ie no cure minor wounds, command etc). This isnt really a problem, just bit odd and i just thought i'd mention it.

 

Also, including 'BGSpawn:2:Vampiric Wolf Lord (inspired to DavidW Wolf of Ulcaster)NOTE: this changes some Vampiric Wolf in the game. It's used by BGSpawn-system' was a silly idea on my part. Getting chomped by a big red vampire doggo that randomly spawned in the middle of the road north of Nashkel was briefly amusing but also really annoying, there's not a lot a party of level 1 characters can do against that thing. Its a real pain in the arse fighting the one in Ulcaster, won't include that in next install.

Link to post
10 minutes ago, Nathan82 said:

[Z#1507.BCS.BAF]  ERROR at line 20 column 1-25
Near Text: ActionOverride
    Parsing.Parse_error
ERROR: parsing [Z#1507.BCS.BAF]: Parsing.Parse_error

Ah, that's too bad. There is a syntax error in a mod added script (for whatever reason) so the Stutter Debug Tool is choking on it. You'd need a more specific version which only patches e.g. baldur.bcs or other scripts in question. The Stutter Debug Tool is cool as it patches all scripts and the player doesn't need to edit the mod file manually, but in the current version it fails if it finds a syntax error.

I'm on my phone currently but will try to provide patching code for baldur.bcs later.

Link to post
26 minutes ago, Nathan82 said:

Z#1507.BCS.BAF

If we take this at face value; This is a usual file being bad in your file system... the game does not read files that have double extensions. The reason for it is that the doubling leads to above 8 character maximum in the lead up to the actual extension. Aka, one of the mods above installed and left a file in a sorry state as it didn't compile it properly, and left it with the double extension.

This can be fixed by the usage of the DECOMPILE_AND_PATCH rather than DE/COMPILE_BCS_TO_BAF.

Edited by Jarno Mikkola
Link to post

@Jarno Mikkola i ran chanre-log on the file and got the following;

Mods affecting Z#1507.BCS:
00000: /* created or unbiffed */ ~SETUP-SPGAUNT.TP2~ 0 0 // Spellhold Gauntlet1.16 BWP Fix
00001:  ~SETUP-SPGAUNT.TP2~ 0 3 // Interjections for Spellhold Gauntlet (dialogue by Liam)1.16 BWP Fix
00002: /* acted upon in an undefined manner */ ~GENERALIZED_BIFFING/GENERALIZED_BIFFING.TP2~ 0 1 // Generalized BiffingBiff all files (recommended by the Big World Dudes)v2.4


I had a look in both the main BGII-SOA foilder and my extracted mods folder for spgaunt and there is a Z#1507.BAF file in both.

There is a Z#1507.BCS file viewable in Near Infinity.

What, if anything,  can i do to fix the .bcs.baf thing in my current install?

Thanks

Link to post

So I've been experimenting with the stuttering/lag thing and have found some more strangeness.

I got a bag of holdi ng fro m Wintrope, in Candlekeep.

Walking around with the bag in inventory doesnt cause a problem. As soon as an item is added to the bag the game starts to stutter. Taking the item out, emptying the bag, does not fix the issue. Once the bag has been used, having it in a character's inventory causes stuttering/lag. Dropping the bag causes the stuttering/lag to stop immediately.

The same behaviour happens with the scroll case found on Gorion's corpse. No problem until it is used.

So i wandered around a bit with both containers unused but in inventory.

I then found doing a quest triggered the same problem. The retrieve the ring from the hobgoblins one at the friendly arm inn. I already had the ring when i spoke to the quest giver. Then once i spoke to her again she takes the item and the stuttering started.

So i tested with containers in inventory and dropped outside. If the quest is completed while the container arent in anyones inventory the stuttering doesnt happen, but if they are it does, and only stops when they are dropped.

I'll try installing LStest again tomorrow and testing again and seeing whether a script triggers or something stands out.

Has anyone else experienced this or seen anything similar? Or have any clue what the hell is going on?

 

Is there a limit to how much RAM that can be assigned to the game cache? Because the games were originally written for 32 bit Windows OS, is it limited to 2GB of RAM or am i being daft?

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...