Jump to content

Errors during Linux install, "cannot convert rcp_prof_<num>"


Recommended Posts

Ok, so I'm trying to install the item randomizer on mode 2, but every time it errors part way through, and each time the error is slightly different, but in a similar format. It'll go through ok until the debug log spits out something like this:
 

ERROR: cannot convert rcp_prof_<num> or %rcp_prof_<num>% to an integer
ERROR: [<creature>.cre] -> [override] Patching Failed (COPY) (Not_found)

<num> is something like 100 or 105, <creature> has been things like beast.cre and slapri.cre. These files always exist in my override directory of my install.

I've run tolower on everything, and while I do have some other mods installed, nothing too large or unusual (bg2fixpack, cdtweaks, level1nps, widescreen, and some romance mods).

Am I doing something wrong here? And what can I run/upload to help you figure anything out?

Link to post

I have a note in the code that it needs to be updated to account for IWD-style weapon proficiencies (from cdtweaks); do you happen to have that component installed? Or one of the other components that alter the proficiency system? I don't know if IWD-style proficiencies, or one of the other ones, would cause an installation failure. What is happening is that the mod reads proficiencies off the creature, and then encounters a weapon that uses numbers not found on the creature, or some other kind of mismatch between read values and assumptions made.

A complete .debug file from one of these failed installation attempts would be helpful.

Link to post
Quote

I have a note in the code that it needs to be updated to account for IWD-style weapon proficiencies (from cdtweaks); do you happen to have that component installed?

I did have one of the alternate proficiencies installed. It wasn't the IWD one, it was one of the options similar to original BG, with the broader weapon groups.

Quote

A complete .debug file from one of these failed installation attempts would be helpful.

Ok, so I deleted my original debug logs, uninstalled all the option from the randomizer mod, and ran it again with --debug-assign and --debug-value. But this time it went through, (somehow, despite having failed dozens of times with these exact same options before), and now I can't uninstall it again. Every time I try to run it, it jumps to asking me what mode I want, with the messages about skipping the randomization options saying "`This component is only meaningful if it is installed before the main component`" I can not get it to ask me which randomization options I want (or get it to fail trying mode 2, no loss) again, even if I go all the way through it and select "uninstall" when it asks me what mode I want. 😕

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...