Jump to content

help with different install error


kreon

Recommended Posts

I get the following bug when trying to install:

Spoiler

Install Component [The Wheels of Prophecy]?
nstall, or [N]ot Install or [Q]uit? i

Installing [The Wheels of Prophecy] [v8.3]
Creating 1 directory
Creating 1 directory
Creating 1 directory
Creating 1 directory
Creating 1 directory
Creating 1 directory
Copying 1 file ...
ERROR: error loading [wheels.tp2/lib/resource/weidu_external_readme.txt]
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [The Wheels of Prophecy], rolling back to previous state
Will uninstall   0 files for [WHEELS/SETUP-WHEELS.TP2] component 0.
Uninstalled      0 files for [WHEELS/SETUP-WHEELS.TP2] component 0.
ERROR: Unix.Unix_error(20, "stat", "wheels.tp2/lib/resource/weidu_external_readme.txt")
Please make a backup of the file: SETUP-WHEELS.DEBUG and look for support at: http://gibberlings3.net/forums/index.php?showforum=156
Using Language [English]

I only have Ascension & Tweaks Anthology installed. I had installed Spell Revisions, but I uninstalled it to install Ascension first.

I searched around and couldn't find this specific issue. Thought it might be a file permission thing, but I changed the permissions on wheels.tp2 and that didn't help. Also tried removing all the WoP files and re-extracting them to the BG2EE install, but no luck.

Any help would be great - thanks!

SETUP-WHEELS.DEBUG

Link to post
On 10/24/2020 at 3:27 AM, Guest ront said:

I think that the best question to ask if there is any ETA for the new version, given that the current version is not advised to be played by DavidW himself.

No ETA, sorry. Not imminent, though. 

Link to post

Hi there,

ERROR: Unix.Unix_error(20, "stat", "wheels.tp2/lib/resource/weidu_external_readme.txt")

It would seem that there is a typo in path: it should be "wheels/[...]" not "wheels.tp2/[...]". So, dirt fix but seem to work: copy the "weidu_external_readme.txt" file into a new directory tree as follow "wheels.tp2/lib/resource/" and re-launch setup-wheels.exe. If you're really lazy, simply copy "wheels" to "wheels.tp2".

Don't know if there is any side effect.

Link to post

Hi there,

ERROR: Unix.Unix_error(20, "stat", "wheels.tp2/lib/resource/weidu_external_readme.txt")

It would seem that there is a typo in path: it should be "wheels/[...]" not "wheels.tp2/[...]". So, dirt fix but seem to work: copy the "weidu_external_readme.txt" file into a new directory tree as follow "wheels.tp2/lib/resource/" and re-launch setup-wheels.exe. If you're really lazy, simply copy "wheels" to "wheels.tp2".

Don't know if there is any side effect.

Link to post

Hi there,

ERROR: Unix.Unix_error(20, "stat", "wheels.tp2/lib/resource/weidu_external_readme.txt")

It would seem that there is a typo in path: it should be "wheels/[...]" not "wheels.tp2/[...]". So, dirt fix but seem to work: copy the "weidu_external_readme.txt" file into a new directory tree as follow "wheels.tp2/lib/resource/" and re-launch setup-wheels.exe. If you're really lazy, simply copy "wheels" to "wheels.tp2".

Don't know if there is any side effect.

Link to post

Hi there,

ERROR: Unix.Unix_error(20, "stat", "wheels.tp2/lib/resource/weidu_external_readme.txt")

It would seem that there is a typo in path: it should be "wheels/[...]" not "wheels.tp2/[...]". So, dirt fix but seem to work: copy the "weidu_external_readme.txt" file into a new directory tree as follow "wheels.tp2/lib/resource/" and re-launch setup-wheels.exe. If you're really lazy, simply copy "wheels" to "wheels.tp2".

Don't know if there is any side effect.

Link to post
Guest At least 3 characters long

Not more than 10% sure what I'm doing, but modifying wheels\sfo\install_sfo.tpa beginning from line 22 from

   ACTION_IF !VARIABLE_IS_SET mod_root BEGIN
      OUTER_SPRINT mod_root "%TP2_BASE_NAME%"
      ACTION_TO_LOWER mod_root
   END

into

   ACTION_IF !VARIABLE_IS_SET mod_root BEGIN
      OUTER_SPRINT mod_root "%MOD_FOLDER%"
      ACTION_TO_LOWER mod_root
   END

Solves the install issue. Not up to the content to see how messed up it might be, but hey, it installed.

Link to post
Guest At least 3 characters long

Not more than 10% sure what I'm doing, but modifying wheels\sfo\install_sfo.tpa beginning from line 22 from

   ACTION_IF !VARIABLE_IS_SET mod_root BEGIN
      OUTER_SPRINT mod_root "%TP2_BASE_NAME%"
      ACTION_TO_LOWER mod_root
   END

into

   ACTION_IF !VARIABLE_IS_SET mod_root BEGIN
      OUTER_SPRINT mod_root "%MOD_FOLDER%"
      ACTION_TO_LOWER mod_root
   END

Solves the install issue. Not up to the content to see how messed up it might be, but hey, it installed.

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...