Jump to content

Issues Installing 33.7


Guest Cynrain

Recommended Posts

Guest Cynrain

Hey there, Im sure you've recieved plenty of posts like this one, but I'm having trouble with the latest release of SCS. Last year I had it running just fine, but had to do a fresh install of windows on my PC. Now i'm returning and re installing all my favourite mods, I find no matter what I do I can't get SCS to install the AI components. The error I get is as thus:

ERROR Installing [Initialise AI components (required for all tactical and AI components)], rolling back to previous state
Will uninstall 156 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
Uninstalled    156 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
ERROR: Failure("SPWI618.spl: read out of bounds")
Please make a backup of the file: SETUP-STRATAGEMS.DEBUG and look for support at: For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.

Is there any easy work arounds? I've tried copying and pasting the file in question into override and that hasn't helped. I've also had this error message show SPIN920.SPL as well, if that helps.

The only other mods I currently have installed are Ascension, Tweaks Anthology, and Unfinished Business in their proper load orders.

Thanks again!

Link to post

The error means that the spell file spwi618.spl (Spell Deflection) is corrupt and can't be edited properly.  Most likely, one of your other installed mods leaves it in a bad state.  From the command line you can run "weidu.exe --change-log spwi618.spl" to see which mods are affecting this file and could be causing this.

Link to post
1 hour ago, Angel said:

T...From the command line you can run "weidu.exe --change-log spwi618.spl" to see which mods are affecting this file and could be causing this.

You'll want to pause that to read it...

Aka, just make a new text file, copy this code into it:

weidu.exe --change-log spwi618.spl
pause

And rename the text file as "change-log.bat" ort what ever, and yes, for that you'll want to have the Windows file extensions shown, or use Notepad's Save As command and make it to overwrite the .txt extension with the .bat... and then you'll just run it as if it were a .exe in the game folder ... with a double click.

And after you have read the made text it makes, push the Enter button to exit it.

Link to post
9 hours ago, Jarno Mikkola said:

You'll want to pause that to read it...

Aka, just make a new text file, copy this code into it:


weidu.exe --change-log spwi618.spl
pause

And rename the text file as "change-log.bat" ort what ever, and yes, for that you'll want to have the Windows file extensions shown, or use Notepad's Save As command and make it to overwrite the .txt extension with the .bat... and then you'll just run it as if it were a .exe in the game folder ... with a double click.

And after you have read the made text it makes, push the Enter button to exit it.

I'm not a very big Windows guru, but don't you need to be in the BG installation dir for this?  I usually use a cmd prompt which doesn't close after a single command.

Link to post
1 hour ago, Angel said:

I'm not a very big Windows guru, but don't you need to be in the BG installation dir for this?  I usually use a cmd prompt which doesn't close after a single command.

You are already there when you run the .bat (in the game directory/folder 😋 ).

Link to post
Guest Cynrain

Hello again, apologies for the slow reply. I have run the .bat file as requested and it came back with this:

G:\Baldur's Gate II - Enhanced Edition>weidu.exe --change-log spwi618.spl
[weidu.exe] WeiDU version 24700
[.\chitin.key] 189 BIFFs, 62285 resources
[.\lang\en_us\dialog.tlk] 117862 string entries

 

Mods affecting SPWI618.SPL:

G:\Baldur's Gate II - Enhanced Edition>pause

It doesnt seem to be coming up with anything... Should I try and acquire some new spell files from another source? I will add that this version is the GOG version, patch 2.5.16.6

Thanks again for your assistance

Link to post
Guest Cynrain

Going to try and do a fresh install of BG2EE, and only have strategems installed to see if it works then... and then somehow get ascension into the mix.

Link to post
23 hours ago, Guest Cynrain said:

G:\

Is this from an external hard drive ?

Also, the --change-log only notes down any weidu mods, so the use of other editing tools and so forth won't show up. Nor will they if you uninstalled/remade the game before you made the log...

Link to post
Guest Cynrain

It is a secondary hard drive, but internal.

So I did a fresh install, SCS installed fine. I did some more testing and found it was Ascension that is creating the issue. Is this common? Is there a version of ascension that works better with 33.7?

Link to post
Guest Cynrain

Ended up fixing the issue with some more testing, installed SCS first up until the problem area, then quit. Installed all other mods and then finished the rest after, works just fine :) Thanks for the assistance everyone ^^

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...