Jump to content

How can mods be compatible with 2.5 and 2.6 simultaneously?


Recommended Posts

Greetings, all!

I assume mods can be compatible with 2.5 and 2.6 simultaneously if the mods are updated.  Still, in general, how can mods be compatible with 2.5 and 2.6 simultaneously if they can be?

Thankee!

Link to post

There is no “in general” answer. Several of my mods are broke because of some changed labels in splprot.2da. So I need to change a line to be more inclusive: from

PATCH_IF (~%label%~ STRING_EQUAL_CASE ~STATE~) BEGIN

to

PATCH_IF (~%label%~ STRING_EQUAL_CASE ~STATE~) OR (~%label%~ STRING_CONTAINS_REGEXP ~statebits=n~ =0)
BEGIN


Easy-peasy: now it works on both patches. 

But other mods may have completely different issues, which may not be amenable to such simple solutions...

Edited by subtledoctor
Link to post
6 minutes ago, subtledoctor said:

But other mods may have completely different issues, which may not be amenable to such simple solutions...

And I am sure there's tons of mods that don't need any thing at all.

Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...