Jump to content

Troubleshooting


Recommended Posts

Hello there!

First, thanks for all the work, moderation, determination, etc. in not only making this engine, but keeping it going for numerous decades. You deserve a very thorough "Thank you! You're amazing!" from the community at large.

I've recently been attempting to install GemRB locally on my x86 Fedora 35 system. I compiled from source, which so far seems successful, but I still haven't been able to get the demo running. I made some progress, but have gotten stuck at a point where I'm not sure how to point the system in the right direction. I've attached my terminal output upon attempting to execute the binary, as well as the .cfg I'm calling.

I'm posting this with my phone, so apologies if format, grammar, etc. are a little off. Appreciate any insight and thanks again.

GemRB.cfg terminal_output

Link to comment

I see you tried latest git. It works for me now, but there have been hundreds of changes in the past few days, so I suggest you first update to the latest code.

At minimum you'll have to bump the resolution.

I also see a bug in one way to run it, investigating.

Link to comment

I re-merged and cloned last night before trying it again. This time, I didn't install locally but attempted to run from build, as you may have noticed. Followed the input on your development doc for compilation.

Ran the "-j3" argument with make.

I tried 800x600 at one point, as well as fullscreen. Crashed with same errors iirc.

I'll make sure and update all before I try again tonight. Interested to hear what you think.

Thanks!

Link to comment
cat > demo.cfg <<KUKU
GameType=demo
GamePath=../demo
GemRBPath=../gemrb
PluginsPath=./gemrb/plugins/
Width=800
Height=600
KUKU

You can generate a minimal config with that and then pass demo.cfg to gemrb.

Link to comment
Quote

  Looking for Freetype: not found!

  Looking for libPNG: not found!

  Looking for Ogg Vorbis support: not found!

The demo needs all these optional plugins, so install development files and rebuild.

Link to comment

OK, re-merged, fetched, updated, and installed devel packages I missed. Recompiled as above and the demo launches and runs. Thanks for your input lynx. Looking forward to helping out if I can. Will start testing around on the demo. Is IWD2 the most efficient play testing at the moment?

Link to comment

You caught us at a bit unstable time, as there are several regressions and bold changes, but that also means testing is even more welcome (just check the tracker before reporting). Eg. you'll probably see missing text in the demo (#1508).

As far as playtesting efficiency, I'm not sure what you mean, but any game is game.

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...