Jump to content

Adjusting difficulty levels (IWD2)


Recommended Posts

Currently playing IWD2 on Insane (I think it's called that, it's the rightmost setting) and having fun with the extra OPPONENTS... 

But... 

I'm wondering if it's possible to adjust the extra damage setting somewhere... The going is just a bit too slow. Too much healing needed 😅

So basically I want all the monsters but not the extra damage.

Link to comment
3 hours ago, Bubb said:

Open icewind2.ini, add the following under the [Game Options] section:

Suppress Extra Difficulty Damage=1

Does this actually work for IWD2? I know it works for IWD1, but for IWD2, the game resets it to 0 when loading a game or opening the Options menu. I didn't notice a damage difference either, but maybe I was testing it wrong (this was months ago so it's not fresh in my mind right now).

Link to comment

Hmmm... I made the change to the ini and went to battle with Vrek Vileclaw.

He did 32 slashing dmg on a crit and 18 damage on a normal hit.

Looks like he has 1d4S claws and a high str...

Ork archers suspiciously only do even damage when they (rarely) land a hit.

Looks like it doesn't change anything 😕

Edit: The setting is retained in the ini file, but doesn't look like it does anything.

Edited by Green Knight
Link to comment
15 hours ago, Bubb said:

You're right — the option's code is still in the engine, but the game immediately discards the INI value and sets it to 0. I've attached a mod that restores the INI option, though since it might have been intentionally disabled I don't know if it will cause problems.

bubb_unlock_iwd2_suppress_difficulty_damage.zip 1.21 MB · 5 downloads

Installed it, then went to battle with some Worg riders (quite a few actually) outside the Fortress.

My party was struck 3 times, for 18, 18, and 12 damage.

So I'd say the fix probably didn't work.

Link to comment

Well, it works in my tests, and I've stepped through the game in a debugger to confirm that. Make sure you:

1) Are installing it on the latest IWD2 patch version, v2.01.

2) That the option is under the [Game Options] section.

3) That the INI value didn't get reset from last time.

4) That there's only one instance of Suppress Extra Difficulty Damage in the INI.

If it still isn't working, could you upload your INI for me to test.

Link to comment
2 hours ago, Bubb said:

Well, it works in my tests, and I've stepped through the game in a debugger to confirm that. Make sure you:

1) Are installing it on the latest IWD2 patch version, v2.01.

2) That the option is under the [Game Options] section.

3) That the INI value didn't get reset from last time.

4) That there's only one instance of Suppress Extra Difficulty Damage in the INI.

If it still isn't working, could you upload your INI for me to test.

Looks like I found the culprit: there was already an instance of Suppress Extra Difficulty Damage=0

(thanks for the assistance - and patience)

Edited by Green Knight
Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...