Jump to content

Weird blocks in fog of war


Recommended Posts

Hello there,

 

I just registered an account for this issue because I cannot find a solution to my problem. I tried to play Baldur's Gate 1 and installed the widescreen mod (and gui mod). But I get some kind of weird blocky artefacts at the edges of unknown territory and fog of war. It is not resolution specific. I tried multiple (1280x768, 1920x1080, 1280x800 on a different PC). I also tried it without the gui-mod. I googled for days but can't find any posts anywhere which mirror my exact problem, nor can I find a solution. I tried to use the ingame graphics menu and played around the options with no luck.

You can see for yourself on the following link:

https://ibb.co/q5knYKs

 

If it is important. I am on Windows 10 and used the Gog-Version.

I would so much appreciate any help about this, even though I have seen this subforum isn't that active anymore.

Cheers

Edited by Buntstift
Link to comment

You need a ddrawfix mod. I would recommend cnc-ddraw:

If that doesn't work, there's also:

  • http://bitpatch.com/ie_ddrawfix.html – you need to open "ddrawfix/ddrawfix.tp2" in a text editor after extracting and remove the "FAIL ~Only x86 systems supported.~" line for it to install. Use the OpenGL option when prompted after running "setup-ddrawfix.exe"

and:

Link to comment
5 hours ago, Buntstift said:

If it is important. I am on Windows 10 and used the Gog-Version.

That must be a very old version of the GoG game installer, cause the newer versions come with one of the fixes preinstalled... for this very reason.

Link to comment
17 hours ago, Jarno Mikkola said:

That must be a very old version of the GoG game installer, cause the newer versions come with one of the fixes preinstalled... for this very reason.

It's the latest version I can download from my GOG-library. I downloaded it via Galaxy and also tried the offline installer from my library and I get the issue in both instances.

Is there probably an ini file or a dll which  this fix is applied to preinstalled I can look out for?

 

18 hours ago, Bubb said:

You need a ddrawfix mod. I would recommend cnc-ddraw:

If that doesn't work, there's also:

  • http://bitpatch.com/ie_ddrawfix.html – you need to open "ddrawfix/ddrawfix.tp2" in a text editor after extracting and remove the "FAIL ~Only x86 systems supported.~" line for it to install. Use the OpenGL option when prompted after running "setup-ddrawfix.exe"

and:

Thanks a bunch for these suggestions.

I tried the cnc-ddraw first but I can't seem to get it work. I tried it without changing any settings first and get an error and I tried playing around with the settings and still get the same error. It always says:

An Assertion failed in D:\Dev\chitin\ChVideo.cpp at line number 4256
Programmer says: No valid video modes supported

 

Then I tried the 2nd suggestion. Funnily enough I tried this before because it was a random suggestion I found on pcgw. But I thought it didn't work at all because I got the exact error you said I should delete from the tp2 file. So I did. I chose the 2nd option (WineD3D DDraw Library) and then my game proceeds to not start anymore. I get the famous windows "X is not responding" error and I must kill the game via task manager. I tried the 1st option out of curiosity (DirectDraw Emulation) and the game does start and yes my blocky  graphical issue is gone (yay!) but now I get flickering throughout the game. :( The sort of flickering like my desktop background shines through at random places.

Will have to try my luck with the third option now.

Somehow I can see why people feel attracted towards the Enhanced Edition.

Link to comment
1 hour ago, Buntstift said:

I tried the cnc-ddraw first but I can't seem to get it work. I tried it without changing any settings first and get an error and I tried playing around with the settings and still get the same error. It always says:

An Assertion failed in D:\Dev\chitin\ChVideo.cpp at line number 4256
Programmer says: No valid video modes supported

Hmm, strange. I'm using cnc-ddraw in my current oBG setup without problems. Maybe try it with the attached settings files, (which have been ripped straight from my working install)?

Edit: Also, the attached "Baldur.ini" assumes your game is installed at "C:\Program Files (x86)\GOG Galaxy\Games\Baldurs Gate". If you have moved your game install you need to open "Baldur.ini" and change the [Alias] lines to match the new path.

settings.zip

Edited by Bubb
Link to comment

Thanks, appreciate the effort!

I used both your ini files and at least get another error now 😁

 

An assertion failed in D:\Dev\chitin\ChDimm.cpp at line 581
Programmer says: Unable to OPEN BIF:DATA\SFXSOUND.BIF

☹️

Link to comment
9 minutes ago, Buntstift said:

An assertion failed in D:\Dev\chitin\ChDimm.cpp at line 581
Programmer says: Unable to OPEN BIF:DATA\SFXSOUND.BIF

Sounds like the [Alias] lines got messed up. If you still have your original "Baldur.ini" try copy+pasting everything under [Alias] from the original file to the new one (replacing what's there). If the original is gone it might be best to try things again from a clean game install.

Link to comment

Okay.

Tried your Baldur.ini with [Alias] paths corrected. I get the first error again:

An Assertion failed in D:\Dev\chitin\ChVideo.cpp at line number 4256
Programmer says: No valid video modes supported

This is independent of the ddraw.ini. I get the error with my ddraw.ini and with yours.
Verified this with a clean game install.

Also I am not super into the technical stuff, but in that Baldur.ini is mostly settings stuff? I compared yours and mine and the only (in my opinion) notable differences (aside from music volumes, mouse settings and such) were:
Path Search Nodes=400000 (vs 4000 in my ini)
CacheSize=1024 (vs 240 in my ini)

Link to comment

Okay another Update:

I tried the third suggestion (ddwrapper) and played around with the ini. I set "ForceDirectDrawEmulation = 1" and this  fixed the blocky shadows. But I get the same flickering issue that I get with ie_ddrawfix. I was reading around ddwrapper some more and found a reddit thread about it and BG1 with the suggestions to also set "NoVideoMemory = 1" and tweak two ingame settings. But sadly this didn't help with the flickering either.

 

I somehow believe the best solution would be the ie_ddraw fix (Wine3d / OpenGL) one, but my game refuses to load at all when I use that option for some reason. I tried compatibility mode on the .exe file and whatnot but I am completely out of luck. :( It just won't load / respond. I also don't think the fault is on my end for the reason that I tried to get the game working on two different PCs with the same errors.

Not even angry at this point, just disappointed.

Link to comment
8 hours ago, Buntstift said:

Okay another Update:

OK, so when you say the screen flickers, is it the screen or the spot where the mouse cursor has been ?
If it's the later, this should fix it: "You could try disabling Hardware Mouse Cursor in Options>Graphics. "


There's a few different versions of similar issues.
If it's the whole screen, ... do you use the the Widescreen mod ? Some of the games, like the Icewind Dale, flickers for some reasons on specific display on a specific resolutions. Choosing a different resolution will fix the issue.

Link to comment

No it is different than in the video. The flicker I get is occasional for a fracture of a second. It seems like a knife cut through the screen for that specific time frame and you can see my desktop or opened folders "behind" the game. I can't force it to happen. It happens on its own. But it is independent from widescreen mod. It happens because of no.1 option in ddraw fix: Force DirectDraw Emulation.

 

Since you mentioned Icewind Dale I did install that game as well (via gog). Ddraw fix is installed automatically in this game somehow and it installs the 2nd option (Wine3d). Game runs fine, even with widescreen mod. Small GUI though and I can't seem to stretch lower resolution to fullscreen. It's always with black bars on top and bottom except when I choose desktop resolution.

I compared Icewind Dale and Baldur's Gate ddraw fixes and because of my limited knowledge I didn't get far so I just copied the Icewind Dale ddraw fix to my Baldur's Gate folder but I get the same result sadly. Game won't start and does not respond and I have to kill it via task manager. I find it  funny because Icewind Dale comes with a script file that installs ddraw fix succesfully

 

Quote

@echo off
setup-ddrawfix.exe --noselfupdatemsg --force-install 2
exit

 

If I run it manually I get the "FAIL ~Only x86 systems supported.~" error. If I copy the script to Baldur's Gate I still get the error. The script does only work via the Icewind Dale install. If I delete the entry and run it, it's like the individual ddraw fix: game won't start and respond.

 

Amazing. 🥲

Link to comment
58 minutes ago, Buntstift said:

. It's always with black bars on top and bottom except when I choose desktop resolution.

Erhm, what option do you have selected in your video cards control panel ? In the so called "Adjust desktop size and position"(well, it's called that in a NVidia Control Panel) ? Mine is "Full-screen", while your sounds like it's "No Scaling".
Or that you didn't actually get into the actual game, which is what the widescreen mod is for, the ability to view larger portion of the game enviroment when it's available.

Edited by Jarno Mikkola
Link to comment

I have selected "keep aspect ratio". But I tried "no scaling" and "fullscreen" as well, it does not change anything. It only fills the screen when I choose 1920x1080 and it looks like in this screenshot from wsgf .

I initially thought this was borked because when you look at the bottom row or the right side of the GUI you see the same tree branches textures repeated next to each other. I guess it is because there is no extra GUI mod like for Baldur's Gate. Now I think this is working like intended. Still the text is too small for my liking, but that's maybe just me.

Still my BG issue prevails

Link to comment

Okay another update: I was finally able to film the flickering issue. You can see it here . It is a download link. I wanted to attach the file (30MB mp4 video) but it is too large and I have no idea where to upload video files anonymously so I chose this method.

You can see it flickers in the main menu (and the intro which I skipped) but it stops after loading screen. I didn't want to film for several minutes. I can basically wander around for minutes and then suddenly the flicker starts again.

Is this normal behavior for the 1st option in ddraw fix?

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...