Jump to content

Baldurdash dialog.tlk and BG1NPC


Recommended Posts

Hello! I have been lurking now for several years on both the G3 and Tutu boards, reading and enjoying the byplay of serious, dedicated people actively creating and improving an already strong role-playing experience. I have immense respect for the amount of time and frustration you folks willingly spend getting the details right. Thank you!


I have been trying to find a solution to a seeming BG1NPC difficulty on my installation that appears to not have been discussed. On Tutu, the question of Baldurdash/Not Baldurdash has been asked several times on several forums, and with the exception of a potential conflict with the Journal components (which I do not install) the documentation has made it clear that Baldurdash before Tutu conversion is good/required/important. The documentation seems to indicate that “To Baldurdash†is to include both bugfix and the textfix/dialog.tlk which comes with the package. This becomes extremely important, as Macready’s new work (http://forums.pocketplane.net/index.php/board,46.0.html) on an easy install includes both Baldurdash and textfix/dialog.tlk. Here is my observation:


On the past several versions of BG1NPC (v4, 5, 8, 9) I had no problems with Tutu and BG1NPC installation, but ran into a dialogue problem which made me nervous. Black Talon and bandits at K’s Caravan shout ending dialogue entries talking about Duke Reitan when hit; Zombies in Garrick’s quest spout random text when hit. Several times, strange dialogue is displayed on some animals on weapons hit. Most posts dealing with this problem talk about incomplete installs, savegames with mods in different orders, mods which overwrite dialogue.tlk after Tutu etc., etc. Carefully checking each thread and following suggestions made me more nervous about proceeding; each version I ended shortly after Cloakwood because I couldn’t see putting in the roleplaying time only to find hopelessly scrambled strings during endgame. Two years of a two month cycle of uninstall, retest, research, install, retry… I guess I should have just jumped in and learned to mod in order to troubleshoot! Of course, the boards and your excellent work made me want to continue to try, instead of just a vanilla Tutu+Tutufix run.


Since Tutu v4 and Tutufix v15 seem to be the last version (and some time will pass before BG1NPC can approach the chapter globals/bugfix changes in Tutu v6), I thought I would just try it out and see what happened, regardless of consequence. I really want my buddies Minsc and Kinven to bring Boo to the Big City! So I started by making a mistake.


WeiDU 185

BG1TOS (verified install via VB file posted in forums at Pocketplane)+Badurdash


Convert via TUTU v4 (54%)

TutuFix v15 (core bugfixes, Imoen to Swashbuckler)

BG1NPC v11 (only Phase I and II)

TutuGUI v1.5

New Game: created character

EUREKA!!! Bandits and Black Talon spawn; no strange dialogue. Garrick wastes the zombies with only the ordinary strange talk (duuhhhhh….). Awesome run through Cloakwood, and two levels of Durlag. Happy playing until I realized that I had forgotten the dialogue.tlk installation from Baldurdash – should have guessed when Cliff Boy didn’t talk about the missing diamond as his reason for jumping. I should have left well enough alone, but I stopped, and:


Uninstall; Reinstall (complete; replaced from vanilla clone on another drive)

WeiDU 185

BG1TOS (verified install via VB file posted at Pocketplane)+Badurdash+Textfix


Convert via TUTU v4 (54%)

TutuFix v15 (core bugfixes, some NPC kits, BG2 Worldmap only)

BG1NPC v11 (only Phase I and II)

New Game: created character

With Baldurdash and with textfix = old problem reappears.



The question I should have asked two years ago is:

Do you folks at BG1NPC use Baldurdash+text update, or only Baldurdash bugfix? If you do use the textfix, how can I go about correcting/troubleshooting the problem that appears on these (multiple, both clean and shortcutted via Pocketplane info) installs? If you don’t use it, is there work that can be done/I can learn to do to fix this before Macready’s EasyInstall program becomes more prevalent?


Thank you again for all your hard work.

Link to comment

I play and mod without the text fixes. I don't think I am competent enough to advise on how to fix those strings in an intelligent way; one of the WeiDU gurus, Cam, or Sim are probably the best people to talk to. :D

Link to comment

It' very odd that the Game Text Update (GTU) would cause a problem like this. The string references themselves don't change*, only the contents of the strings. So an incorrect pointer in a sound reference/dialogue/description/etc. should be incorrect whether the GTU is present or not. The only way I can conceive of such an issue occurring would be using the TotSC version of GTU on a non-TotSC install or vice-versa.


* I can provide boring technical details if someone wants. But you probably don't.

Link to comment

Lord, you people are fast -- thanks!


Checked the


BG1 (TOS, 3 disc, USA distribution)




and the TOB materials as well.


I will download new copies of the GTU again to be sure, and test.

As my problem hasn't been reported, my personal fix is easy: follow Domi (anywhere!), drop the GTU, and use BG1NPC.

Of course, if my checked and rechecked TOS install is not truly a complete install in some way even after converting correctly...

perhaps I had better go buy another copy and test it as well.


To confirm: in a complete and correct install of Tutu, including the TOSC Game Text Update, BG1NPC v11 should (and does) operate without this error?

Link to comment

I can't say with 100% surety about Garrick's zombies - we had a few oopses like that before, when there were no strings assigned, but I do not recall the game characters spouting wrong strings on my virginal install.


Cam, one thing I was blaming the problem for a while was the SUBCOMPONENT option. Am I just being paranoid?

Link to comment

Shouldn't be SUBCOMPONENTs--it's really just a call to make WeiDU have flashy menus. (Well, flashy for a DOS box. :D )


I'd be curious to see if cmorgan's issue is caused by either BG1 NPC or Tutufix. I'll caveat this by saying that I run a fairly close Tutu setup to what cmorgan has described (Tutu, Tutufix, BG1 NPC, TutuGUI, Baldurdash & GTU for both BG and BG2, and a few other mods like Tweaks) without experiencing this problem. It may also be that my assumption that no strref's are changed in the GTU for BG Baldurdash is incorrect.

Link to comment

CamDawg, if you are running a similar setup and do not have this problem, it has to be something that I am doing/something wrong with my specific discs/install.


Last night I downloaded new copies of everything, got the latest WinZip, defragged, rebooted to vanilla WinME SE, cleared out all background problems, did a complete reinstall (following my traditional procedure, above) carefully checking CamDawg's suggestions re:TOSC Baldurdash dialog.tlk; still the same strange responses on the Black Talon/Bandits created at the Caravan.

Gnashed teeth; then had a brainstorm --

Macready's install is a working program with Baldurdash and core v15 fixes. So a simple test of this being just my materials or a true potential bug might be to compare differences between EasyInstall and my installation. Plus, I could do it now and not wait for a week for a new copy of TOS to arrive from eBay.

Downloaded EasyInstall program, ran it, added the rest of my traditional modifications, and before I bothered to begin comparing files between the two, created a fighter and ran him down to the Caravan -- whacked away -- no strange dialogue.

I will test this weekend, trying to recreate the problem with Garrick's zombies and comparing files, but the good news appears to be that my problem is pretty unique, and can be solved for others by having them use the EasyInstall program. (Wish I had thought of testing this out on another disc set before posting, but then again i wouldn't have thought of it without this discussion!).

Link to comment

Thank you so much for posting! It is very important to know the way to troubleshoot the problems, especially the puzzling ones like that. I would appreciate it very much if you give a quick update as to if everything functions properly. :D

Link to comment

Did some playtesting this weekend. Using EasyInstall Tutu and usual cast of mods, taking several NPCs out for a walk and laying waste to the countryside (NOT my usual paladiny playstyle!) created no strange dialogue at all. Baldurdash dialog.tlk GTU is complacently cohabitating with BG1NPC v11; the zombies, sirenes, animals, and bandits all fine. I am a happy adventurer, looking forward to the epic experience!


Still working on the local direct installation problem (if nothing else, in appreciation for the work done by the various modders; plus, you learn lots from the behind-the-scees read). Because MacReady's install program does not include a setup-tutu.debug file, I was unable to look for differences between the two conversions the "easy" way, so next weekend's project is to try some detective work between the .tp2 and the actual dialog.tlk files to see where the problem is. Time to become conversant in the tlk tools...

Link to comment

As I understand it, Macready's installer was built from a TOS installation, which means the error would have shown up there as well as on my installation. EasyTutu has also had confirmation of a working install from a 5 disc original + TOSC user.


That being said, if someone PM's me a clean, patched but un-BD'd dialog.tlk from a 5 disc original + TOSC, I should be able to use weidu –tlkcmp to see if there are any differences between the versions.


I am still hung up on the idea that somehow the "sound only" (3) string references were messed with and overwritten with text. That would match up with text displayed only when hit... I just don't know how.

Link to comment

Well, good news and bad news (no spoiler info included in this post).

The good news is I have been able to make it to 6th level, clear much of the southern Sword Coast, and pick up lots of NPCs with no problems before beginning Cloakwood. The bad news...

I spoke too soon about Garrick's quest. While the bandits at the caravan (Kaigan's dudes) worked fine without Kaigan in the party, and I was unable to replicate any errors in dialogue at first, I just took a break from deciphering strrefs to play a little. Got a great run, including beginnig Dynaheir's romance, but hit the same problem with the EasyTutu (Baldurdashed) that I had with my own installation:

"GQ" begins fine, until combat is initiated. The Zombies, however, seem to think that they are respondents (and journal travelogue interpreters!) in the Albert's Doggie Quest. I cannot tell if it is text displayed due to a Zombie action or due to a successful hit.

Since I finished Albert's quest before Garrick's, and the spawned Zombies look like special spawns, I am going to hope this is not a scramble problem which will be a game-stopper. I am, however, requesting knowledgeable help -- it is a little unnerving to see a card-carrying member oof the Undead say "Thank you vewy much..."


Edit: A check of the X#GARZ01.DLG has strref 50543; nothing seems amiss. The X#GARZ01.CRE (and the other three .CRE files), however, have SOUND:DAMAGE = "I have met a child named Albert..." and SOUND:DYING = "You will? Oh, thank you vewy much...".

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...