Jump to content

Problem using gemrb with BG1


Recommended Posts



I downloaded and installed correctly gemrb (I'm on Linux). I made a wine installation of BG1 in ~/.wine/drive_c... and put the 5 CDs in /mnt/divers/BG/CD{1,2,3,4,5}, and put this in /usr/local/etc/gemRB.cfg :


GamePath=/home/nico/.wine/drive_c/Program Files/Black Isle/Baldur's Gate/







But game fails to start :


nico@detritus:~/.wine/drive_c/Program Files/Black Isle/Baldur's Gate$ gemrb -c /usr/local/etc/GemRB.cfg

GemRB Core Version v0.2.6 Loading...

[Core]: Initializing Variables Dictionary...[OK]

[Core]: Loading Configuration File...Loaded config file /usr/local/etc/GemRB.cfg


[Core]: Starting Plugin Manager...

[PluginMgr]: Loading Plugins...


[Core]: Initializing Resource Manager...

[KEYImporter]: Opening /home/nico/.wine/drive_c/Program Files/Black Isle/Baldur's Gate/chitin.key...[OK]

[KEYImporter]: Checking file type...[OK]

[KEYImporter]: Reading Resources...

[KEYImporter]: BIF Files Count: 141 (Starting at 24 Bytes)

[KEYImporter]: RES Count: 15237 (Starting at 4241 Bytes)

[KEYImporter]: Resources Loaded...[OK]

[KEYImporter]: Searching for gemrb.INI...[ERROR]


Cannot Load INI

Termination in Progress...

[KEYImporter]: Searching for defsound.2DA...[ERROR]

Press enter to continue...


Anyone can help ? The game works fine under wine.



Link to comment
The ini file should be in the <gemrbpath>/override/<gametype> path in the filesystem.

Maybe you need to set the GemRBPath config parameter too.


OK, it worked : I had to put


bt this was documented as "the full path to the GemRB executable". Strange. The executable is of course in /usr/local/bin, But anyway, It works now. Well, not completly : I can't change options, and I can't see my save files. I'll try to refine my config file later.


Thanks for the tips.



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...