Jump to content
Sign in to follow this  
Guest SleepingDog

Game crashes / freezes when entering the new area

Recommended Posts

Guest SleepingDog

Got the same problems. Loads the area, hear a bit of music and then the screen either locks or crashes. Using v21 and have done the uninstall/ install procedure. Gone back to old save games. None of it works so I am stuck.

 

I did use Amber v11 way back and I did not have this problem.

 

Despite the problem this is an excellent mod.

Share this post


Link to post

This issue has followed us through different versions. Only thing I've managed to do in order to get rid of it is ensuring that the user does not close the installation screen too early and thus prevent the audio & tilesets from unpacking.

 

Can you hear Amber's voicing?

Can you hear Amber's custom music during her talks?

What operating system you have on your computer? (So far there hasn't been any pattern on certain windows version failing to unpack audio or tilesets, though.)

 

You can't see the area, right? In other words: the game crashes / freezes on the load screen?

 

If the game crashes/freezes to the load screen:

 

1. If you look inside the override folder (that's in the main bg2 folder) is there m#ar01.tis or .tiz file in there?

 

2. Can you uninstall and install Amber again once more? When you are asked if you want to install the second component (multiplayer friendly flirting), can you take a look the possible error text that's displayed on the install window above it? The audio and tileset files are unpacked before the second component, but by a separate bat file and thus the possible errors are not printed to the weidu.log.

 

If the game crashes/freezes after the area had loaded and not to the load screen:

 

Then it's strange. The first area should not have any trouble locating the ambient and it didn't crash on mac either.

Share this post


Link to post
Guest SleepingDog
This issue has followed us through different versions. Only thing I've managed to do in order to get rid of it is ensuring that the user does not close the installation screen too early and thus prevent the audio & tilesets from unpacking.

 

Can you hear Amber's voicing?

Can you hear Amber's custom music during her talks?

What operating system you have on your computer? (So far there hasn't been any pattern on certain windows version failing to unpack audio or tilesets, though.)

 

You can't see the area, right? In other words: the game crashes / freezes on the load screen?

 

If the game crashes/freezes to the load screen:

 

1. If you look inside the override folder (that's in the main bg2 folder) is there m#ar01.tis or .tiz file in there?

 

2. Can you uninstall and install Amber again once more? When you are asked if you want to install the second component (multiplayer friendly flirting), can you take a look the possible error text that's displayed on the install window above it? The audio and tileset files are unpacked before the second component, but by a separate bat file and thus the possible errors are not printed to the weidu.log.

 

If the game crashes/freezes after the area had loaded and not to the load screen:

 

Then it's strange. The first area should not have any trouble locating the ambient and it didn't crash on mac either.

Share this post


Link to post
Guest Guest

Apologies for the above post - I pressed the wrong key.

 

Yes to Amber's voicing.

Yes to ambient music.

Windows XP.

 

No it freezes after the load screen. I can see the area and I can see two goons facing my party and if I am quick enough I can set a destination for the party to move to using my mouse. I can also hear for a moment or two some background sound. (Sometimes it crashes rather than freezes).

 

It's a tis file.

 

I get the mesage:-

 

"unpacked 229 tiles with method 0, 0 tiles with method 1, 250 tiles with method 2".

Share this post


Link to post
Guest SleepingDog

It appears that the problem disappears when I remove the Spell Refresh mod so it looks like that this may be incompatible with Amber.

 

Thanks for your help.

 

Regards.

Share this post


Link to post

Okay, then it's not the 'tilesets-not-unpacking'-problem. (I'm sort of glad that it isn't.)

 

Since this a different issue than the one that was discussed in this thread previously I'll try to split this to a separate topic in order to avoid any confusion.

 

If you try to pause your game immediately when you enter the area what happens?

 

The only thing that's changed from v 1.1 to 2.1 in that area specifically is the area script and the script of one of the character in that area. I've tested both, though, and they work fine on my game. There is a know issue with script trigger AreaCheckObject() crashing the game when it's not true, but so far it has only affected a mac systems on the area 2 - in Windows there has not been any problems with that trigger.

 

Anyhow, pausing the game will stop the scripts from running. Other things that might crash the game like that are missing ambient sounds and corrupted creature files. I don't think that it's the ambient though, since the ambient sound that the first area uses is (if I recall correctly) the same general outside/city ambient sound that's used in original game's areas. I'll re-check that just in case, though. It would be strange if a creature or a script would have become corrupted in your install, but we'll see once we figure out what's going on.

 

Can I have a copy of your setup-amber.debug?

I'd also like to see your weidu.log and if you have any non-weidu mods installed I'd like to know that too. You can send both files to amber@welho.net

 

The problem was solved while I typed... :)

Edited by Meira

Share this post


Link to post
It appears that the problem disappears when I remove the Spell Refresh mod so it looks like that this may be incompatible with Amber.

 

Thanks for your help.

 

Regards.

 

 

Okay... I'll take a look at that and see if I can do anything to ensure compatibility in the future.

 

Good to hear that the issue is solved. :)

Share this post


Link to post
No it freezes after the load screen. I can see the area and I can see two goons facing my party and if I am quick enough I can set a destination for the party to move to using my mouse. I can also hear for a moment or two some background sound. (Sometimes it crashes rather than freezes).

 

that, by the way, is an animation conflict. it's unlikely to be Amber that's causing this - it's either Spell Refresh being broken (as it works, i suspect, by creating an invisible creature to refressh yr spells - my guess would be that is overwrites rather than patches the animation) or Spell Refresh clashing with another mod that alters animations. at any rate, you've found the solution: stay well away from Spell Refresh.

Share this post


Link to post

I don't know... :) The spell refresh does not seem to contain aninmations or such. In fact it consists of only setup.exe, .tp2 and .tra files. And all the COPY_EXISTING_REGEXP GLOB etc. magic happens in the tp2. Now I'm almost clueless in what comes to REGEXP stuff, but to me it seems that only spell files ~^.+\.spl$~ are affected here. There are no scripts, animations ect. included in the mod. And I'd imagine that Igi would know better than overwrite stuff. :)

 

In the area that crashes there is an NPC who casts (applies) two protective spells on herself when the party enters. Since the quest was created fairly long time ago I might just have used a code to apply those spells that isn't a standard procedure (similar to the issue with AreaCheckObject() vs. InActiveArea() on Mac). Or those spells might not be in her spell book at all, or something, which I'd imagine might choke the system when she re-learns them... I don't know yet, but I figured that I'd try to re-create the problem on my game before jumping to any conclusions.

Edited by Meira

Share this post


Link to post
Guest Guest
I don't know... :) The spell refresh does not seem to contain aninmations or such. In fact it consists of only setup.exe, .tp2 and .tra files. And all the COPY_EXISTING_REGEXP GLOB etc. magic happens in the tp2. Now I'm almost clueless in what comes to REGEXP stuff, but to me it seems that only spell files ~^.+\.spl$~ are affected here. There are no scripts, animations ect. included in the mod. And I'd imagine that Igi would know better than overwrite stuff. :)

 

In the area that crashes there is an NPC who casts (applies) two protective spells on herself when the party enters. Since the quest was created fairly long time ago I might just have used a code to apply those spells that isn't a standard procedure (similar to the issue with AreaCheckObject() vs. InActiveArea() on Mac). Or those spells might not be in her spell book at all, or something, which I'd imagine might choke the system when she re-learns them... I don't know yet, but I figured that I'd try to re-create the problem on my game before jumping to any conclusions.

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...