Jump to content
Guest Guest

Crash

Recommended Posts

Well, three different players reporting a repeating crash (within a short time span, no less) is hardly a small glitch in my book. ;) Sadly, so far I have not been able to re-create this issue in my game, though. A crash like that (area loads, you can see a flash of it and then the game crashes) could be caused by a number of reasons.

 

Last time it turned out to be a scripting command that Mac didn't like, but it had no effect on a Windows game. A missing ambient sound could cause a crash like that too, but why would it be missing now, since I haven't changed the ambient sounds? A corrupt creature or other object (like a door) can also cause a crash, but again; why now? Scripts are the only thing I've changed recently, so I'm currently suspecting one of them, but I guess I need to do more testing to figure out if that's true.

Share this post


Link to post
Guest Guest

well alright... not so small glitch then... but as i said good luck... sadly it seems like you'll need it ;)

Share this post


Link to post
Guest Guest

Guest #2 here...

 

I reinstalled and let it sit for a long time (well... 2 minutes or so) after I thought it was done just to make sure it all got installed. If it happens again I will let you know.

Share this post


Link to post

It's unlikely that several people would have similar problems in similar places at random, but it is still possible.

 

I've seen behavior like that when the download and installation were not complete. I've sometimes had some luck doing a fresh download/install.

Share this post


Link to post
Guest Guest

well, I followed what >berelinde< sayd.

 

New download/install, run a new game and all is OK!!!

 

I think there where a Bit loosed in the Internet ;)

 

Thanks berelinde

 

OldMen

Share this post


Link to post

What a relief!

 

It is so frustrating when things go wrong and you have no idea why. But sometimes downloading causes files to become corrupted, and the only resolution is a fresh download.

 

Glad it worked out for you! ;)

Share this post


Link to post

That's good to hear.

 

I'm beginning to think we should implement a CRC integrity check to the download... If anyone knows of any free handy tools for doing this (or has any experience in implementing a CRC check in a ZIP file), we would be very thankful for any advice.

Share this post


Link to post
Guest Guest

Well I just played through from Chap. 1 all the way through to Ymmyrt's front yard again, after reinstalling Amber 2.3 and it still crashed when going into his house.

 

Then I redownloaded and reinstalled, loaded up a previous save game, fought the battle again, and it crashed again.

 

Both times I tried it, I successfully cast hold person on Lorraine and killed all of her guards. I'll try it again without doing that but I am skeptical whether that will work.

 

If worse comes to worse I have another save from before she gets kidnapped.

Share this post


Link to post
Guest Guest

By the way I am using two NPCs which I created, dunno if that has any effect on the matter.

Share this post


Link to post
By the way I am using two NPCs which I created, dunno if that has any effect on the matter.

 

 

No, that would not have any effect.

 

 

 

Do you recal which mirror you used to download the mod and if you used the same mirror on both times you downloaded? Maybe there's a faulty download out there? :p

Share this post


Link to post
Guest Guest
Do you recal which mirror you used to download the mod and if you used the same mirror on both times you downloaded? Maybe there's a faulty download out there? :p

 

I downloaded it from IEGMC America this time, can't recall where I got it the first time.

 

I actually got around the problem, sort of... the kidnappers came to grab Amber in the graveyard but we ducked into a crypt before the dialogue finished. They didn't follow us so I saved. When we came back out, the slavers were just standing around doing nothing (blue circles). If I talked to the slaver wizard the kidnap script would start again. So I reloaded the save game and instead of talking to them, just killed them all. They just stood around hiding in their little blue circles while we slaughtered them. Bwahahaha... they won't be kidnapping Amber anytime soon. I assume that it pretty much ended the Amber storyline though. Oh well, maybe next time.

Share this post


Link to post
Guest Guest

I got the same issue as the guest poster above me where even a reinstall won't fix it.

I sent you an email a few minutes ago with my WeiDU log and a descript of the problem (really the same as the other guests have posted)

 

Let me know in a reply email what more info you need please

Share this post


Link to post

Okay, I got it. I'll look in to it ASP (meaning tomorrow).

Share this post


Link to post

i was asked about this over at SHS, and the problem, as far as i can see, is in M#AR02.bcs; specifically in the second block:

IF
 AreaCheck("M#AR02")
 InActiveArea("m#lorraine")
 !Dead("m#lorraine")
THEN
 RESPONSE #100
MoveGlobal("M#AR01","m#lorraine",[580.370])
END

 

the DV - m#lorraine - is too long; unless i'm mistaken DV's have to be 8 characters or less; certainly, both DLTCEP and InfExp are telling me that m#lorraine is not a valid DV. it needs to be changed both in the script, and in the three associated .cre files (M#LORR10.cre, M#LORR13.cre, M#LORR17.cre).

 

by the way: should that script block be sending lorraine to M#AR01.are? i've not played this far thru the mod yet, so i don't know - but usually script blocks like this, at the top of the script, are about creating the cre. not removing them. but anyway, that's not the cause of the CTD - that's (again, caveat: unless i'm wrong) due to the DV being invalid.

Edited by seanas

Share this post


Link to post

Huh?

 

Yeah, I do think that you're right about the character limit in DV. The 'huh?' is because so far the scripts calling her by that DV seem to work. :p

 

I *think* that that block is supposed to move Lorraine back to m#ar01 from m#ar02 if she should enter it by accident. The quest was created a long, long time ago, and it was probably not the best idea ever to code a quest when my coding skill were still a bit.. ...undeveloped.

Share this post


Link to post
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...