Jump to content

no gemrb.ini


Recommended Posts

I've compiled gemrb 0.2.8 on amd64/gentoo, I've set the paths but I get:


[PluginMgr]: Loading Exports for BIF File Importer...[OK]
[Core]: Plugin Loading Complete...[OK]
[Core]: Creating Object Factory...[OK]
[Core]: GemRB Core Initialization...
[Core]: Searching for Video Driver...[OK]
[Core]: Initializing Video Plugin...[OK]
[Core]: Searching for KEY Importer...[OK]
[Core]: Initializing Resource Manager...
[KEYImporter]: Opening /home/piotr/.wine/drive_c/bg/Chitin.key...[OK]
[KEYImporter]: Checking file type...[OK]
[KEYImporter]: Reading Resources...
[KEYImporter]:  BIF Files Count: 182 (Starting at 24 Bytes)
[KEYImporter]:  RES Count: 41793 (Starting at 5449 Bytes)
[KEYImporter]: Resources Loaded...[OK]
[KEYImporter]: Searching for gemrb.ini...[ERROR]
Cannot Load INI
Termination in Progress...
[KEYImporter]: Searching for defsound.2da...[ERROR]
Press enter to continue...


with paths:


I've tried placing gembr.ini in game folder and the current one (from which I run gemrb) with no effect. the gemrb.ini exists in /usr/share/gemrb/override/tob/

Link to comment

GemRBPath=/usr/share/gemrb/ helped ;)


next problem:

open /dev/[sound/]dsp: No such file or directory
[Core]: Starting up the Sound Manager...Retrying to open sound, last error:(0)
open /dev/[sound/]dsp: No such file or directory
Retrying to open sound, last error:(0)


/dev/dsp and /dev/sound/* are deprecated OSS sound devices. /dev/snd should be used. ln -sf /dev/null /dev/dsp

"solved" the problem - game starts.






The game works but it's rather unplayable - I can't attack/spellcats and no keyboard shortcuts.

Link to comment

You should be able to attack, melee combat works.

It is known the spellcast/ranged attack doesn't work, it was never implemented, i'm just working on it.


About the sound issues:

GemRB opens the default sound device, if you don't like how it works, you must recompile OpenAL (remove OSS support from it).

Or probably you can configure openal to ignore OSS (but i don't know how).

Link to comment

I am finding myself with the same problem (missing gemrb) and the solution above has no effect.


I set GemRBPath to /usr/local/share/gemrb/ , which is where the override and guiscripts were installed to, which I assume was the intent of the original solution. Since I cannot think of a good reason why that should be any different, other than the path variation, I find it all too frustrating to bear...


Surely gemrb should be expected to know where its own files are installed to? Can you not improve the situation somewhat? I'm not asking for a config wizard or anything silly like that. But the use of the config file, for new users, should be completely limited to setting up the paths to the game, which is the only thing that causes difficulty thanks to differences between windows/linux. GemRB itself *can* be made to just work with the directory structure specified when you compile it.


It can also be further simplified to not need a configuration file at all, if it read most options from the usual [gamename].ini and was passed the game type and path at the command line, eg: gemrb -game iwd /path/to/icewinddale/


But all in all, something needs to change at some point, because the current installation method is almost terrifying to any novice...

Link to comment
Guest Guest



after kludging it to work by copying gemrb's override folder to the standard IWD one, which was a success, I now have this problem (note that I recompiled with --prefix=/usr/, which is why the message doesnt read /usr/local/share anymore. paranoia got me.):


ImportError: No module named GUIDefines

[GUIScript]: Check if /usr/share/gemrb/GUIScripts/GUIDefines.py exists! [ERROR]

[KEYImporter]: Searching for defsound.2da...[Found in Override]

Press enter to continue...




chiv@blackbook:~/games/iwd$ ls /usr/share/gemrb/GUIScripts/GUIDefines.py



So for whatever reason I cant fathom, Gemrb seems unable to find anything that is in /usr/share/gemrb, no matter what it is. I am stumped, please tell me if you have seen this before, or does my system just have it in for me?

Link to comment
Guest Guest

Hmmm. That I found out last night, at least the console output seems to know where to look. However, it doesn´t solve my problem, Gemrb still doesnt find the files. It finds everything from the .key file, but gets stuck finding its own resources.


I had moderate success running from the build directory instead, but it still would not fully function. Even when run from within the build directory, the GUI script plugin reports loading successfuly (finds GUIDefines.py as opposed to not finding it), and yet the game abrubtly halts as soon as the display window is made, stating that it can´t find Start.py. I am vexed.


It´s tantalising as well, because I enjoy seeing every inch of progress from this project. It almost feels like its teasing me....


I dont know if it is worth mentioning, but this is from an svn checkout from yesterday morning and not the source package.

Link to comment
Guest Guest
Probably the casesensitive flag should be set?


Is there an example config file somewhere? I'm trying to run BG1, it seems to load all the games files but then complains that it can't find its own ini file (which is in the default installation folder). Am I missing the obvious here?

Link to comment
Probably the casesensitive flag should be set?


No, that is definitely set. I would not trouble you if I was not truly stumped, I actually find myself quite embarrassed that I can´t divine the solution.



In reply to the other guest post, there should be config files installed into /usr/local/share/etc if I am not mistaken (I´m far away from my own computer so I can´t check). The options are mostly self explanatory.

Link to comment

Probably the casesensitive flag should be set?


Is there an example config file somewhere? I'm trying to run BG1, it seems to load all the games files but then complains that it can't find its own ini file (which is in the default installation folder). Am I missing the obvious here?


The example config should be in the distribution (commented up).


I guess you meant its own .cfg file.

The gemrb.ini files are game specific. The gemrb.cfg is common.


I need complete logs + contents of gemrb.cfg to diagnose problems.

Link to comment
I need complete logs + contents of gemrb.cfg to diagnose problems.


Sorry, I cant give you that, this is just a public computer.


I did manage to diagnose the problem a bit further last night though - for some reason, when the Keyimporter is looking for a file and asks the core plugin what game type it is, it gets told gemrb, rather than what is set in the ini. I tried putting a printf statement in the ini parsing function underneath the "GameType" comparison, to test whether it was reading it properly, yet it never came out in the console. Just to make sure, I put another underneath where it sets the cachepath, and that worked.


So just to be clear, the game is looking for gemrb.ini in /usr/local/share/gemrb/gemrb and that is why it cannot find it.


I´m afraid I cant be any more specific than that, this is just from memory. At least for now, I can hammer it into working by renaming the override/ and /guiscrpt/how folders to /guiscript/gemrb etc


I must say, the game is looking very nice, edging its way slowly to completion. You are doing die hard fans a great service sir, and for that you should be honoured ;). I just hope the occasional bugs don´t give you too many sleepless nights.

Link to comment

I'm sure this is a configuration problem.


Remove the following entries:



GUIScriptsPath is normally the same as GemRBPath (no need to add GUIScripts to its end).




CachePath is set to GemRBPath + "/Cache" automatically.


Also check the following entries:



make sure there is no extra space in the end, and it is one of the following:



CaseSensitive=1 (in case there are any game/gemrb files on an ext2 filesystem)

Link to comment
Guest Guest
CachePath is set to GemRBPath + "/Cache" automatically.


This is not so on my system, if I dont set the path, it looks in .gemrb/Cache (of course GemRBPath would be in /usr/local/share/gemrb anyway, so this is probably more desirable)


The other options I have been over a hundred times in the last few days. By the way, case sensitive is ifdef´d to 1 on all non windows systems anyway.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...