Jump to content

My PS:T Blurry issues


Recommended Posts


i recently decided to gather some information about playing PS:T and Baldur's Gate in my new modern PC. Eventualy i stumbled upon you guys, i consider myself advanced pc user, i think i did everything properly to run PS:T in Windows7 64bit with an ATI 5870. (Using WidescreenMod and Setup-GhostDog's-PST-UI, latest versions).

The game runs fine, but with extremely blurred (and sometimes watery-moving) image. It's like it is drawn with wet colours! It is like if you see the game behind a glass that has water flowing on it!. I tested it in 1920x1200, 1680x1050 and 1280x800. all have same issue.

Here is a pic of this issue..Oh and when i mouseclick something that could be a button, it strangely loses all the blur and looks proper crispy button.




Uploaded with ImageShack.us


I am not posting the widescreen debug file its insanely huge..if i have to, i will.

Looking forward for your reply, thanks ^^

Link to comment
There is something wrong with your video card and/or drivers, which I can't diagnose remotely.


it seems there must be a specific ATI 5870 issue? (or 5xxx series in general).

Anyway, i did what most would do, downloaded virtualbox and installed my old win98 :) however i had some issues there in general, then i tried installing my old winxp pro cd on virtual box, all worked like a charm, meaning all tweaks and addons on torment worked fine and the game played fine at 1280x800 without blurry issues.

Now i got abit more into virtualisation solutions, testing vmware player and win98. Much better support in directx (goes up to dx8 i think) and in drivers. But i am stuck at the point, after installing widescreen mod (and the 3-4 more mods for the game tweaks) i get the "no supported video resolutions, says the programmer" error. i will play with it abit more ^^.

Link to comment

PST works in 16 bit color depth, not 32 bit, and I think that message pops up when it can't correctly set the color depth; try forcing the color depth to 16 bit in your guest OS (or randomly try different configuration options in both VMWare and the guest OS, or revert to the known-working VirtualBox/XP).

Link to comment

Yes, i edited the .vmx file of the virtual os and added the line


svga.spoof16bppHost = "TRUE"


now, vmware runs win98 on 16bit, however before installing anything i run ps:t and win98 froze. it seems 640x480 isn't working at vmware/win98, tried to put win98 at 640x480, same thing. Will update this post after widescreen mod gets in the game.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...