Jump to content

Planescape:Torment v. Win10

Recommended Posts



I'll apologise now, if it's come up before. Though I've found similar issues through searching, it was either for far older operating systems (12 years ago, for example), or for Baldur's Gate.


Since I found out about Planescape:Tides of Numenera, I've been dying to play Torment again. I've never actually finished the entire game, since when I'd discovered how fantastic RPG's are, it was already quite dated. I have tried, though, several times. When the enhanced editions of Baldur's Gate (and Age of Empires) emerged, I'd read that Planescape was in the cards....so excited about that....I don't think it has happened, or I'd not be here now. In fact, an enhanced version would go a long way to rectifying why I've never been able to get through the game in it's entirety. Which is sad, because it's really one of the best things I've ever played. It's just that it doesn't hold up, visually, as far as more modern PC's and operating systems go. Can't zoom out to see outside your immediate surroundings, the visuals are dreadful on HD, etc. Still a great game, though, and I'd like to get through it ONCE, so I can play Tides of Numenera.


So, I've tried installing the tweak pack (yes, the Ps:T one). SO many times. Followed the instructions, and have I've tried it with, and without, the Platter mod. It won't even get to the splash screen; just ''Torment.exe has encountered errors and will be closed by Windows.'' Or something similar. When I've uninstalled it all, it plays fine. What I'm wondering, is if anyone has tried this on Windows 10? .


Any ideas? Would be most appreciated. I'd be most grateful, thank you.


Win 10, GOG version. Perhaps a different partition/drive? Compatibility mode does not work in any way, shape or form. I've tried every conceivable setting, more than once.




EDIT: Because I'm a sucker for punishment, thought I'd try once again. So, far, cannot get the Platter fixpack to install, now, either (''unable to find dialog.tlk''). Thought I'd managed it previously; perhaps I was mistaken. I may try to map a new network drive, see if it makes a difference. I'm wondering if GOG may be an issue? Argh...


EDIT, again: After some digging, turns out it has nothing to do with GOG. In fact, they'd posted their own ''mods to install'' guide about six years ago. So, following it, I've installed 1) Bigg's Widescreen; 2) Ghostdog's UI; 3) Ultimate WeiDU Fixpack; 4) Qwinn's Unfinished Business; 5) Qwinn's Tweak Pack. Started the game after every install, looks amazing. There are still some of the features I'd like from the G3 mod, though; for some reason most of the tweaks in Qwinn's were ''not recommended''. I may try again, as I can probably uninstall just that mod if it goes to hell again. At least I now have a hope of actually playing and finishing the game; the newer resolution fix is just what I needed.


EDIT, thrice, ffs: Installed the G3, one component at a time. Just the ''max HP'' does not work. Poo. At any rate, thanks for the mods, folks.


Cheers. :-)

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...