Jump to content



Recommended Posts

I tried installing GemRB on Ubuntu 8.04 (64-bit) and got the following error when running ./configure:

checking for sdl-config... no

checking for SDL - version >= 1.2.0... no

*** The sdl-config script installed by SDL could not be found

*** If SDL was installed in PREFIX, make sure PREFIX/bin is in

*** your path, or set the SDL_CONFIG environment variable to the

*** full path to sdl-config.

configure: error:


*** You need LibSDL (www.libsdl.org) version 1.2.0 or greater to compile GemRB


Now I checked Synaptic and found that I do have LibSDL 1.2 installed. I did a search and found it under /usr/lib. I figure I need to change the path so GemRB can see it but I'm not sure how to do that (still fairly new to linux).

Link to comment

Turns out I didn't have the dev package installed. Fixed that problem but now it can't find python headers. Searching for them now.


EDIT: Found the headers. Config works! Here's hoping the rest of the install process runs smoothly.


EDIT2: Everything's installed. Now I'm having problems running it. Seems it can't find Chitin.key.

Link to comment

Got the config file to work but now I have yet another problem (does it ever end?). For all 3 of my IE games (IWD, BG1, BG2) I get this:

[Core]: Checking for Dialogue Manager...[OK]
[KEYImporter]: Searching for months.2da...[ERROR]
Cannot find DATA/DEFAULT.BIF... Resource unavailable.
[Core]: Loading Dialog.tlk file...[OK]
[Core]: Loading Palettes...
[KEYImporter]: Searching for MPALETTE.bmp...[ERROR]
Cannot find DATA/DEFAULT.BIF... Resource unavailable.
[KEYImporter]: Searching for MPALETTE.bmp...[ERROR]
Cannot find DATA/DEFAULT.BIF... Resource unavailable.
[KEYImporter]: Searching for MPAL256.bmp...[ERROR]
Cannot find DATA/DEFAULT.BIF... Resource unavailable.
[Core]: Palettes Loaded
[Core]: Initializing stock sounds...
[KEYImporter]: Searching for defsound.2da...[Found in GemRB Override]
[Core]: Initializing the Event Manager...[OK]
[Core]: BroadCasting Event Manager...[OK]
[Core]: Initializing Window Manager...[OK]
[Core]: Initializing GUI Script Engine...[OK]
[KEYImporter]: Searching for cursors.bam...[ERROR]
Cannot find DATA/GUIBAM.BIF... Resource unavailable.
[Core]: Loading Cursors...[ERROR]
[KEYImporter]: Searching for defsound.2da...[Found in GemRB Override]


So GemRB can't find these files even when they're all where they're supposed to be?

Link to comment

Yes, and I tried both 0 and 1 for that value and got the same result.


Edit: Only BG2 is giving me the error listed above now. BG1 and IWD are giving me this:


[Core]: Setting up the Console...[OK]
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
open /dev/[sound/]dsp: Device or resource busy
[Core]: Starting up the Sound Manager...Retrying to open sound, last error:(0)
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
open /dev/[sound/]dsp: Device or resource busy
Retrying to open sound, last error:(0)

Link to comment

Check if you truly have those bif files in your game's data path.


The second seems to be an openal problem. Your openal isn't quite up to the task of handling the sound device.

You need to find a way to configure openal to use a different method, or whatever.

You can also try to use gemrb without sound (remove libOpenALAudio*) from the plugins dir.

So NullSound will load instead.

Link to comment

I've checked and yes I do have those files. It just occurred to me that I have BGT installed on BG2. Could that possibly conflict with GemRB?


EDIT: With regards to IWD and BG1. I managed to get them up and running. Turns out I needed python-openal to get it to work.

Link to comment

Not sure about bgt, it should work, and i'm sure eventually you will be able to make it work.


python-openal sounds like something that is needed to access openal from python. It sounds excess, since we don't handle python from openal, and separated the two things as much as we could. The only idea why it still helped you is that it reconfigures openal in a way it works with your system :)

Which is good, but i'm 90% sure it is just a lucky coincidence.

Link to comment

Good news! I uninstalled all mods on my BG2 installation and got GemRB to work! This does lead me to believe one of the mods was the cause. My primary suspects are BGT and the G3 tweakpack, though after installing Tutu and getting it to work with GemRB I'm leaning towards the tweakpack. I'll have to run some more tests to be sure though.


Have a new problem regarding IWD:


After a few seconds of this blue screen, the program closes altogether.

Link to comment

It would be very strange if bgt or any other mod would cause problems in openal!


The bluescreen problem going backwards on the cause and effect chain is:


1. the area file (.are) couldn't be loaded, this causes a blue screen (and soon a crash).

2. on the log snippet it is clear that it tried to load 'badval.are' which is of course not existent. It is the default value in startare.2da

3. at this point, i'm puzzled... Not sure how old your gemrb is (if you can always download the most recent version).

I've fixed a few things about finding a saved game (you didn't say if it is a new game or a loaded game). And i've fixed a few parts about using the extension packs of games (not sure if you use iwd, how or totlm).

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...