Jump to content

[SOLVED(?)][Mac OS X] SCSII install failure, please help!


ericp07

Recommended Posts

Installation is now underway, behaving as it should :)

 

It appears that, under OS X, it's not necessary to run Setup-scsii_autoinstall.tp2, so I'm ignoring that.

 

First time this error happened to me:

 

Install Component [Retrieve Dropped Items from Hell]?

nstall, or [N]ot Install or [Q]uit? i

 

Installing [Retrieve Dropped Items from Hell] [v21]

Copying and patching 1 file ...

Copying and patching 1 file ...

Appending to files ...

Appending to files ...

Appending to files ...

Appending to files ...

Copying and patching 1 file ...

Appending to files ...

Appending to files ...

Copying 1 file ...

Copying and patching 1 file ...

Copying and patching 2 files ...

Cannot resolve action 0x157

ERROR: [cut100a.bcs] -> [override] Patching Failed (COPY) (Not_found)

Stopping installation because of error.

Stopping installation because of error.

 

ERROR Installing [Retrieve Dropped Items from Hell], rolling back to previous state

Will uninstall 3 files for [setup-scsii.tp2] component 4030.

Uninstalled 3 files for [setup-scsii.tp2] component 4030.

ERROR: Not_found

PLEASE email the file Setup-scsii.DEBUG to davidw, Gibberlings3 forums

Using Language [English]

 

I'll skip the component until I know how to fix it, so someone please advise.

 

Meanwhile, continuing through installation.

 

It's annoying that ACTION.IDS is removed from the override folder, but good that the file is present in one of the mod's backup folders.

Link to post

Another error!

 

[scsii/help/scripts/gpmerc_old.baf] PARSE ERROR at line 5 column 16-27

Near Text: )

Type mismatch in "ID" argument of [shout].

Expecting type "integer".

 

[scsii/help/scripts/gpmerc_old.baf] ERROR at line 5 column 16-27

Near Text: )

Parsing.Parse_error

ERROR: parsing [scsii/help/scripts/gpmerc_old.baf]: Parsing.Parse_error

Stopping installation because of error.

Stopping installation because of error.

 

ERROR Installing [smarter general AI], rolling back to previous state

Will uninstall 2047 files for [setup-scsii.tp2] component 6000.

Uninstalled 2047 files for [setup-scsii.tp2] component 6000.

ERROR: Parsing.Parse_error

PLEASE email the file Setup-scsii.DEBUG to davidw, Gibberlings3 forums

Using Language [English]

 

I have no clue about this one, so please advise. This component has always installed successfully for me in the past.

Link to post

Tons more components failing to install :( Improved general AI fails, improved fiends/celestials/spiders/dragons, smarter mages and priests... I've never encountered errors with any of these before.

 

Please help!

Link to post

Here's the result of my SCSII installation, copied from my weidu.log:

 

~SETUP-SCSII.TP2~ #0 #1000 // Initialise mod (all other components require this): v21

~SETUP-SCSII.TP2~ #0 #2010 // More consistent Breach spell (always affects liches and rakshasas; doesn't penetrate Spell Turning): v21

~SETUP-SCSII.TP2~ #0 #2019 // Antimagic attacks penetrate improved invisibility -> Antimagic spells remain single-target, but affect the target creature whether or not it is invisible (default option): v21

~SETUP-SCSII.TP2~ #0 #2030 // Iron Skins behaves like Stoneskin (can be brought down by Breach): v21

~SETUP-SCSII.TP2~ #0 #2050 // Make individual versions of Spell Immunity available, so that players can use them in Contingencies etc.: v21

~SETUP-SCSII.TP2~ #0 #2070 // Blade Barrier and Globe of Blades only affect hostile creatures: v21

~SETUP-SCSII.TP2~ #0 #2100 // Make Minute Meteors into +2 weapons: v21

~SETUP-SCSII.TP2~ #0 #2120 // Slightly weaken insect plague spells, and let fire shields block them: v21

~SETUP-SCSII.TP2~ #0 #2150 // Make spell sequencers, spell triggers, and contingencies learnable by all mages: v21

~SETUP-SCSII.TP2~ #0 #2160 // Add an extra copy of some hard-to-find spell scrolls: v21

~SETUP-SCSII.TP2~ #0 #2170 // True Sight/True Seeing spells protect from magical blindness: v21

~SETUP-SCSII.TP2~ #0 #3070 // Make the healing and resurrection powers of the Rod of Resurrection into separate abilities: v21

~SETUP-SCSII.TP2~ #0 #3530 // Faster Bears: v21

~SETUP-SCSII.TP2~ #0 #3540 // Grant large, flying, non-solid or similar creatures protection from Web and Entangle: v21

~SETUP-SCSII.TP2~ #0 #4010 // Make Freedom scrolls available earlier: v21

~SETUP-SCSII.TP2~ #0 #4040 // Improved shapeshifting: v21

~SETUP-SCSII.TP2~ #0 #4050 // Make party members less likely to die irreversibly: v21

~SETUP-SCSII.TP2~ #0 #4100 // Treat mages' and priests' High-Level Abilities as innate abilities rather than memorisable spells (each may be taken only once): v21

~SETUP-SCSII.TP2~ #0 #5010 // Remove animation from the Cloak of Mirroring (leave it for other spells and effects that use the same graphic): v21

~SETUP-SCSII.TP2~ #0 #6040 // Give fiends more staying power by increasing their hit points (this component has no effect unless Improved Fiends is installed): v21

~SETUP-SCSII.TP2~ #0 #6070 // Give Celestials slightly more staying power: v21

~SETUP-SCSII.TP2~ #0 #6090 // Give dragons more staying power by increasing their hit points: v21

~SETUP-SCSII.TP2~ #0 #6095 // Standardise dragon immunities: dragons in Shadows of Amn get the same immunities to vorpal attacks (etc) as their Throne of Bhaal cousins: v21

~SETUP-SCSII.TP2~ #0 #6108 // Enemy mages (and Elder Orbs) use Simulacrum and Project Image spells (this component will have no effect unless you install Smarter Mages or Smarter Beholders): v21

~SETUP-SCSII.TP2~ #0 #6137 // Add high-level abilities (HLAs) to ToB mages -> All ToB mages who can cast 9th-level spells get HLAs: v21

~SETUP-SCSII.TP2~ #0 #6139 // Add high-level abilities (HLAs) to SoA mages -> All SoA mages who can cast 9th-level spells get HLAs: v21

~SETUP-SCSII.TP2~ #0 #6161 // Add high-level abilities (HLAs) to ToB priests -> All ToB priests who can cast 7th-level spells get HLAs: v21

~SETUP-SCSII.TP2~ #0 #6171 // Add high-level abilities (HLAs) to SoA priests -> All SoA priests who can cast 7th-level spells get HLAs: v21

~SETUP-SCSII.TP2~ #0 #7040 // Improved Random Encounters: v21

~SETUP-SCSII.TP2~ #0 #6015 // More sensible choices of weapon proficiencies and kits for fighters (also fixes some errors in fighter stats): v21

Link to post

This is a stressful nightmare (but I hope someone is getting a good chuckle out of it)...a problem with another mod forced me to annihilate the installation and start over, with an archived copy of the same installation just before SCSII.

 

Double-checked that ACTION.IDS is in override before running weidu-mac to install. Also made sure the last two lines in scsii.ini read:

 

Disable_ToBEx 1

Disable_Hacks_If_ToBEx_Skipped 1

 

SCSII still removes ACTION.IDS from override during initialization, and does not add another file of the same name, which causes an installation error for component 1000, but the error is not specified. Huh?

 

Every time the install fails, I look in override and see that ACTION.IDS has again been removed. Dropping a copy of the file into override, and then running the installer again, has the same result:

 

ERROR Installing [initialise mod (all other components require this)], rolling back to previous state

Will uninstall 809 files for [setup-scsii.tp2] component 1000.

Uninstalled 809 files for [setup-scsii.tp2] component 1000.

ERROR: Not_found

 

Interestingly, SCSII's 1000 folder, inside the backup_BGII - SoA folder, has a newly-created file called override.ACTION.IDS, which is identical to ACTION.IDS.

 

Edit: Deleted the entire mod, downloaded a new copy (of the OS X version 21, I double-checked that), set it up in my main BG2 folder using /Install-tools/Install-mod.sh, replaced scsii.ini with my edited version, then ran weidu-mac to install the mod. It's installing components I choose without errors...

 

...then fails on Smarter general AI (because ACTION.IDS is again removed from override; drag/dropped ACTION.IDS from 5020 folder inside backup_BGII - SoA folder). Telling the installer to install this component again after adding ACTION.IDS back into override results in the component installing as it should, and ACTION.IDS remains in override :) Carrying on with installing components...

 

Many parse errors reported during installation of some "smarter" components due to items not found in SPELL.IDS, but installation continues...

 

...and completes successfully! :D I find it odd that so many errors popped up related to SPELL.IDS, but I'll let that slide unless things go horribly wrong in-game.

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...