Jump to content

How to update my WeiDU?

Recommended Posts

Hello everybody!

While trying to do a BGT multimod installation (on Windows 64 bit) I discovered that for whatever reason the mods start to install with WeiDu v246, though the latest version is 249 and I have put the latter into my BGII-SoA folder. I tried to fiddle with programs that come along with WeiDu like Weinstaller (though I do not really know what I'm doing). Somehow I managed to proceed to version 247 (again no idea how that was accomplished) but I suspect that - while the majority of mods installs just fine with the outdated versions - some of the newer ones fail because of that. Actually it's the Expanded Thief Stronghold v3.0.0 mod (gbthfkp) that's constantly failing to install (see attached Debug-log).

I have no idea how to pacify it with a newer WeiDu version, so any hints would be welcome.




Link to comment

Far from a PC, but if I remember correctly, there is a folder in BWP root wich store the weidu installer (maybe the source folder) in v246.

To proceed with weidu 249 you have to replace this file (maybe weidu-64.exe or something similar) with any weidu installer v249 (with the same name obviously...)

Link to comment

If you're using the mod's own installer, that's whatever version of WeiDU the installer is a copy of. Which shouldn't be a problem for the mod in question, if the mod is properly designed. If you're using a separate installation tool, there's a copy of the WeiDU executable in there somewhere - and that's the file you need to update.

Installing different mods with different versions of WeiDU is not a problem. The only problems come when you install a mod with a WeiDU version that doesn't support all the features that particular mod uses. For example, my tweak mod needs some features of 247, and will throw a syntax error with anything older. I distributed some versions of my mod with installers that were based on older versions of WeiDU ... until people actually tried those installers, and discovered the problem.

Link to comment

Thanks for your input.

Indeed I tried to use the BiGWorld Installer previously, but did not succeed. Thus I'm currently trying to install my (massively reduced number of) mods one by one and with my bare hands. The BiGWorldInstallpack folder is still in the BGII SoA folder and contains WeiDu v246. So it was my first guess also to replace it with the newest version. But that didn't help, which is kind of plausible when I'm actually not using the installpack.

So it's good to know that the mods use the WeiDU version they are delivered with and that different versions in different mods should not be a problem. But that leaves my problem unsolved that the Expanded Thief Stronghold mod does not install while I suspect it's the WeiDu version that causes the problem (though it's only a guess since I do not understand the Debug-log). Unfortunately there is no subforum for this mod that I know of.

Any more suggestions by any chance? I really like this mod and would regret to have to drop it.





Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...