Jump to content

GemRB for Android Accelerometer issue


Recommended Posts

I downloaded GemRB for my Asus eee Transformer and when I saw Baldur's gate start working I became giddy as a prepubescent girl meeting justin bieber ... until when I got in game I noticed that the accelerometer didn't work as expected. The game forces landscape orientation (as it should) but the accelerometer acts as if it is in portrait orientation. I move the screen down by tilting left, left by tilting up, etc. Is there any way that I can fix this via config file or is it hardcoded in? My tablet only has three hardware buttons including the power button so other hardware is out of the question at the moment. The in game keyboard caches commands in the android version of the program so using arrow keys with that is also out. Ideas?

Link to comment

Well two finger draggin doesn't seem to do anything in baldur's gate 1 but dragging to the side of the screen is working for now. It is rather inconvenient though so if you could work on the accelerometer and/or release the source for the android version then that would be great.

Link to comment

most of the android code is in our repository. The thing that makes it complicate it is the state of the custom android sdl port that we have to use and the sad state of sdl in general.

Link to comment

Tried accelerometer - it work fine (up is up, left is left etc) on my 2.3 device. And it works independently of system orientation. I tried with latest SF (http://sourceforge.net/projects/gemrb/files/Other%20Binaries/android/) version but it should not matter so this part wasn't changed for a long time.


Any specific features about your device (custom rom etc)?


Also you can enable grey lined touch areas to scroll screen with single taps:


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...