Jump to content

Trying to set up GemRB: Plugin Loading Failed, check path


Recommended Posts

Hi there,

I'm super new to all of this, just downloaded GemRB from here and created a GemRB.cfg and from the gemrb.exe output "Plugin Loading Failed, check path" I assume something is wrong with my paths.

Can someone check the .cfg pls and tell me what I did wrong?

When I extract gemrb-win32-bedfde6 to the standard directory C: I get the same error so I think the issue is the game installation directory? How can I fix this?

Link to comment

The first thing I noticed is unrelated, but you should know that gemrb needs original game files — it doesn't work with ee versions yet. The error is much sooner though.


Try moving or copying gemrb_core.dll from

Q:/Download Temp Files/gamesDiv/Baldur's Gate/Modding/gemrb-win32-bedfde6

to its plugins subdir.


This is a new automated build, so it hasn't received much testing yet. Thanks for checking in!

Link to comment

Thx for the reply!

When moving the gemrb_core.dll to plugins, I can't start gemrb.exe and I get another error message instead saying that the .dll is missing and that I should install again.


When copying the .dll to plugins, I get the same error as before: "Plugin Loading Failed, check path"

Link to comment

This is what it looks like:



The line above states: Loading Plugins from C:/gemrb-win32-bedfde6/plugins


So I simply copied the plugins directory to C: with that exact path, but I get the exact same error every time.

From a noob-perspective this looks like the path for plugins is somehow defined somewhere and causes this error because it is unable to find the directory.

Link to comment

It's unable to find any of the dlls within it. Could it be some of the notorious windows protection stuff? Or is that only for the preinstalled dirs? I remember people had problems with installing mods in general.


Anyway, I've added some extra error reporting for windows. Please try the new build (gemrb-win32-382c3a7) and post that log.

Link to comment

But the directory it's looking in is there, right, and full of dlls?

Try changing PluginsPath in the config, so it uses backslashes.

In this log there's also no config message, so it could be it's not even using your config. On other oses this is trivial to check with strace, but you can just pass it the path to the config when running: gemrb.exe -c path/to/conf

Link to comment

Yes, the directory is there, 43 .dll files inside.


And you were right, changing config using backslashes did work this time. Now I get this:



So I guess everything works fine now - problem is that I have BGEE right?



Edit: I did another test. Turns out changing to backslashes isn't even needed. Only thing I have to do is duplicate the GemRB.cfg.sample and rename it to GemRB.cfg - I don't have to edit the .cfg at all.

Link to comment

What I don't understand is: when I change the game path to my steam BGEE directory, the GemRB.exe doesn't seem to check that path at all. Instead it keeps looking for the game in a pre-selected directory (the one that is inside the GemRB.cfg.sample file). It totally ignores path changes that I make inside the .cfg


I'm not sure if this is related to the BGEE issue - or if this is an internal problem that ignores custom paths?

The error log should state that the game directory was found, despite of the version of the game (imho) - but give an error for the BGEE stating that it is not compatible with it. That would at least inform the user that the problem is the BGEE and not the game path itself :)

Link to comment

If you're using a custom config, you need to tell gemrb to read that instead. We check a few paths and use the first thing we find named gemrb.cfg. Are you sure the log is identical to what you have above? You can also change CD1 and comment out the rest.


BGEE will error out soon enough. From what I heard, dialog.tlk was moved into language subdirs, so we'll complain.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...