Jump to content

Unable to install SCS on BG2 EE steam version


Recommended Posts

Make a new .txt file in the game folder and rename it(and it's file extension) as "random.bat" and copy paste this code to it(when you edit the file with Notepad for example):

mkdir change-log
WeiDU.exe --log nul --change-log spell.ids >change-log/change-log.txt --out change-log 

And then run the file as if it were a .exe file, it will run the windows command console(CMD.exe) in the game folder which will result into making of the folder if it doesn't exist in there already and it will print files to the folder, primarily the change-log.txt with will tell you what files modified the spell.ids file, the file that when read produces error that prevent the SCS's install as shown in this:


Reading in data: spellcodes
Copying and patching 1 file ...
[./override/spell.ids] loaded, 28343 bytes
ERROR: cannot convert level or %level% to an integer
ERROR: [spell.ids] -> [override] Patching Failed (COPY) (Not_found)
Stopping installation because of error.

Link to comment

I can't attach the stratagems debug because it's too big, but I did attach the changelog.txt.,

It's called archiving a file... a .zip archive is usually best, cause most forums allow uploading their attaches and most people have a tool installed that can unpack them. This can reduce the file size anywhere from 1:1 to 1:100 000 especially if it's a simple text file.

And yeah, in here the MOST people are even the ones that do not know they have the capability build in every Windows, Mac and Linux OS'es. There are others but the most common is usually best cause it's the most common.


Also attaching a file that only has a few lines in it is less than useful:


[WeiDU.exe] WeiDU version 23700






Mods affecting SPELL.IDS:

00000: ~BP/SETUP-BP.TP2~ 0 0 // Big Picture, core component (required for most subcomponents): v181-b4611

00001: ~WHEELS/SETUP-WHEELS.TP2~ 0 0 // The Wheels of Prophecy: v6

Link to comment

So I tried to reproduce the error by reinstalling bg2 ee and installing the mods through the BWS except leave everything involving tactics and such out of it, just doing the content mods and cosmetic mods, no NPC mods except for some really basic ones. Once done I tried installing SCS and I got none of the errors from before. ?

Guess that fixed it, just no clue what caused it in the first place.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...