Jump to content

Help, GemRB 0.9.0 on the Raspberry Pi 3 and 4


Recommended Posts

I have successfully compiled GemRB 0.9.0 on a Raspberry Pi 3 and 4 using OpenGL.  It runs but it is slow.   I've been trying to compile using OpenGL ES, it compiles successfully but fails to launch and crashes because of the video driver.


Edited by RetroNinja
Added Pi 4 screen shot
Link to comment

Okay, I see that OpenGL ES is not yet supported yet in GemRB 0.9.0.  I see that PiKiss offers GemRB 0.8.8 using OpenGL ES.  So does GemRB 0.8.8 support OpenGL ES on the Raspberry Pi?

Re: So I tried it, it works but not really.  I tried it in full screen and windowed mode but the GUI is all garbled.  I get the same result when using the PiKiss version.

Edited by RetroNinja
Link to comment

Since none of the regular contributors have any relevant hardware, I'm afraid it's up to other, yet unknown contributors. The stuff in the screenshot makes it look like GLES3 has changes in its shader API/language, so perhaps the fix is easier than it seems. But I'm not a graphics guy at all.

Link to comment

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...