Jump to content

IWD2 GUI Status


Recommended Posts

MessageWindow.py for IWD2 doesn't seem to be working correctly as I can't see any sort of GUI. It's as if it were hidden.


It may have something to do with this recurring error:

[GUIScript]: Missing function:UpdateControlStatus

I'll check with BG2 and see if it has the same problem. If so it's a problem with my GemRB installation, if not then I'll have a look at IWD2's GUI scripts and see why that function's missing.

Link to comment
Guest lynx

I tried my iwd2 copy and it loads fine, but apart from the base bar and the dialogs to get there, not much more of the gui works. Character generation is very good (adding feats has no restrictions and no visual feedback, distributing ability points ignores the modifier and there is no sound feedback when choosing the voice)[drow cleric]. But that's about it. :cool: You should definitely see more than just the play area though.

Link to comment

Well character generation definitely sounds like a good place to start. I think that will ease me into the API. As with learning all new APIs, I'm stumbling around in the dark a bit.


I need to get this issue sorted first though. I just tried running BG2 and it has the same problem. Character generation GUI seems fine (aside from the crash when clicking the appearance tab) but the main game has no GUI to speak of.


I've got an odd setup which I think may be part of the problem. The SVN compiled version of GemRB won't run as it complains it can't fine libgemrb_core.so.0 at all. That's installed in its own subdirectory in $HOME.


So instead I'm using the latest linux binary version. I extracted that to /usr and the gemrb binary can now find libgemrb_core.so.0. I had to move the GUIScripts directory to $HOME/.gemrb because I want to edit the GUI scripts without root privileges. Gemrb.cfg is setup correctly and it can find everything but, as I've said, no GUI appears in-game.


Both IWD2 and BG2 report the error that I've posted above and BG2 also gives an extra error of:

[GUIScript]: Missing function:SelectionChanged

Is this distinctive in any way? Sounds like some modules aren't being imported correctly although I would have expected an error for that too.

Link to comment
Guest lynx

Usually the gui disappears if python encounters an error (no exception set, traceback ...). Check if there is a few lines of output that is not directly from gemrb.

That function is in GUICommonWindows.py - check if python encounters problems before defining it.

gemrb/GUIScripts/iwd2/GUICommonWindows.py:537:def SelectionChanged ():



http: //linux.prinas.si/gemrb/doku.php?id=guiscript:start

http://linux.prinas.si/gemrb/doku.php?id=g...ex&do=index (the alphaindex plugin is broken)

Link to comment

OK, I sent the output of GemRB to a file called gemrb.log. When I had removed that I was left with the following output in the terminal:

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback


Once I'd started a game I got a python error saying it was unable to import the module named 'string'.


Clearly the problem is that I haven't installed the 32-bit python libraries. I have the 64-bit ones as I was able to compile GemRB from CVS but I forgot that the binary download was 32-bit.


Edit: Installing the 32-bit versions of python, python-libs and python-devel doesn't seem to help however I believe this is a problem at my end as I'm unable to run simple python files at all without encountering that error - even though /usr/lib64/python2.5/site.py and /usr/lib64/python2.5/string.py most certainly do exist. I'll do more investigating and get this working.


Edit 2: Fixed. I now have a GUI in BG2 and IWD2. I can see what you mean about it needing more work. I'll see what I can do :cool:

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...