Jump to content

[Ps:T] What does not work...


Recommended Posts

Hi again!


I stopped playing BGI for a while and decided to play with Torment (since some friends of mine told me it is awesome game).


Anyway, i installed it via wine, wine refused to lunch it but tried GemRB anyway and it seems to be everything as it should be.


Some stuff that does not work well:


1. Zombies fall twice. First - when i kill it, second - while after first.

2. Drops does not 'shine' when i hit alt.

3. Full screen does not work, but it seems to be known.

4. Scrolling horisontally (as it is in BG) does not work at all.

5. Using 'A' for atack does not work.

6. Using key does seem to not work, but


since it is my first time i simply can miss something...


Best regards!

sorry for being annoying.

Link to comment
Guest Guest

I can append something to this list:


First, some background, maybe this works with vanilla PST, I don't know:

I have the problem that the original PST (2CD version+Widescreen-Mod+WeiDU-Fixpack 4.11+Unfinished Business 4.1+Qwinns Tweak Pack 4.1+GhostDogs UI Mod 2.01) in VirtualBox (WinXP) crashes if I move the group into the area with Sandoz to complete the quest for the godsmenship.

So I tried to complete this quest with gemrb (0.6.3 on Linux) and use the savegame in my VirtualBox again.

After copying the game from VirtualBox into my Linux home and renaming all bif files to BIF files and moving all BIF files from the cache directory into the pst directory (to get rid of a blue gamescreen), the game finally worked with gemrb, but:


* copying a spell into the spellbook does not work...

* ... and if I try to copy another spell into the spellbook, the first spell's scroll is being removed from the inventory

* using the save menu does not work (it does not draw to the screen and is unusable, but I think it's somehow there)

* using the autosave from gemrb does crash the original pst if I try to load this savegame


unfortunately the git-version of gemrb does not compile for further testing:

[...]/gemrb/plugins/GUIScript/GUIScript.cpp: In function 'PyObject* PyString_FromResRef(char*)':

[...]/gemrb/gemrb/plugins/GUIScript/GUIScript.cpp:136:47: error: 'PyString_FromStringAndSize' was not declared in this scope


Link to comment

You can avoid renaming of the files if you tell gemrb that your filesystem is case sensitive: CaseSensitive=1


I wonder what files you had to copy from cache. It is a temporary directory, where no files should be in the original install. It is just to keep files there while the engine is running.

So, copying any files from cache is a bad idea.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...