Jump to content

Multiplayer dialogue fix?


Recommended Posts

Hello everyone. First of all sorry if it was a wrong place to ask, i hope i chose it accordingly. I'm looking for a patch or mode which will change Baldur's Gate / Icewind Dale behaviour when played multiplayer. I was trying to play with a friend of mine, and when i choose to talk to someone he also being shown a dialogue menu. He prefer to skip most of the dialogues, i do not. So, my question, if there any fix for this behaviour that will allow 2nd player to enjoy movements/battles while i'm reading through the dialogues? Thank you in advance.

Link to comment

Is the pause-in-dialogue-in-MP standard behaviour? BG2Tweak has the following component:

Force All Dialogue to Pause

This component will change all dialogue to pausing. No longer will bandits attack in the middle of a conversation. This component will affect all dialogues in the game, including ones introduced by mods.


But I take it that that component basically mimics MP behaviour (for SP)?

Link to comment

When you host a multiplayer game, there's an option for "Pausing Dialog", having it unchecked should give the behaviour you want?


Just tried it with ID1. In the multiplayer game permissions there are only options to allow/disallow player to engage into dialogues and to allow/disallow him to pause the game. I would like to make it the way that when 1 player is engaged into conversation with npc's 2nd player won't be shown a dialogue - i mean to make it that dialogues are shown only to player started the conversation, not all players as it implemented in original game. If there a way to do that?

Link to comment

You're not looking at all the options. There is an option when setting up the game to check/uncheck "Pausing Dialog". Don't have the game available right now, but if you don't find on your own it I'll guide you there.


EDIT: Ok now I've looked. When you're in the permissions screen, there's a big button that says "OPTIONS". Go there :)

EDIT2: This is in BG2, I don't know how it works in BG1 (BG1 MP crashes my game). If it is BG1 you want to play - and the option is not there - you can use BGT. If you want want to play IWD1, you can use IWD-in-BG2. Voilá!

Link to comment

Btw, if u have crashes while entering tcp/ip game doing that in windowed mode usually helps to avoid crash. If that not working then windows xp compatibility mode in addition to windowed mode works most of the times. It is possible to switch to fullscreen after the game was started. Just thought this may help to someone who would like to try ID1/BG1 multiplayer.

Link to comment

Btw, if u have crashes while entering tcp/ip game doing that in windowed mode usually helps to avoid crash.

Hah that's hilarious - it actually worked :D And you are correct, the option to not pause in dialogue does not exist in BG1.


I can really recommend playing your multiplayer game in BGT. No fancy megamod installation, just BGT. So basically FixPack, BGT, TweakPack, IR, SR, RR and SCS, and you've got yourself a fantastic game in the BG2 engine.


If you're playing IWD1, I'd recommend you look into IWD-in-BG2. If you want to try it (it's in advanced beta, and I'm playing it SP right now) for a MP campaign, you could start a thread in that forum and ask DavidW - the author - if he's got any recommendations. This is how the option menu look in IWD-in-BG2 MP by the way, with the dialogue option highlighted:


Link to comment

I'm actually not familiar with these modes, have to read of it a little of em. Thank you very much for the hints, i'll definitely give these tweaks a try. Btw, a discouraging thing i've noticed - although there is a "Pausing Dialog" option in BG2 this checkbox not exist in ID2. So, between ID1 ID2 BG1 BG2 the only game having this option is BG2.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...