Jump to content

iPad IOS 5.1 crashing


Recommended Posts

the ios version doesnt exactly work that way. I don't think i have ever built against the iOS 5.1 SDK. I'll have to update my toolchain and give it a try and see what happens.


I'm assuming this is crashing before you even reach the launcher interface?

Link to comment

I'm having the same problem on iOS 5.1.1. GemRB crashes straight back to desktop on

launch without getting to the launcher interface. Looking at the console shows the



Wed Jun 27 18:33:40 com.apple.launchd[1] <Notice>:

(UIKitApplication:net.sourceforge.GemRB[0xa721]) Exited: Killed: 9

Wed Jun 27 18:33:40 SpringBoard[41] <Warning>: Unable to obtain a task name port

right for pid 1403: (os/kern) failure

Wed Jun 27 18:33:40 kernel[0] <Debug>: AMFI: hook..execve() killing pid 1403: no

code signature


SSH'ing into the phone and looking at the app's directory structure shows some

missing elements compared with all the other apps I have, notably entitlements.xml

and a subdirectories called _codesignature or something similar. Looking at the

Cydia guide to the need for code signing (short version at

http://www.saurik.com/id/8/ ) leads me to think that the lack of a code signature is

the problem.


I've tried spoofing a signature using ldid but that keeps dumping me out with an

error message. I don't have access to a Mac so I can't compile the source and

self-sign either. Is anyone able to link to a signed .ipa for the app, or point us

in the right direction to self-sign it?

Link to comment

this has nothing to do with a bug in gemrb. it is getting killed before even entering main().


I don't know exactly what is wrong nor am i going to try and find out; I do not have an iOS device nor does anybody else on the team.

This is open source software complete with xcode project and everything so feel free to look at it yourselves or ask somebody you know that is an iOS developer.


Its not that im not willing to help, but there isn't much i can do from my position since it works fine on the simulator.

Link to comment

Having spent the best part of a week researching this (albeit from a starting point of complete ignorance about programming, Unix and Apple in general so I may be completely wrong) I think it's an issue with iOS 5.1 and/or XCode 4.3.2. The blog post here describes a workaround - http://androidnirvana.comule.com/wordpress/2012/05/building-apps-for-ios-5-1-with-xcode-4-3-2-without-code-signing-and-developer-provisioning-profile/ .


I don't have access to a Mac so can't use XCode, but if anyone here has the time and tools, could they give it a try?

Link to comment

LOL, this is just too much of a hassle. Apple doesn't deserve to survive. Given enough time, i'm pretty sure freedom will win.


one can only hope.


tho i would like to point out that the real difficulty here is that it is hard to develop for a platform that you do not have a device for.

Link to comment

Got it to start up on 5.1.1. Turns out I know someone with a Mac. My steps were as follows:


1. Download AppResign (onto a Mac).

2. Create a new self signing certificate in keychain manager called "iPhone Developer".

3. Download the GemRB.ipa. Rename the .ipa to .zip. Uncompress it.

4. Open up AppResigner. Navigate to [uncompressed folder]/GemRB.app . Sign the GemRB binary.

5. Install GemRB onto the iPad via iTunes.

5. Get confused by the fact that you're using three devices simultaneously. Attempt to touch your computer monitor to move the cursor, then use its keyboard to try typing something on the iPad. Complain loudly about the lack of a right mouse button on the Mac. (This step is optional).

6. Find the GemRB folder on the iPad. It's in var/mobile/Applcations/[RANDOM TEXT]/GemRB.app.

7. Replace the GemRB binary in that folder with the one you signed in step 4 above.


I largely followed the steps on the wiki, but unzipping-AppResigning-rezipping made the .ipa invalid for me (it added a folder called OSX in there which probably isn't too healthy).


I haven't tried installing anything yet, so it may be that this doesn't actually let you play Planescape, but it does at least get past the "killed:9" error on 5.1.1. I've signed the binaries for the "recommended" build and the latest one if anyone is interested.

Link to comment

Like i said before, newer builds are already signed. you are using the build from before the SDL 2.0 change apparently.


we don't have any good working builds because i got a new machine so our mac/ios buildbot is no more until I set up a new one. Until then everybody is going to have to compile from source. i strongly encourage you to do so if your mac friend will have it. many changes and bugfixes have been rolled out since the even the last buildbot version not to mention the old "recommended" version.

Link to comment

Baldur's Gate 1 runs fine.


As for the Buildbot .ipas, both the "recommended" version and the latest one on Sourceforge (2012-04-26) gave the "killed 9" error, as did all the other ones I tried. If Buildbot is signing the compiled code then it's doing it in a way which 5.1.1 doesn't like.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...