Jump to content

[help needed] EET installation error

Recommended Posts

I've just bought BGEE and BG2EE from Steam (i.e. and also dowloaded EET RC4 to try it out.


Followed the instructions (moved both game directories to c: root directory in order to avoid UAC issue, also avoided all hidden files) to use modmerge before running the EET installer, however, after running the installer for a few minutes, it encountered a parsing error and then it rolls back and stopped the installation. Tried to reinstall both games from Steam for three times but every time still running into the same error. Attached the debug file. Pls kindly give me a hand (The debug log was too large - 11MB, so I've rared it)SETUP-EET.DEBUG.rar

Link to comment

Copying 3 files ...

[EET/temp/RACE.IDS] loaded, 1353 bytes

Copied [EET/temp/RACE.IDS] to [override/RACE.IDS]

[EET/temp/CLASS.IDS] loaded, 2225 bytes

Copied [EET/temp/CLASS.IDS] to [override/CLASS.IDS]

[EET/temp/SPECIFIC.IDS] loaded, 599 bytes

Copied [EET/temp/SPECIFIC.IDS] to [override/SPECIFIC.IDS]

Compiling 1859 scripts ...


[EET/compile/baf/K#BIO.baf] PARSE ERROR at line 6 column 1-64

Near Text: )

Type mismatch in "STRREF" argument of [setPlayerSound].

Expecting type "integer".


[EET/compile/baf/K#BIO.baf] ERROR at line 6 column 1-64

Near Text: )


ERROR: parsing [EET/compile/baf/K#BIO.baf]: Parsing.Parse_error

ERROR: error compiling [EET/compile/baf/K#BIO.baf]: Parsing.Parse_error

ERROR: compiling [EET/compile/baf/K#BIO.baf]!

Stopping installation because of error.


ERROR Installing [initialise EET (first mod in install order)], rolling back to previous state

Hmm, seems to me K4thos <descriptive term>/forgot to extend the SetPlayerSound to one of the .ids files according to this.

What OS is you computer under ?


If it's a Windows 10, then "(moved both game directories to c: root directory in order to avoid UAC issue, also avoided all hidden files)" does nothing, as you don't really have the write right in any other folder than the folders under C:\Users\<username>\Games*\ which is not there by default.

So essentially you are not dealing with the User Account Control anymore, it's the Operation System that you'll have the problem with/and you'll be dealing with.


The *the folder can be named as you like, it's typically games, cause you put (old) games into it... but it's your computer, so do what ever you like. The newer games usually work without the above cause they themselves make modifications in the os and need to know the place to do so, which is the C:\Users\<usename>\Searches\Documents\My Games\<game s internal folder structure> in Win7, or in C:\Users\<username>\AppData\Local\<games internal folder structure> ..


The reason being the above probably doesn't work is cause the edits your computer makes are saved to C:\Users\<username>\AppData\Local\BG EET\BG2EE\ -folders, and the games engine is old enough to not give a &%¤#. Cause it's not programmed to.

The AppData folder is hidden by default, so you can't find it using the windows find unless you enable the show the hidden folders -folder option.

Link to comment

Hi K4thos, just tried to download again using your link, but it seems the result is the same - the same error was encountered and it still refers to this K#BIO.baf. Also tried to give write access right to everyone for the user folder (but I don't think there's anything being written in there). Attached again the new debug log



I've just checked whole mod with TextCrawler program and it didn't found K#BIO referenced anywhere within the mod. And you re using the latest version based on your debug file. So the only expalantion that comes to mind is that you had old version of EET in your BG2:EE directory and than extracted new version on top of it leaving the old files there. You should first delete whole EET directory before extracting the archive.


To be more precise EET uses this code:

COMPILE ~EET/compile/baf~

so if you have junk EET/compile/baf/K#BIO.baf file there from very old version of EET than you won't be able to install it because the installer tries to compile all scripts in that directory.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...