Jump to content

Harper - Zhent fight?


Recommended Posts

I have been playing around with Tutu and BG1 NPC mod, and have K&J and X&M in my party - have had for a looooong time already. Still, they haven't fought, something I thought was inevitable...


Is this removed either by the Tutu itself or the NPC mod? I seem to remember that some of the original BG1 NPC banters were cut, no? (Haven't seen K&J's 'Please, Jaheira, must you be so... insufferable?' smalltalk from the original BG1 :))


Does the BG1 NPC mod has some banter or something that will eventually lead the Harpers and Zhents to fighting?

Link to comment

No, what is happening is the following: The original BioWARE dialogues are a combination of random opportunities. SOmetimes the very similar dialogue between Zhents and Harpers ends in a fight, sometimes it does not (it was this way in the original BG). Also, the way BG1 was coded is that when transfered to TUTU the BG1 dialogues kept repeating. If we let them repeat, especially with the banter accelerator it became quite tedious. What I have done is I went through all 8-10 possible random lines that start those dialogues and I made them non-repetitive, by adding variables (which BioWARE did not have). So now you will have a few separate dialogues that will spur randomly either ending in a fight or not. We also boldly WEIGHT'ed our dialogues above BioWARE's (when we did not want to deal with eliminating the repeats). So no, we did not cut BioWARE content, only ajusted it a bit to make sure that the player has a chance to see our dialogues as well as BioWARE's. Try Ctrl+I for a while if you have cheats installed and they will eventually have those dialogues you were looking for.

Link to comment

O, goodie. It's also worthwhile to update to V9 or 10_a1, if you do not have it yet, to help with the roguish scripted talks jumping in instead of their non-scripted neighbors and perhaps slowing down the appearance of Bio's ones.

Link to comment

I got the quest from SEniyad in Cloakwood-1, everything worked fine there. But, I can't find the encounter with Beador and the Shadow Druids in Cloakwood-3. They just don't show up, I've searched the whole map in vain. :)

Link to comment

The previous one is too busy while this one is too underused. I vaguely remeber asking you/posting that I am shifting the encounter one map over when I was first coding it, but it was sometime.... If I did not, I appologize, it had been a mad time with quest coding (lol, I really hope I won't have to code any more quests). I'd rather not be re-positioning the actors and rewriting Globals now if the island looks ok: Nice open area there by the fir-tree for a fight, gives PC something to do instead of having it all in the same place....

Link to comment

Okay, the encounter with Beador can stay on that map, it actually works out very well. I played through the quest and everything was working perfectly. :D


A few suggestions:


- Beador was too hard to save from getting killed. I think you should double his existing HP to give him a better chance of surviving. :)

- Maretha, the girl to be rescued, has a very odd voice when she approaches the PC upon entering the Tree House. She says 'Aye mate?' in distinctively male voice, whereas I would expect her to say some line voiced by female voice actor. :D

- The description of Jaheira's reward item, that club, is a bit incorrect. It currently reads:


Damage: 1d6


It should be:


Thac0: +2

Damage: 1d6 +2,


thus I wasn't entirely sure if the club actually worked as a +2 weapon. It would be nice if you could check this too.




Oh, and about the Harper - Zhent fight: I was finally able to get the dialogue that leads to them fighting. They became unselectable (purple circles around feet) and... just stood there, looking at each other. They were not fighting. And, I could not get them to rejoin the party by forcetalking them.


I wonder what's gone wrong here, is this Tutu issue or is this Bg1 NPC issue?

Link to comment

Glad it works; have you tried both paths? Last time it was tested there still were glitches, so I would like to have the clean 'pass' on it.


The club is +2, I just need to revise the description, no problems.


The purple thing is a TUTU issue, Ghrey said he fixed it for V13 TUTUfix. If you are running the latest TUTUfix, you will need to report the reoccurence at TUTU forums.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...