Jump to content

Please help me with SoA bug in Underdark - Android GemRB


Recommended Posts

Hi, I'm in the Underdark in Ust Natha and I'm just about to take a quest from Faere and Solaufein to kill the Svirfneblin Captain and bring them his helmet . I was supposed to meet with Faere and Sola' in Ust Natha's Tavern, so I entered the tavern, approached Faere and Sola without talking to them yet and then I saved and exited the game.


I started the game again, loaded the save and I'm standing in the Tavern but now there's no Faere or Sola' here. I tried loading the game many times, quitting and entering the tavern and they are still gone.


What can I do? Are there any cheat codes for the Android GemRB that would allow me to summon Faere and Solaufein?

Link to comment

here's the link. i forgot to tell i'm using widescreen mod 3.05 at 800x480 resolution. http://www.directmir.../files/XKA1O8AP


I don't have any saves before I entered the tavern cause I overwritten them. However I do have a save after the tavern when I've already accepted the quest to kill the Svirfneblin Captain with Solaufein. This save (quicksave file) I saved in the main Underdark cavern while I was standing right next to Solaufein and was about to talk to him to go kill the captain. When I load this save Solaufein is gone but I was standing right next to him.


So in both these saves I can't complete the quest because either I can't take it (no Faere and Sola in the Ust Natha's tavern) or in the second save (the quicksave) after taking the quest there's no Solaufein in the Underdark (but he was there, but no more after loading the quicksave).


Probably this bug isn't present in the original game. I finished BG2 many times on my PC (around 10) and have never gotten into such troubles.

Link to comment

Damn :D It works. I summond Solaufein and I can continue the quest :D His ID is: UDSOLA01.cre . I found it using shadow keeper bg save editor on my pc.


CreateCreature(1,"UDSOLA01") worked.


Thanks. I'll report later if I could finish the quest. EDIT: Quest completed, I can move on further now. thanks again.


PS. Could you please point me to a list of cheat codes working for gemrb in case eg. I would need to create some quest item etc?

Link to comment

Thanks. I actually used this list before but I entered this command as follows: GemRB.CreateCreature(1, UDSOLA01.cre).

Didn't know I have to use quotation marks and remove the "GemRB." and ".cre" part of it, that's why I thought these codes do not work...


We could really use a guide how to use the most needed cheat codes in a correct way.

Link to comment

having GemRB. infront shouldn't matter, but quoting definitely does. It most likely did in the original too, since it used a stripped down lua for its console. Unquoted makes the interpreter think it's a variable and since it was not defined ...

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...